Last Comment Bug 668157 - dom should use mozilla::Preferences
: dom should use mozilla::Preferences
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: DOM (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla14
Assigned To: Masayuki Nakano [:masayuki] (Mozilla Japan)
:
Mentors:
Depends on: 656826 743785
Blocks:
  Show dependency treegraph
 
Reported: 2011-06-29 01:47 PDT by Masayuki Nakano [:masayuki] (Mozilla Japan)
Modified: 2012-04-09 13:14 PDT (History)
5 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Part.1 Add new APIs to mozilla::Preferences (3.90 KB, patch)
2011-06-29 01:47 PDT, Masayuki Nakano [:masayuki] (Mozilla Japan)
roc: review+
Details | Diff | Review
Part.2 dom should use mozilla::Preferences (40.47 KB, patch)
2011-06-29 01:49 PDT, Masayuki Nakano [:masayuki] (Mozilla Japan)
jst: review+
Details | Diff | Review
part.1 Add Preferences::GetType() and Preferences::GetDefaultType() (3.51 KB, patch)
2012-04-03 04:02 PDT, Masayuki Nakano [:masayuki] (Mozilla Japan)
no flags Details | Diff | Review
part.2 mozilla/dom should use mozilla::Preferences (35.71 KB, patch)
2012-04-03 04:29 PDT, Masayuki Nakano [:masayuki] (Mozilla Japan)
jst: review+
Details | Diff | Review

Description Masayuki Nakano [:masayuki] (Mozilla Japan) 2011-06-29 01:47:54 PDT
Created attachment 542742 [details] [diff] [review]
Part.1 Add new APIs to mozilla::Preferences

dom needs nsIPrefServiceInsernal interface and GetType().
Comment 1 Masayuki Nakano [:masayuki] (Mozilla Japan) 2011-06-29 01:49:52 PDT
Created attachment 542743 [details] [diff] [review]
Part.2 dom should use mozilla::Preferences
Comment 2 Masayuki Nakano [:masayuki] (Mozilla Japan) 2011-06-29 01:57:08 PDT
Note that I don't change nsPluginsDirUnix.cpp.
http://mxr.mozilla.org/mozilla-central/source/dom/plugins/base/nsPluginsDirUnix.cpp#150

If I changed it, it would need more changes in the method because it's using the result buffer in low-level.
Comment 3 Robert O'Callahan (:roc) (Exited; email my personal email if necessary) 2011-06-29 02:23:29 PDT
Comment on attachment 542742 [details] [diff] [review]
Part.1 Add new APIs to mozilla::Preferences

Review of attachment 542742 [details] [diff] [review]:
-----------------------------------------------------------------
Comment 4 Johnny Stenback (:jst, jst@mozilla.com) 2012-03-30 21:22:03 PDT
Comment on attachment 542743 [details] [diff] [review]
Part.2 dom should use mozilla::Preferences

Sigh, this *completely* fell through the cracks and got lost in my review queue, sorry! :(

r=jst, but this doesn't so much apply any more. I'll gladly review updated versions if needed (in no time this time, promise!)
Comment 5 Masayuki Nakano [:masayuki] (Mozilla Japan) 2012-04-03 04:02:07 PDT
Created attachment 611773 [details] [diff] [review]
part.1 Add Preferences::GetType() and Preferences::GetDefaultType()
Comment 6 Masayuki Nakano [:masayuki] (Mozilla Japan) 2012-04-03 04:29:27 PDT
Created attachment 611776 [details] [diff] [review]
part.2 mozilla/dom should use mozilla::Preferences

some pref names have been changed, I checked them again very carefully, but I'd like you to check them too.
Comment 7 Johnny Stenback (:jst, jst@mozilla.com) 2012-04-03 08:18:22 PDT
Comment on attachment 611776 [details] [diff] [review]
part.2 mozilla/dom should use mozilla::Preferences

Looks good, I checked all the pref names as well and didn't see anything wrong there.

r=jst!

Note You need to log in before you can comment on or make changes to this bug.