Moving text selection selector onto an input field results in softkb popping up

RESOLVED WONTFIX

Status

defect
P2
normal
RESOLVED WONTFIX
8 years ago
3 months ago

People

(Reporter: aakashd, Unassigned)

Tracking

Firefox 7
Firefox 7
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Build Id:
Mozilla/5.0 (Android; Linux armv7l; rv:7.0a1) Gecko/20110629 Firefox/7.0a1 Fennec/7.0a1 ID:20110629041011

Steps to Reproduce:
1. Go to www.pastebin.com/
2. Scroll down to the bottom of the textarea
3. Long-tap on any of the words in the phrase: "Optional Paste Settings"
4. When the text selection selectors pop-up, move either of them onto the textarea.

Actual Results:
The textarea is selected and the softkb pops up. If there's text already in the textarea, then its selected.

Expected Results:
The text outside of the textarea is selected in relation to the position of the text selection selector. The textarea should not be selected and the softkb should NOT pop up.
Blocks: 661388
(In reply to comment #1)
> I think this may be related to bug 667097

Nope, it's bug 669816
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 669816
There is a hack in the code that is supposed to circumcent this, at:
http://mxr.mozilla.org/mozilla-central/source/mobile/chrome/content/content.js#1415
This was added in a patch for bug 667062.

However, I'm still seeing this in current trunk build on the LG Optimus Black.

Is this bug supposed to be fixed or is it still supposed to be an issue?

Anyway, I'm reopening this bug for now, otherwise it's too confusing (for me at least).
Status: RESOLVED → REOPENED
Depends on: 654352
Resolution: DUPLICATE → ---
No longer blocks: 667243
Depends on: 667243
Closing all opened bug in a graveyard component
Status: REOPENED → RESOLVED
Closed: 8 years ago3 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.