The default bug view has changed. See this FAQ.

Sometimes grossly inflated, sometimes no spacing in PDF output

RESOLVED FIXED in mozilla12

Status

()

Core
Printing: Output
RESOLVED FIXED
6 years ago
5 years ago

People

(Reporter: Stefan, Assigned: Stefan)

Tracking

Trunk
mozilla12
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Assignee)

Description

6 years ago
Created attachment 542868 [details]
Testcase to be printed as PDF

User Agent:  

Steps to reproduce:

1. Opened the testcase.
2. File-Print-Print to File-Output Format PDF-Print
3. Opened mozilla.pdf.
4. Repeated 1--3 several times.

[The Question "What DID you do?" cannot be answered using present tense. Is that intentional?]


Actual results:

Sometimes there was "grossly inflated spacing (wording stolen from Bug 667242, albeit  gfx.font_rendering.harfbuzz.scripts=3) and sometimes there was no spacing at all.


Expected results:

Letters in PDF should always have been spaced correctly.
(Assignee)

Comment 1

6 years ago
Created attachment 542869 [details]
Testcase PDF output showing grossly inflated spacing
(Assignee)

Updated

6 years ago
Attachment #542868 - Attachment mime type: text/plain → text/html
(Assignee)

Updated

6 years ago
OS: Other → Linux
Hardware: All → x86_64
(Assignee)

Comment 2

6 years ago
Version used to create PDF:
Mozilla/5.0 (X11; Linux x86_64; rv:7.0a1) Gecko/20110629 Firefox/7.0a1

Updated

6 years ago
Component: General → Printing: Output
Product: Firefox → Core
QA Contact: general → printing

Comment 3

6 years ago
 Mozilla/5.0 (X11; Linux i686; rv:8.0a1) Gecko/20110720 Firefox/8.0a1

Confirming issue - setting status to New.

Since when have you started seeing this problem?
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Comment 4

6 years ago
> Since when have you started seeing this problem?

On 2011-06-29 but I infrequently use the browser to print to PDF.
(Assignee)

Comment 5

6 years ago
Is this related to Bug 667242 - grossly inflated spacing in printed page when harfbuzz is disabled?
(Assignee)

Comment 6

6 years ago
(In reply to George Carstoiu from comment #3)
> Since when have you started seeing this problem?

2011-05-26-03-mozilla-central seems to be the first version which shows this problem.
(Assignee)

Comment 7

6 years ago
The problem occurs only with Type 1 fonts. The commit

http://hg.mozilla.org/mozilla-central/rev/db4b1f3096ea

seems to be the first which reproduces the problem.
(Assignee)

Comment 8

5 years ago
(In reply to Stefan from comment #7)
> http://hg.mozilla.org/mozilla-central/rev/db4b1f3096ea

I cannot trace back how I came to db4b1f3096ea so I did another bisection:

last good 2011-05-25-03-mozilla-central 836aa9658341
first bad 2011-05-26-03-mozilla-central 831f8e040f38

The first bad revision is:
changeset:   70170:acb4e51fa8a6
user:        Jeff Muizelaar <jmuizelaar@mozilla.com>
date:        Thu Mar 10 14:52:15 2011 -0500
summary:     Bug 562746. Update cairo to 1.10.
(Assignee)

Comment 9

5 years ago
With the two patches mentioned here

  https://bugs.freedesktop.org/show_bug.cgi?id=31062#c2

printing works fine again.

http://mail.gnome.org/archives/gnome-announce-list/2011-January/msg00005.html
--> https://bugs.freedesktop.org/show_bug.cgi?id=31062#2
    --> http://cgit.freedesktop.org/cairo/commit/?h=1.10&id=f47830dbbc34c7068ccdd8f7f9042e8734c9e408
    --> http://cgit.freedesktop.org/cairo/commit/?h=1.10&id=43c93f2b101f534f8aa4213403af3281fcdc17fb
(Assignee)

Comment 10

5 years ago
Created attachment 586294 [details] [diff] [review]
patch
Comment on attachment 586294 [details] [diff] [review]
patch

Jeff, it sounds like we should cherry-pick this from cairo.
Attachment #586294 - Flags: review?(jmuizelaar)
Is there anyway we can get an automated test for this?
Comment on attachment 586294 [details] [diff] [review]
patch

Adrian, what do you think of this?
Attachment #586294 - Flags: review?(ajohnson)

Updated

5 years ago
Attachment #586294 - Flags: review?(ajohnson) → review+
/me realizes Adrian wrote those patches. Sorry for the noise.
Attachment #586294 - Flags: review?(jmuizelaar) → review+
Pushed to -inbound:
https://hg.mozilla.org/integration/mozilla-inbound/rev/f43cfe78a5b4
Assignee: nobody → kdevel
Status: NEW → ASSIGNED
Target Milestone: --- → mozilla12
https://hg.mozilla.org/mozilla-central/rev/f43cfe78a5b4
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.