Last Comment Bug 668655 - "Compact Folders" dialog is randomly popped-up when deleting messages
: "Compact Folders" dialog is randomly popped-up when deleting messages
Status: VERIFIED DUPLICATE of bug 286888
: ux-userfeedback
Product: Thunderbird
Classification: Client Software
Component: General (show other bugs)
: 5.0
: All Other
: -- normal with 2 votes (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-06-30 15:36 PDT by Richard Mlynarik
Modified: 2011-07-10 12:59 PDT (History)
9 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
stupid-compaction-dialog.jpg (28.87 KB, image/jpeg)
2011-06-30 15:36 PDT, Richard Mlynarik
no flags Details

Description Richard Mlynarik 2011-06-30 15:36:45 PDT
Created attachment 543282 [details]
stupid-compaction-dialog.jpg

User Agent: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10_6_8; en-us) AppleWebKit/533.21.1 (KHTML, like Gecko) Version/5.0.5 Safari/533.21.1

Steps to reproduce:

"Upgraded" to TB 5.0.  (I know, I know.)

Deleted some messages from my mail (using the Delete key)

Surprise!  Time for an exciting new modal dialog!  (See attached image.)


Actual results:

Every so often (not precisely reproducible) an unwanted, irritating new dialog pops up:

   Compact Folders.

   Do you wish to compact all local and offline folders to save disk space?

   [x] Always ask before compacting folders automatically.

   [Cancel] [Compact Now.]


Expected results:

I don't need this nonsense.  I didn't ask for it.  Don't randomly pop up COMPLETELY IRRELEVANT internal junk when I'm just trying to delete a message, something I do hundreds of times a day.

If I really want to compact folders, and save 2 cents worth of disk space or something, I'll find some command that does it.  (I distinctly remember there being a command to do that explicitly -- oh yeah, there is is, still there, amazingly: right-click on a folder in the standard mail reading pane folder list and "Compact" is one of the options I can explicitly CHOOSE if I CHOOSE TO DO SO.)

Even if I did want it done, I don't want to have random dialogs pop up when I'm doing something REALLY REALLY SIMPLE AND BASIC like DELETING MESSAGES.

And lastly, the dialog offers no option for "Go away and never never never ask me this stupid question ever again" -- my assumption being that if I uncheck the "Ask me before ..." option then it will do something I didn't ask for without asking me.

Please, just make it stop.

And stop "upgrading" things.  Just fix BUGS, for God's sake!
Comment 1 Dan Mosedale (:dmose) 2011-07-06 17:48:25 PDT
You've been warned repeatedly about the Bugzilla Etiquette rules, and you're still failing to respect them.  I'm sorry to have to do this, but I'm going to disable your account.
Comment 2 Peter Hollo 2011-07-08 01:17:52 PDT
I can confirm this awesomely-reported bug. It "bugged" me too.
Comment 3 J. Kanowitz 2011-07-08 06:57:18 PDT
Clearly the OP did not recognize a patch for annoyance-compatibility with Outlook's "AutoArchive" dialog.
Comment 4 Patrick Walton (:pcwalton) 2011-07-08 08:44:47 PDT

*** This bug has been marked as a duplicate of bug 286888 ***
Comment 5 Wayne Mery (:wsmwk, NI for questions) 2011-07-08 18:32:53 PDT
This bug report is in fact (IMO) invalid. Yes, Thunderbird behavior changed in release 5 by bug 437657 (related to bug 286888), making the default to autocompact. But the dialog itself is not new. And there are two easy/trivial ways to avoid the "annoying pop up": 
1. uncheck the box in the dialog 
2. change the compact option back to pre-v5 behavior to not automatically compact.

None of the above makes this a duplicate bug 286888, unless the choices provided to the user are undesirable. But afaik it was anticipated (see bug 437657).  Not ideal perhaps, but I don't think a better plan has been proposed.
Comment 6 Wayne Mery (:wsmwk, NI for questions) 2011-07-08 22:26:42 PDT
I'd like to clarify comment 5 and the undupe, because part of comment 0 ("Even if I did want it done ...") is a dupe, but it seems like only a small part...

Only the reporter can say, but the major thrusts of comment 0 seem to be a) don't compact for me, and b) don't ever prompt. But a) compact is the new intended default and to change the default back would most likely be wontfix, and b) until bug 286888 is fixed, the prompt is there to hint to the changed behavior. 

But ultimately, comment 0 makes many points and it's unclear which one item the reporter wants. So invalid
Comment 7 Brendan Eich [:brendan] 2011-07-09 17:11:26 PDT
Once again I'm on side with the reporter's substance, not style.

Comment 6 does not make this bug invalid. (a), making compact the default, is not the issue. (b), that the summary of this bug, the chief complaint (never mind the many points in comment 0), is a dup of bug 286888. If that bug were fixed, would Richard have reported this bug? I don't think so, and he can't say since he has been banned.

It's important not to overreact or seem to dismiss bugs, however badly filed, especially if their summary is on target. So I think this is a dup.

/be
Comment 8 Blake Winton (:bwinton) (:☕️) 2011-07-09 17:29:31 PDT
I don't particularly care what this bug is marked, as long as it's resolved, but in the interests of letting Richard have his say (if only by the proxy of number of bugs duped to 286888), I'm changing it to resolved/duplicate.

Wayne, I can see your reasoning for marking it invalid, but I'm hoping you don't really care enough to change it back.  ;)

Richard, if you're still getting email notifications, and want to email me with a response to Brendan's question, I'ld love to hear it.  My address is <bwinton@mozilla.com>.

Thanks all,
Blake.

*** This bug has been marked as a duplicate of bug 286888 ***
Comment 9 Wayne Mery (:wsmwk, NI for questions) 2011-07-09 20:59:09 PDT
Not that it matters, but I'm fine either way
Comment 10 Phillip A Remaker 2011-07-10 12:54:47 PDT
The bug is quite valid.  The user experience of ordinary users is substantially diminished by random modal dialogs about system internals that a user has no knowledge or concern about.

Compaction should either happen in the background or in some non-intrusive way that does not ask a user to decide.  If it is needed, it should be done.  It if it not needed, it should not be done.  If the system cannot decide, the system is designed incorrectly.

This is a perfectly valid bug about user experience problems.
Comment 11 Blake Winton (:bwinton) (:☕️) 2011-07-10 12:59:11 PDT
(In reply to comment #10)
> The bug is quite valid.  The user experience of ordinary users is
> substantially diminished by random modal dialogs about system internals that
> a user has no knowledge or concern about.
> 
> This is a perfectly valid bug about user experience problems.

You're right that there is a valid bug here, but I think it will best be solved by the fix for bug 286888.  If you can help us fix that bug, I would be greatly appreciative.  (If not, that's quite alright too.)

Thank you,
Blake.

Note You need to log in before you can comment on or make changes to this bug.