Thunderbird 5.0 crashes on launch, on OS X 10.6.8 consistently [@ libsystem_c.dylib@0x27d14 ]

RESOLVED WORKSFORME

Status

Thunderbird
General
--
critical
RESOLVED WORKSFORME
7 years ago
6 years ago

People

(Reporter: Forrest Aldrich, Unassigned)

Tracking

({crash, regression})

All
Mac OS X
crash, regression

Firefox Tracking Flags

(Not tracked)

Details

(crash signature, URL)

Attachments

(2 attachments)

(Reporter)

Description

7 years ago
Created attachment 543472 [details]
crashreport.txt

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:5.0) Gecko/20100101 Firefox/5.0
Build ID: 20110615151330

Steps to reproduce:

I launched TB 5.0 on my OS X system, and it immediately crashed.  This has happened since the pre-release stages.   I am running OS X 10.6.8, current patches.


Actual results:

A crash report was generated that could not be submitted. Therefore, I will attach it here.



Expected results:

TB should have launched normally.

Comment 1

7 years ago
Forrest, 
Did this crash for you in version 3.1?  
Did you update to 10.6.8 before moving to Thunderbird 5?
Does it crash if you start in safe mode?
 http://support.mozillamessaging.com/en-US/kb/safe-mode
Severity: normal → critical
Keywords: crash, regression
OS: Other → Mac OS X

Comment 2

7 years ago
regression mark is speculative. As is this question ...
Is this the same v5 Mac 10.6.8 crash I mailed to ludo about from http://getsatisfaction.com/mozilla_messaging/topics/how_to_fix_a_startup_crash ?
(Reporter)

Comment 3

7 years ago
I re-confirmed the problem, post install of 10.6.8 and using safe-mode.   I just received two other posts from the Mozilla forums confirming this problem (unknown yet as to whether they used safe mode).

This time around, I noticed the TB window opens, with 2 tabs, it waits a couple of seconds then crashes.  The crash reporter is not able to submit the report.  I will attempt to attach the crash report from safe mode.
(Reporter)

Comment 4

7 years ago
Wayne, I have no connection to the link you have mentioned.
(Reporter)

Comment 5

7 years ago
Created attachment 544520 [details]
Log of crash from safe mode.

Comment 6

7 years ago
http://support.mozillamessaging.com/en-US/kb/safe-mode works for me

Updated

7 years ago
(Reporter)

Comment 7

6 years ago
This does not work for me (it's the same process).  I tried this both with addons disabled and enabled.  It behaves as described.

Comment 8

6 years ago
This is happening to me, OSX 10.6.8, Thunderbird 5.0. Consistently crashes, and in safe mode too. Had to reinstall 4.x

Comment 9

6 years ago
Sorry, meant 3.x, not 4.x
Ha can you guys try two more things :

1) Validate your fonts using Font Book; remove or disable all fonts with errors or warnings, as well as any duplicate fonts.
2) Restart your Mac in Safe Mode to clear the OS font caches (which contain data for the corrupt or invalid and duplicate fonts you removed/disabled in step 1).
(Reporter)

Comment 11

6 years ago
This had no effect on the problem.  Now I need to go back and reload those fonts (which I need for Photoshop work).  They were not fonts that would be used by TB anyway..

Comment 12

6 years ago
The font suggestion didn't work for me either.
Not surprisingly, I can't reproduce this.  Can anyone else here do so,
besides Forrest and Graham?

Looking at the crash stack, I'd guess TB is crashing trying to draw
some kind of graphic in the title bar, or maybe as a background to the
entire window.

Does TB support themes?  And are either of you (Forrest and Graham)
using a non-default theme?  Does the crash go away if you restore the
default theme?

Comment 14

6 years ago
I have only ever used the default theme.
(Reporter)

Comment 15

6 years ago
I'm only using the default theme; never used anything else.

Comment 16

6 years ago
(In reply to comment #13)
> Looking at the crash stack, I'd guess TB is crashing trying to draw
> some kind of graphic in the title bar, or maybe as a background to the
> entire window.

FWIW, new Mac crashes filed in last 2 months - https://bugzilla.mozilla.org/buglist.cgi?type1-0-0=substring&keywords=crash&keywords_type=allwords&list_id=813361&field0-0-0=short_desc&type0-0-1=substring&field0-0-1=longdesc&type1-0-1=allwordssubstr&classification=Client%20Software&classification=Components&op_sys=Mac%20System%207&op_sys=Mac%20System%207.5&op_sys=Mac%20System%207.6.1&op_sys=Mac%20System%208.0&op_sys=Mac%20System%208.5&op_sys=Mac%20System%208.6&op_sys=Mac%20System%209.x&op_sys=Mac%20OS%20X&chfieldto=Now&query_format=advanced&chfield=[Bug%20creation]&chfieldfrom=2m&type0-0-0=substring&field1-0-0=short_desc&product=Core&product=Firefox&product=MailNews%20Core&product=SeaMonkey&product=Thunderbird&product=Toolkit&field1-0-1=short_desc
(Reporter)

Comment 17

6 years ago
I can confirm that the same problem happens on OS X 10.7 Lion.   Using a fresh, new install.
Graham and forest does it happen on a new profile too ?
(Reporter)

Comment 19

6 years ago
I ran TB with the profile manager, created a fake user (no accounts), exited, then brought TB up again with profile manager and selected my own profile.  This time it worked.   I quit TB, started it again without the profile manager and it worked again.

That's not to say it won't crash again, but I think we narrowed down where the problem may exist?

I'll be interested if Graham can see the same results.

Thank you for the input.

Comment 20

6 years ago
I can confirm that TB 5.0 crashes for me on Mac 10.7
Running in safe mode with my normal profile also crashes

Creating a new profile however allowed me to launch TB without a crash. Going back to previous profile crashes again.

Note: TB only crashes *after* I type in and submit my master password.

AdapterRendererIDs: 0x21b00,0x20400
Add-ons: en-GB@dictionaries.addons.mozilla.org:1.19.1,randomsig@oppermann.ch:1.5,{847b3a00-7ab1-11d4-8f02-006008948af5}:1.2,{a62ef8ec-5fdc-40c2-873c-223b8a6925cc}:0.8,{ad7d8a66-253b-11dc-977c-000c29a3126e}:0.8.33,{e2fda1a4-762b-4020-b5ad-a41df1933103}:1.0b4,{CC3C233D-6668-41bc-AAEB-F3A1D1D594F5}:0.7.6.4,{972ce4c6-7e08-4474-a285-3208198ce6fd}:5.0
BuildID: 20110624154109
CrashTime: 1311340903
EMCheckCompatibility: true
Email: <snip>
FramePoisonBase: 7ffffffff0dea000
FramePoisonSize: 4096
InstallTime: 1310114514
Notes: Renderers: 0x21b00,0x20400GL Context? GL Context+
GL Layers? GL Layers+

ProductName: Thunderbird
ReleaseChannel: release
SecondsSinceLastCrash: 357
StartupTime: 1311340896
Theme: classic/1.0
Throttleable: 1
Vendor: 
Version: 5.0

This report also contains technical information about the state of the application when it crashed.

Comment 21

6 years ago
Graham, does your stack match Forest's? (see the bug attachments)
If not, please attach your stacktrace file to the bug.

Azrael, please post your crash report ID
 http://support.mozillamessaging.com/en-US/kb/Mozilla+Crash+Reporter#Viewing_crash_reports

Comment 22

6 years ago
Hopefully not over-kill:
https://crash-stats.mozilla.com/report/index/bp-4c050f7d-0699-4c69-8bf3-5bf482110722
https://crash-stats.mozilla.com/report/index/bp-407de10b-3d96-483e-88c1-eea9f2110722
https://crash-stats.mozilla.com/report/index/bp-af4a0253-9858-4d04-918e-66a212110722
https://crash-stats.mozilla.com/report/index/bp-0e80be77-ea43-4639-8a0d-500a32110722
https://crash-stats.mozilla.com/report/index/bp-50698d83-1dde-4816-91bb-f5a6a2110722
https://crash-stats.mozilla.com/report/index/bp-975a32c7-507f-4cfd-ac26-384d72110722
Summary: Thunderbird 5.0 crashes on launch, on OS X 10.6.8 consistently. → Thunderbird 5.0 crashes on launch, on OS X 10.6.8 consistently [@ libsystem_c.dylib@0x27d14 ]

Comment 23

6 years ago
Azrael's stack doesn't match Forest's, but does match to bug 662091
I've been asked what I thought was the "crash signature" when I wrote comment #13.

I was (of course) looking at the two crash stacks that Forrest attached.  In both cases I suspect the most diagnostic part is "CUISharedArtReader::Setup()".

CUISharedArtReader has come up before in Thunderbird crash logs, including in one other bug I worked on (bug 463970).  None of them has ever been resolved, as far as I can tell.

https://bugzilla.mozilla.org/buglist.cgi?list_id=835087&resolution=---&resolution=FIXED&resolution=INVALID&resolution=WONTFIX&resolution=DUPLICATE&resolution=WORKSFORME&resolution=INCOMPLETE&resolution=SUPPORT&resolution=EXPIRED&resolution=MOVED&query_format=advanced&longdesc=CUISharedArtReader&longdesc_type=substring

But it doesn't make sense to include CUISharedArtReader in the "Crash Signature" field, because Breakpad can't resolve symbols in system libraries -- so CUISharedArtReader would never show up in a Breakpad crash stack.
Another thing to beware of:

The XUL symbols in Forrest's stacks are almost certainly all spurious.  All the downloadable FF builds (including nightlies) have their symbols stripped.  So gdb has to guess which symbol is/was at a given address, and usually guesses wrong.

Breakpad has other, more accurate ways to get symbol information.  But (as I already said) it can't find any symbols in system libraries.

Comment 26

6 years ago
we seem to be getting a bunch of TB5 Mac crashes being reported in getsatisfaction. but don't have a good sense of the distribution of signatures and causes. Perhaps others do.

here's the situation on crash-stats...

https://crash-stats.mozilla.com/topcrasher/byversion/Thunderbird/5.0
sort on the Mac column header twice
mouse over the version field to display what versions are crashing for each sig
the first 6 signatures are being reported as occurring only for version 5 (and it's alphas) an newer.

see also https://crash-stats.mozilla.com/query/query?product=Thunderbird&version=Thunderbird%3A5.0&platform=mac&range_value=2&range_unit=weeks&date=07%2F26%2F2011+07%3A33%3A10&query_search=signature&query_type=contains&query=&reason=&build_id=&process_type=any&hang_type=any&do_query=1

Comment 27

6 years ago
I was having a similar sounding problem. Running 10.6.8 and TB5.0 crashes at launch every time, even in safe mode. When I use a new profile with no accounts, TB5.0 would run.

I finally got TB5.0 to launch by running TB6.0 (beta) just once. It didn't crash. Then, I launched TB5.0 and it's been OK since.

One thing though, when TB5.0 was launching for the first time after running TB6.0, I managed to click on the close button of the second tab (the one that says "Welcome to TB5"). So, if the problem is something with the welcome tab, the fix might have nothing to do with running TB6.

Updated

6 years ago
Crash Signature: [@ libsystem_c.dylib@0x27d14 ]

Comment 28

6 years ago
Forrest, Richard, have you tried version 7?
Or 8 in beta from http://www.mozilla.org/en-US/thunderbird/channel/ ?

Comment 29

6 years ago
(In reply to Wayne Mery (:wsmwk) from comment #28)
> Forrest, Richard, have you tried version 7?
> Or 8 in beta from http://www.mozilla.org/en-US/thunderbird/channel/ ?

Unfortunately, I can no longer duplicate this crash. I'm still using TB5.0 and running TB6.0 that *one* time fixed the problem for me. Seems to me to indicate that something in the settings file was giving TB5 a problem and that running TB6 fixed it.
(Reporter)

Comment 30

6 years ago
This is what I believe happened (in the simplest sense):  Thunderbird encountered a parameter or a format issue and choked on it from the preferences.  This is probably just an artifact of how it's been evolving.   I'm not having any issues like that with the latest version.

Comment 31

6 years ago
WFM per comment 30
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.