Virtual folder as subfolder of local folders with colon ':' in name appears twice after restart.

RESOLVED WORKSFORME

Status

--
major
RESOLVED WORKSFORME
7 years ago
5 years ago

People

(Reporter: lisa.pfisterer, Unassigned)

Tracking

(Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [WORKSFORME in Thunderbird 24.0.1])

(Reporter)

Description

7 years ago
User Agent: Mozilla/5.0 (Windows NT 5.1; rv:5.0) Gecko/20100101 Firefox/5.0
Build ID: 20110615151330

Steps to reproduce:

Create a virtual folder as subfolder of local folders.
Name it X:Y and click ok.
The folder is created and visible.
Restart Thunderbird.


Actual results:

After the restart of Thunderbird the folder appears twice with the same name.


Expected results:

No second folder should be there.
Blocks: 124287
Confirmed with next build.
> Name : Thunderbird, Version : 5.0
> User Agent : Mozilla/5.0 (Windows NT 5.1; rv:5.0) Gecko/20110624 Thunderbird/5.0 
> Application Build ID : 20110624125636

(1) Create virtual folder of X:Y under folder b.
  virtualFlders.dat
   uri=mailbox://nobody@Local%20Folders/b/X%3AY
   terms=AND (subject,contains,XXX)
  created file : ...\b.sbd\X4c35ceda.msf (:Y part is hashed)
(2) Restart Tb => Two X:Y at folder pane
  virtualFlders.dat
   uri=mailbox://nobody@Local%20Folders/b/X4c35ceda
   terms=AND (subject,contains,XXX)
   uri=mailbox://nobody@Local%20Folders/b/X%3AY
   terms=AND (subject,contains,XXX)
(3) Change condition in properties of any one of two X:Ys.
  virtualFlders.dat
   uri=mailbox://nobody@Local%20Folders/b/X4c35ceda
   terms=AND (subject,contains,YYY)
   uri=mailbox://nobody@Local%20Folders/b/X%3AY
   terms=AND (subject,contains,YYY)
  Condition of two entries is updated at same time. 

If rename of existent virtual folder(e.g. ABC) to X:Y, inconsistent entry of uri=mailbox://nobody@Local%20Folders/b/X%3AY is not created, and entry of uri=mailbox://nobody@Local%20Folders/b/X4c35ceda which is consistent with file name is used since initial.

Workaround.
  Create virtual folder ABC, then reame ABC to X:Y.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Severity: normal → major
Component: Folder and Message Lists → Backend
Product: Thunderbird → MailNews Core
QA Contact: folders-message-lists → backend
Summary: Virtual folder as subfolder of local folders with colon ':' in name appears twice after restart. → Virtual folder with illegal file name character such as colon ':', non-ascii in name appears twice after restart
Version: 3.1 → Trunk
Following is non-english name case reported to bug 694933 comment #3.
> Name is "Новые" (in russian)
> virtualFolders.dat content, Before restart
> uri=mailbox://igba@isd01.isd.dp.ua/Inbox/%D0%9D%D0%BE%D0%B2%D1%8B%D0%B5
> scope=mailbox://igba@isd01.isd.dp.ua/Inbox|mailbox://igba@isd01.isd.dp.ua/Inbox/06cb4a5e|mailbox://igba@isd01.isd.dp.ua/Inbox/2d5a1aed|mailbox://igba@isd01.isd.dp.ua/Inbox/Maillists|mailbox://igba@isd01.isd.dp.ua/Inbox/TMS|mailbox://igba@isd01.isd.dp.ua/Inbox/SoftTest
> terms=AND (status,isn't,read)
> searchOnline=false
> virtualFolders.dat content, After restart, new definition appears (and old one is retained):
> uri=mailbox://igba@isd01.isd.dp.ua/Inbox/be3d2674
> scope=mailbox://igba@isd01.isd.dp.ua/Inbox|mailbox://igba@isd01.isd.dp.ua/Inbox/06cb4a5e|mailbox://igba@isd01.isd.dp.ua/Inbox/2d5a1aed|mailbox://igba@isd01.isd.dp.ua/Inbox/Maillists|mailbox://igba@isd01.isd.dp.ua/Inbox/TMS|mailbox://igba@isd01.isd.dp.ua/Inbox/SoftTest
> terms=AND (status,isn't,read)
> searchOnline=false
Summary: Virtual folder with illegal file name character such as colon ':', non-ascii in name appears twice after restart → Virtual folder(Saved Search Folder) with illegal file name character such as colon ':', non-ascii in name, appears twice after restart
OS: Other → All
Summary: Virtual folder(Saved Search Folder) with illegal file name character such as colon ':', non-ascii in name, appears twice after restart Virtual folder(Saved Search Folder) with illegal file name character such as colon ':', non-ascii in name, appears twice… → Virtual folder(Saved Search Folder) with illegal file name character such as colon ':', non-ascii like "Новые" in name appears twice after restart Virtual folder(Saved Search Folder) with illegal file name character such as colon ':', non-ascii like …
No longer blocks: 694933
Duplicate of this bug: 694933
As seen in bug 927827 "ascii illegal file name character" case, original comment #0 case(and comment #1), doesn't occur in Tb 24, although bug 694933 comment #3(== comment #2) still occurs in Tb 24.

Change back to original bug summary, and cancel duping of bug 694933.
Summary: Virtual folder(Saved Search Folder) with illegal file name character such as colon ':', non-ascii like "Новые" in name appears twice after restart → Virtual folder as subfolder of local folders with colon ':' in name appears twice after restart.
WORKSFORME in Thunderbird 24.0.1(already fixed by unknown change)
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
Whiteboard: [WORKSFORME in Thunderbird 24.0.1]
You need to log in before you can comment on or make changes to this bug.