Beginning on October 25th, 2016, Persona will no longer be an option for authentication on BMO. For more details see Persona Deprecated.
Last Comment Bug 669154 - Empty button briefly visible during startup from locale picker
: Empty button briefly visible during startup from locale picker
: regression, verified-aurora
Product: Fennec Graveyard
Classification: Graveyard
Component: General (show other bugs)
: Trunk
: ARM Android
: P3 normal (vote)
: Firefox 8
Assigned To: Wesley Johnston (:wesj)
Depends on:
Blocks: 689706 666973
  Show dependency treegraph
Reported: 2011-07-04 06:21 PDT by Aaron Train [:aaronmt]
Modified: 2011-09-27 13:03 PDT (History)
5 users (show)
See Also:
QA Whiteboard:
Iteration: ---
Points: ---

Nightly (07/04) - Startup (17.27 KB, image/png)
2011-07-04 06:21 PDT, Aaron Train [:aaronmt]
no flags Details
Patch (3.48 KB, patch)
2011-07-12 10:15 PDT, Wesley Johnston (:wesj)
mark.finkle: review+
mark.finkle: approval‑mozilla‑aurora+
Details | Diff | Splinter Review

Description Aaron Train [:aaronmt] 2011-07-04 06:21:47 PDT
Created attachment 543757 [details]
Nightly (07/04) - Startup

Mozilla/5.0 (Android; Linux armv7l; rv:7.0a1) Gecko/20110704 Firefox/7.0a1 Fennec/7.0a1
Device: HTC Nexus One, Samsung Nexus S
OS: 2.3.4

Upon launching Nightly, I see an empty button from what looks like the locale picker.

STR: Create a new profile, launch Nightly

See screenshot
Comment 1 Naoki Hirata :nhirata (please use needinfo instead of cc) 2011-07-11 09:14:12 PDT
Gingerbread Only?
Comment 2 Cristian Nicolae (:xti) 2011-07-11 23:18:25 PDT
(In reply to comment #1)
> Gingerbread Only?

This issue occurs also on:
Build id : Mozilla/5.0 (Android;Linux armv7l;rv:8.0a1)Gecko/20110708
Firefox/8.0a1 Fennec/8.0a1
Device: LG Optimus 2x
OS: Android 2.2
Comment 3 Wesley Johnston (:wesj) 2011-07-12 10:15:18 PDT
Created attachment 545403 [details] [diff] [review]

This moves this check into the CLH so that we don't even show the window in this case. That also means (I think) we can remove some of this logic from localePicker.js
Comment 4 :Ehsan Akhgari (Away Oct 25 - Nov 9) 2011-07-13 08:54:35 PDT
Comment 5 Naoki Hirata :nhirata (please use needinfo instead of cc) 2011-07-15 13:44:03 PDT
Mozilla/5.0 (Android; Linux armv71; rv8.0a1) Gecko/20110715 Firefox/8.0a1 Fennec/8.0a1
Device: HTC Flyer
OS: Android OS 2.3
Comment 6 Wesley Johnston (:wesj) 2011-07-19 14:01:14 PDT
Comment on attachment 545403 [details] [diff] [review]

This should be pushed to aurora.
Comment 7 Mark Finkle (:mfinkle) (use needinfo?) 2011-07-19 14:26:44 PDT
Comment on attachment 545403 [details] [diff] [review]

mobile-only and low-risk patch. been on nightly for a bit with no problems.
Comment 8 Wesley Johnston (:wesj) 2011-07-20 14:05:03 PDT
Pushed to aurora:
Comment 9 Aaron Train [:aaronmt] 2011-07-25 08:13:19 PDT
Verified Fixed on Aurora (7.0a2)
Mozilla/5.0 (Android; Linux armv7l); rv:7.0a2) Gecko/20110725 Firefox/7.0a2 Fennec/7.0a2

Note You need to log in before you can comment on or make changes to this bug.