Crash when downloading or trying to view downloads

RESOLVED WORKSFORME

Status

--
critical
RESOLVED WORKSFORME
8 years ago
3 years ago

People

(Reporter: bobby, Unassigned)

Tracking

({crash, regression})

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
Running latest nightly, I'm trying to download require.js. Require.js' website brings me to the actual js file when I click on the download link, so I right-click on it, choose a directory, and kablamo.

"""
init windows
install addon
running on Linux
minefield: symbol lookup error: /usr/lib/gnome-vfs-2.0/modules/libfile.so: undefined symbol: gnome_vfs_unescape_string
"""

Simply clicking on the "Downloads" button to see a list of downloads causes this to happen too.

I don't get an about:crashes log after this happens.

Not terribly sure if this is a result of something within firefox, or if I should blame an Arch package update.
If it's happening with a mozilla.org build, it's our bug.

Is this a regression?  If so, what's the range?
Component: General → File Handling
QA Contact: general → file-handling

Comment 2

8 years ago
Using 8.0a1 (2011-07-10)

I can confirm this problem. Happens to me too.

Linux yasar-laptop 2.6.39-ARCH #1 SMP PREEMPT Mon Jun 27 22:01:13 CEST 2011 i686 Intel(R) Pentium(R) M processor 1.86GHz GenuineIntel GNU/Linux
Duplicate of this bug: 668997
(Reporter)

Comment 4

8 years ago
(In reply to comment #2)
> Using 8.0a1 (2011-07-10)
> 
> I can confirm this problem. Happens to me too.
> 
> Linux yasar-laptop 2.6.39-ARCH #1 SMP PREEMPT Mon Jun 27 22:01:13 CEST 2011
> i686 Intel(R) Pentium(R) M processor 1.86GHz GenuineIntel GNU/Linux

Do you actually use gnome? I'm on Arch as well. Seriously considering it as the source of this bug.

Seems to occur only when Downloads pane tries to open.

Any other linux's have this happen?

Comment 5

8 years ago
I used gnome earlier with this system, then switched to xfce. As far as I know (I may be wrong about this), thunar volume manager, or some other xfce component needed gnome vfs so I kept it installed. I also think that that might be source of the problem.

Comment 6

8 years ago
Removing gnome-vfs package solved problem for me. I also had to remove all other packages that depended on gnome-vfs but I didn't need them much so that wasn't a problem.

Updated

8 years ago
Duplicate of this bug: 671202

Comment 8

8 years ago
I run Arch with Gnome 3 and I also experience this problem in Firefox Nightly, Aurora and Beta. I started a thread about this problem here before I saw this bug report: http://forums.mozillazine.org/viewtopic.php?f=23&t=2249357

When I start Firefox Nightly from the command-line, it returns this error when it crashes:
[23:54] daniel@arch ~ $ firefox-nightly
firefox-nightly: symbol lookup error: /usr/lib/gnome-vfs-2.0/modules/libfile.so: undefined symbol: gnome_vfs_unescape_string
[23:54] daniel@arch ~ $

Comment 9

8 years ago
Just updated Firefox Beta to 6.0b2-1 on Arch, and this bug still occurs.
(Reporter)

Comment 10

8 years ago
I can confirm that.

Interestingly, I have another machine running the same setup on which this doesn't occur, but I have no idea what the difference is besides the obvious (drivers, physical shape of the machine, other things that probably don't matter,...).
(Reporter)

Comment 11

8 years ago
Just tested: this doesn't happen in firefox-7.0a2.en-US.linux-i686. So, it's new in 8.
(Reporter)

Comment 12

8 years ago
Also, a clean downloads list prevents it (deleted the downloads.sqlite in my profile).
Can you find a regression range?
Keywords: regression
(Reporter)

Comment 14

8 years ago
Sorry about not finding a regression range. I don't normally have the firefox source handy to start jumping around in.

Regardless, this seems to have stopped in either the latest nightly, or the latest update of gnome utils for arch. Can anyone verify?
(In reply to comment #14)
> Regardless, this seems to have stopped in either the latest nightly, or the
> latest update of gnome utils for arch. Can anyone verify?

Sorry, no. Still happens for me on a fully updated arch system with the latest nightly (be4b064f1159).

Deleting downloads.sqlite prevents the crash when opening the download list but it still crashes with the same "libfile.so" error if you open the "General Tab" in preferences.

Comment 16

8 years ago
There's a bug report for libgnomevfs2-0 in Debian because of this: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=626076

I use GNOME 3 in Debian and Firefox 5.0 (from Mozilla, but it happens with Iceweasel too). FF crashes with this same error when I try to open the 'Preferences' window.
I started to happen after I was watching an HTML5 video on YouTube and then closed FF. The next time it started to behave this way (removing ~/.mozilla didn't help).

Comment 17

8 years ago
Same Thing here, also when i go to general settings tab, at preferences.

Comment 18

8 years ago
In the bug report from Debian is a workaround:
uncomment "file:file" in 
/etc/gnome-vfs-2.0/modules/default-modules.conf
so you will get
#file: file

Comment 19

7 years ago
Krzysztof Łuczak added the following comment to Launchpad bug report 827211:

Confirmed - it works.
I also get this message when trying do sava an attachement from Icedove/Thunderbird.

-- 
http://launchpad.net/bugs/827211

Comment 20

7 years ago
In the Debian bug report one user wrote that he solved deleting the downloads.sqlite file from the profile directory.

http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=626076#91

I made this test, too, end the problem actually seems solved. The weird thing is that the old file was 4kb in size - I do not store the download history - while the newly created one is 64 kb.
I have this problem too. I use ArchLinux x86_64 and Firefox Nightly from AUR (https://aur.archlinux.org/packages.php?ID=19830) The problem happens also when i try to open the preferences. As Workaround i use currently this one:
LD_PRELOAD=/usr/lib/libgnomevfs-2.so.0 firefox-nightly
It seems to be fixed with one of the last nightly builds or an gnome-vfs update. No problems on opening the preferences or the download windows.
(Reporter)

Comment 23

7 years ago
I can confirm this. Just updated my arch install, which, in turn, updated gnome-vfs. Also, on latest nightly now.

Looks like this disappeared eerily.
WFM per comment 23
Severity: normal → critical
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Keywords: crash
Resolution: --- → WORKSFORME

Comment 25

7 years ago
Juergen Schroeder added the following comment to Launchpad bug report 827211:

I can confirm this solution LMGE Firefox 9.0.1.

I testet with a fresh user without the sqllite files and any rc-files. FF crashes on preferences and donwloading.

uncomment "file:file" in /etc/gnome-vfs-2.0/modules/default-modules.conf

solves the problems

J. Schroeder ;-)

-- 
http://launchpad.net/bugs/827211
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.