background color not drawn on horizontal scroll

VERIFIED WORKSFORME

Status

P3
normal
VERIFIED WORKSFORME
20 years ago
10 years ago

People

(Reporter: akkzilla, Assigned: ramiro)

Tracking

Trunk
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

20 years ago
Run apprunner, with the current default url.  Page is too wide to fit in normal
window width, so horizontal-scroll right to see the other part of the page -- on
Linux, the white background isn't drawn for the right part of the page.  Not a
problem on Windows.

Updated

20 years ago
Assignee: beard → ramiro

Comment 1

20 years ago
Is this is a duplicate of bug #6634? Here's the screenshot posted there.
   http://bugzilla.mozilla.org/showattachment.cgi?attach_id=207

However, they may both be ultimately a bug with the TABLE COLSPAN code,
which is bug #6404 (although that one has a different 'flavour' -- columns
magically "collapse").
(Assignee)

Updated

20 years ago
Target Milestone: M7

Comment 2

20 years ago
yes, i see it.  i wonder what broke, it used to work.

marking m7.
(Reporter)

Comment 3

20 years ago
Yes, that screenshot is exactly what I'm seeing; this bug must be a dup of that
one.
(Assignee)

Updated

20 years ago
Status: NEW → ASSIGNED
Target Milestone: M7 → M10

Comment 4

20 years ago
m10

Comment 5

20 years ago
I think this problem might be that the clip region for the rendering context
that draws the background is set only to the visible area.

So, when you scroll horizontally (and gtk physically moves the widget to the
left) the rendering area remains the visible area - except offseted to the
right.

Comment 6

20 years ago
*** Bug 3017 has been marked as a duplicate of this bug. ***
(Assignee)

Updated

19 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → WORKSFORME

Comment 7

19 years ago
I just tried it and it works now.

marking worksforme.

Updated

19 years ago
Status: RESOLVED → VERIFIED

Comment 8

19 years ago
Wit the Sept 2 build, this problem is not occuring.
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.