Last Comment Bug 669820 - [TI] Permaorange on WinXP debug - buildbot.slave.commands.TimeoutError: command timed out: 5400 seconds elapsed during dom-level2-core/test_setAttributeNS02.html
: [TI] Permaorange on WinXP debug - buildbot.slave.commands.TimeoutError: comma...
Status: RESOLVED FIXED
: intermittent-failure
Product: Core
Classification: Components
Component: JavaScript Engine (show other bugs)
: Trunk
: x86 Windows XP
: -- normal (vote)
: ---
Assigned To: general
:
: Jason Orendorff [:jorendorff]
Mentors:
Depends on:
Blocks: 438871 LandTIOnMC
  Show dependency treegraph
 
Reported: 2011-07-06 22:18 PDT by Phil Ringnalda (:philor)
Modified: 2012-11-25 19:31 PST (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Phil Ringnalda (:philor) 2011-07-06 22:18:29 PDT
Came in on a TM -> JM merge, needs to go out before we can merge TM -> m-c.

http://tinderbox.mozilla.org/showlog.cgi?log=TraceMonkey/1309985080.1309991255.15426.gz

12926 INFO TEST-START | /tests/dom/tests/mochitest/dom-level2-core/test_setAttributeNS01.html
--DOCSHELL 184F0128 == 7
--DOMWINDOW == 842 (1827BCD0) [serial = 5862] [outer = 00000000] [url = http://mochi.test:8888/tests/dom/tests/mochitest/dom-level2-core/files/staffNS.xml]
--DOMWINDOW == 841 (185B5A80) [serial = 5859] [outer = 00000000] [url = http://mochi.test:8888/tests/dom/tests/mochitest/dom-level2-core/files/staffNS.xml]
--DOMWINDOW == 840 (0F2B0900) [serial = 5856] [outer = 00000000] [url = http://mochi.test:8888/tests/dom/tests/mochitest/dom-level2-core/files/staffNS.xml]
WARNING: NS_ENSURE_TRUE(mState == STATE_TRANSFERRING) failed: file e:/builds/moz2_slave/tm-w32-dbg/build/netwerk/base/src/nsSocketTransport2.cpp, line 1889
before 856064, after 856064, break 00000000
++DOMWINDOW == 841 (17BCD8C8) [serial = 5867] [outer = 07FFC5A0]
pldhash: for the table at address 17C68850, the given entrySize of 48 probably favors chaining over double hashing.
++DOCSHELL 17C687E8 == 8
++DOMWINDOW == 842 (1827BCD0) [serial = 5868] [outer = 00000000]
WARNING: Subdocument container has no frame: file e:/builds/moz2_slave/tm-w32-dbg/build/layout/base/nsDocumentViewer.cpp, line 2438
++DOMWINDOW == 843 (0ED2F808) [serial = 5869] [outer = 1827BC80]
--DOCSHELL 186C2010 == 7

command timed out: 5400 seconds elapsed, killing pid 3012
WARNING: NS_ENSURE_SUCCESS(rv, 1) failed with result 0x80520012: file e:/builds/moz2_slave/tm-w32-dbg/build/parser/htmlparser/src/nsExpatDriver.cpp, line 711
WARNING: NS_ENSURE_SUCCESS(rv, rv) failed with result 0x80530005: file e:/builds/moz2_slave/tm-w32-dbg/build/content/base/src/nsContentUtils.cpp, line 2100
WARNING: NS_ENSURE_SUCCESS(rv, rv) failed with result 0x80530005: file e:/builds/moz2_slave/tm-w32-dbg/build/content/base/src/nsGenericElement.cpp, line 2574
12927 INFO TEST-PASS | throw_INVALID_CHARACTER_ERR
program finished with exit code 1
elapsedTime=5400.532000
Comment 1 Brian Hackett (:bhackett) 2011-07-08 06:06:55 PDT
This only appeared in two of the last four pushes to TM, and seems to stop on a different test pretty much every time.  I'm guessing this is not getting stuck, just hitting an absolute timeout on how long the mochitest can take.
Comment 2 Phil Ringnalda (:philor) 2011-07-08 20:44:04 PDT
Seems like a reasonable bet to me: "Windows debug" is our synonym for "slow" so if, as I finally heard, you've got a perf impact, timing out on Windows debug is not-too-surprising fallout from that.
Comment 3 Brian Hackett (:bhackett) 2011-07-19 11:57:40 PDT
This hasn't happened on any platform in the JM branch since the patch for bug 670185 went in (which was, in large part, cutting out work done during GC).  How should this get marked as resolved?
Comment 4 Phil Ringnalda (:philor) 2011-08-01 00:45:16 PDT
Fixed by bug 670185

Note You need to log in before you can comment on or make changes to this bug.