Last Comment Bug 66984 - Need name for new image library (rename libpr0n)
: Need name for new image library (rename libpr0n)
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: ImageLib (show other bugs)
: Trunk
: All All
: -- minor (vote)
: mozilla10
Assigned To: Bobby Holley (:bholley) (busy with Stylo)
:
:
Mentors:
: 128502 (view as bug list)
Depends on:
Blocks: 698263
  Show dependency treegraph
 
Reported: 2001-01-29 15:40 PST by Hixie (not reading bugmail)
Modified: 2011-10-30 05:43 PDT (History)
10 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch v1 (309.11 KB, patch)
2011-10-08 08:54 PDT, Bobby Holley (:bholley) (busy with Stylo)
joe: review+
Details | Diff | Splinter Review

Description Hixie (not reading bugmail) 2001-01-29 15:40:57 PST
ImageLib is boring and libpr0n is offensive, so that means we have to come up 
with a new name. Surely Pav can come up with one. Personally I don't understand
what is wrong with Pav's original "Library for Picture Rendering Object Nodes" 
or, for that matter, "Library for Picture Rendering, version 0.n". But...
Comment 1 Stuart Parmenter 2001-01-29 15:46:45 PST
wontfix
Comment 2 Hixie (not reading bugmail) 2001-01-29 15:49:03 PST
It appears blake backed down and so libpr0n is acceptable. VERIFIED.
Comment 3 Gervase Markham [:gerv] 2001-05-02 16:17:52 PDT
I'm not shockingly impressed with 'libpr0n' (the name, that is) either, but
there it is. 

Gerv
Comment 4 Stuart Parmenter 2003-05-03 15:42:20 PDT
*** Bug 128502 has been marked as a duplicate of this bug. ***
Comment 5 Glenn Randers-Pehrson 2003-05-03 16:39:39 PDT
Nine minutes was not sufficient discussion of this proposal..  Please
reopen it.  Or, better, mark this one a dupe of bug #128502 which has
had more discussion.  The name libpr0n and the accompanying web site
is a stupid stupid offensive joke and inhibits some people, myself
included, from working on files in the libpr0n directory.   Glenn
Comment 6 Stuart Parmenter 2003-05-03 16:47:01 PDT
It was discussed at length offline.  pr0n could stand for anything, and I don't
think I've ever made any statement about what it stood for.  I had nothing to do
with the website, and I think you are taking it far too serious.  Get over it
man.  You're the only person I know of who is offended by a name that doesn't
mean anything.
Comment 7 Stuart Parmenter 2003-05-05 15:08:42 PDT
*** Bug 128502 has been marked as a duplicate of this bug. ***
Comment 8 Stuart Parmenter 2003-05-05 15:17:45 PDT
The image library's name will always be libpr0n even if you don't like it. 
That's the name that was picked (for somewhat silly reasons at the time) and it
will always be that.  Would you rather the official name be well documented in
the source?  I never saw a reason since the directory name was what it is.
Comment 9 Alec Flett 2003-05-05 15:21:36 PDT
I don't even see how the word "pr0n" is offensive in the first place. Even if it
was "porn" how is the word "porn" itself offensive? does that mean all software
that can be used to view porn is offensive? is mozilla offensive? c'mon folks.
We've moved past the 18th century.
Comment 10 Stuart Parmenter 2003-05-06 00:06:50 PDT
*** Bug 128502 has been marked as a duplicate of this bug. ***
Comment 11 Stuart Parmenter 2003-05-06 00:24:07 PDT
*** Bug 128502 has been marked as a duplicate of this bug. ***
Comment 12 Glenn Randers-Pehrson 2003-05-06 05:21:09 PDT
Perhaps "libpr0n" standing alone isn't offensive.  But in connection
with the libpr0n web site (the first hit returned by Google), with which
I believe you are familiar, it is.

In the real world where I worked, heads have rolled for making jokes that seem
similarly innocuous.  The jokester and two levels of his supervision found
themselves out of work, on the grounds of creating a hostile work environment.

Please reopen this bug.  I have transferred my vote here from bug #128502.

Glenn
Comment 13 Hixie (not reading bugmail) 2003-05-06 05:25:40 PDT
If we called it "libimg2" and someone (say, me) went ahead and registered
libimg2.com and copied the libpr0n.com content to it, you would have the same
problem. So the name of the library is irrelevant. If you have a problem with
the libpr0n.com Web site, please take it up with its webmaster (me) in private
e-mail, as it has nothing to do with Mozilla.

This is the 21st century, not the 18th. If you, or people you work with, have
problems with pornographic materials, you have problems much bigger than the
codename of an internal Mozilla module.
Comment 14 Glenn Randers-Pehrson 2003-06-09 06:04:14 PDT
I'm withdrawing my objection to the name "libpr0n" and have cancelled my vote
for this bug.  The sheriff won't be confiscating my computers, since he was
recently forced to resign under sex offense charges.  Don't believe me?  Google
for "harford sheriff resignation".  The new sheriff hasn't as yet made a big
issue of Internet pornography.  BTW I still think the name libpr0n is somewhat
unprofessional and I still don't feel comfortable telling my employer and family
that I'm working on it.
Comment 15 Alex Merry 2004-08-19 12:55:17 PDT
Well, I was amused by it when I was browsing the source tree. It's the sort of
joke the finds its way into a lot of software.

Although I'm not quite sure why you have to say "I worked on libpr0n", rather
than "I worked on the image decoding library of mozilla". For a start, it's a
lot more obvious what you're talking about for someone not intimate with the
mozilla tree.
Comment 16 Bobby Holley (:bholley) (busy with Stylo) 2011-10-08 08:35:12 PDT
*** Bug 128502 has been marked as a duplicate of this bug. ***
Comment 17 Bobby Holley (:bholley) (busy with Stylo) 2011-10-08 08:36:41 PDT
Joe and I talked about doing this a few years ago. I think it's time to finally make it happen.

Patch coming right up.
Comment 18 Bobby Holley (:bholley) (busy with Stylo) 2011-10-08 08:38:28 PDT
I think that bz will be the most appropriate sr here.
Comment 19 Bobby Holley (:bholley) (busy with Stylo) 2011-10-08 08:54:19 PDT
Created attachment 565742 [details] [diff] [review]
patch v1

Attaching a patch.

This patch was generated by doing the following:
1 - Rename of modules/libpr0n to image

2 - Source-wide grep for all files containing 'modules/libpr0n', followed by:
perl -pi -e 's/modules\/libpr0n/image/'
on those files

3 - Changing the depth on all the Makefiles, with a cross-check at the end to make sure they've all been fixed.

Flagging joe for the module owner signoff, and bz for sr. If they're both fine with it, I'll flag khuey for the build-side review.
Comment 20 Joe Drew (not getting mail) 2011-10-08 17:32:29 PDT
We can do better than "image", can't we? :)
Comment 21 Boris Zbarsky [:bz] (still a bit busy) 2011-10-08 20:48:30 PDT
Why do you need an sr here at all?  This is a mechanical-ish change, no?

If you need one, please pick someone comfortable with reviewing build system changes (so not me).
Comment 22 Bobby Holley (:bholley) (busy with Stylo) 2011-10-08 22:06:04 PDT
(In reply to Joe Drew (:JOEDREW!) from comment #20)
> We can do better than "image", can't we? :)

imagelib?

(In reply to Boris Zbarsky (:bz) from comment #21)
> Why do you need an sr here at all?  This is a mechanical-ish change, no?

Ok, sure. I guess the politics here have cooled off sufficiently such that it's unnecessary.
Comment 23 Boris Zbarsky [:bz] (still a bit busy) 2011-10-08 22:09:51 PDT
I don't think the politics ever involved anything other than the module owner liking the name.  But Stuart is no longer module owner, so as long as the current module owner is happy, there's no problem.
Comment 24 Bobby Holley (:bholley) (busy with Stylo) 2011-10-08 22:19:07 PDT
Comment on attachment 565742 [details] [diff] [review]
patch v1

(In reply to Boris Zbarsky (:bz) from comment #23)
> I don't think the politics ever involved anything other than the module
> owner liking the name.  But Stuart is no longer module owner, so as long as
> the current module owner is happy, there's no problem.

Ok! :-)
Comment 25 Joe Drew (not getting mail) 2011-10-12 15:32:09 PDT
Comment on attachment 565742 [details] [diff] [review]
patch v1

Review of attachment 565742 [details] [diff] [review]:
-----------------------------------------------------------------

I am VERY SAD but Jeff points out that image is a better name than any of my alternates.
Comment 26 Bobby Holley (:bholley) (busy with Stylo) 2011-10-12 18:06:10 PDT
(In reply to Joe Drew (:JOEDREW!) from comment #25)
> Comment on attachment 565742 [details] [diff] [review] [diff] [details] [review]
> I am VERY SAD but Jeff points out that image is a better name than any of my
> alternates.

Just out of curiosity, why not imagelib? We've been namespacing new files as mozilla::imagelib, so it might be nice if they matched.

'image' does have aesthetic appeal though, so I'm happy sticking with that too. ;-)
Comment 27 Joe Drew (not getting mail) 2011-10-12 20:33:48 PDT
(In reply to Bobby Holley (:bholley) from comment #26)
> Just out of curiosity, why not imagelib? We've been namespacing new files as
> mozilla::imagelib, so it might be nice if they matched.

We should fix that by changing mozilla::imagelib to mozilla::image :)
Comment 28 Bobby Holley (:bholley) (busy with Stylo) 2011-10-16 20:31:13 PDT
pushed to try: https://tbpl.mozilla.org/?tree=Try&rev=5346aa9d36af
Comment 29 Bobby Holley (:bholley) (busy with Stylo) 2011-10-17 12:26:40 PDT
Last one was bitrotted by the time it was pushed. :\

Trying again: https://tbpl.mozilla.org/?tree=Try&rev=ffbcf69cacc9
Comment 30 Bobby Holley (:bholley) (busy with Stylo) 2011-10-18 00:06:40 PDT
Landed, with Brendan's approval, to mozilla-central:
https://hg.mozilla.org/mozilla-central/rev/0a5e72d1b479

Resolving fixed.

Note You need to log in before you can comment on or make changes to this bug.