Last Comment Bug 669886 - Make nsMappedAttributeElement, nsStyledElement, nsStyledElementNotElementCSSInline, nsGenericHTMLElement, nsGenericHTMLFormElement and nsGenericHTMLFrameElement participate in DOM Memory Reporter
: Make nsMappedAttributeElement, nsStyledElement, nsStyledElementNotElementCSSI...
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: DOM: Core & HTML (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla8
Assigned To: Mounir Lamouri (:mounir)
:
Mentors:
Depends on: 669308
Blocks: 663271
  Show dependency treegraph
 
Reported: 2011-07-07 07:19 PDT by Mounir Lamouri (:mounir)
Modified: 2011-07-25 05:58 PDT (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch v1 (7.13 KB, patch)
2011-07-07 07:19 PDT, Mounir Lamouri (:mounir)
jst: review+
Details | Diff | Review

Description Mounir Lamouri (:mounir) 2011-07-07 07:19:30 PDT
Created attachment 544472 [details] [diff] [review]
Patch v1

I will probably have to make nsFrameLoader participate in DOM Memory Reporter too in another patch.
Comment 1 :Ms2ger 2011-07-07 10:18:56 PDT
Comment on attachment 544472 [details] [diff] [review]
Patch v1

>--- a/content/html/content/src/nsGenericHTMLElement.cpp
>+++ b/content/html/content/src/nsGenericHTMLElement.cpp
>+nsGenericHTMLFrameElement::SizeOf() const
>+{
>+  PRInt64 size = MemoryReporter::GetBasicSize<nsGenericHTMLFrameElement,
>+                                              nsGenericHTMLElement>(this);
>+  // TODO: might need to implement SizeOf() in nsFrameLoader.
>+  size += mFrameLoader ? sizeof(*mFrameLoader.get()) : 0;

Do you need the .get()?
Comment 2 Marco Bonardo [::mak] 2011-07-20 06:56:22 PDT
this has been backed out by ehsan due to bustage with all the other changesets in the same push
Comment 3 Marco Bonardo [::mak] 2011-07-25 05:58:20 PDT
http://hg.mozilla.org/mozilla-central/rev/c62d7cde4bf2

Note You need to log in before you can comment on or make changes to this bug.