Closed Bug 669941 Opened 10 years ago Closed 10 years ago

"Find in this message" searching All message unless chosen twice

Categories

(Thunderbird :: Mail Window Front End, defect)

All
macOS
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 564328

People

(Reporter: derek, Unassigned)

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:5.0) Gecko/20100101 Firefox/5.0
Build ID: 20110615151330

Steps to reproduce:

Pressed cmd F (or Edit>Find>Find in this message)


Actual results:

The message list refreshed to show items matching search preferences, in fact behaving as 'Find in ALL messages', not as 'Find in this message' as described in the Edit menu.


Expected results:

I want to be able to search a currently selected message as an entirely separated function from searching all messages with a single key command, not the duplicate pressing of one.  In my view, these need to have separate keybindings as used to be the case.

Currently one has to press cmd+F twice to drill down to search the current message body, and go through a rigmarole of Esc and mouseclicks to change the focus in order to get in and out of various places, oftentimes having to use the mouse to click the right bit so as to bring the right part to the front so the keybinding will work.

It would be far more practical to make Current Message search separate from All Messages search, each with their own keybinding shortcut.  Currently, cmd+shift+F brings up the global search pane, so I suggest perhaps cmd+opt+F could be used to go straight to the message body search.

The menu says "Find in this message" even though it is finding in All Messages.  I therefore propose this be spilt into two parts for this menu (with differentiated keybindings as outlined above):
"Find in this message" (if selected, otherwise gray)
"Find in all messages" (if Account Folder selected, otherwise Gray)
OS: Other → Mac OS X
Status: UNCONFIRMED → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 564328
You need to log in before you can comment on or make changes to this bug.