Last Comment Bug 670040 - Make nsISessionStartup.state a jsval to save repeatedly stringifying/parsing the initial state
: Make nsISessionStartup.state a jsval to save repeatedly stringifying/parsing ...
Status: RESOLVED FIXED
: dev-doc-complete
Product: Firefox
Classification: Client Software
Component: Session Restore (show other bugs)
: unspecified
: All All
: -- minor (vote)
: Firefox 8
Assigned To: Dave Townsend [:mossop]
:
Mentors:
Depends on:
Blocks: 670033 672178
  Show dependency treegraph
 
Reported: 2011-07-07 16:26 PDT by Dave Townsend [:mossop]
Modified: 2011-08-24 08:34 PDT (History)
7 users (show)
dtownsend: in‑testsuite-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch rev 1 (11.23 KB, patch)
2011-07-07 16:41 PDT, Dave Townsend [:mossop]
paul: review+
Details | Diff | Splinter Review

Description Dave Townsend [:mossop] 2011-07-07 16:26:53 PDT

    
Comment 1 Dave Townsend [:mossop] 2011-07-07 16:41:17 PDT
Created attachment 544653 [details] [diff] [review]
patch rev 1
Comment 2 Paul O'Shannessy [:zpao] (not reading much bugmail, email directly) 2011-07-13 17:17:24 PDT
Comment on attachment 544653 [details] [diff] [review]
patch rev 1

yay jsvals!
Comment 3 Dave Townsend [:mossop] 2011-07-15 09:52:03 PDT
Landed: http://hg.mozilla.org/mozilla-central/rev/a65a4165c236

I updated https://developer.mozilla.org/en/XPCOM_Interface_Reference/nsISessionStartup but this might want to go onto the Firefox 8 for developers page
Comment 4 Mike Pesce (:By-Tor) 2011-07-16 07:21:26 PDT
Since http://hg.mozilla.org/mozilla-central/rev/a65a4165c236 it has been impossible to compile under VS2010.  I can't quite figure out why, but, a bisection shows this changeset as the culprit.  The crash will usually occur once shlibsign.exe is hit. 

From my Event log:
Faulting application name: shlibsign.exe, version: 0.0.0.0, time stamp: 0x4e216d7d
Faulting module name: jemalloc.dll, version: 8.0.0.4214, time stamp: 0x4e21707a
Exception code: 0xc0000005
Fault offset: 0x00004672
Faulting process id: 0x16d8
Faulting application start time: 0x01cc43aa429bab0f
Faulting application path: d:\build\mozilla-central\obj-i686-pc-mingw32\nss\shlibsign.exe
Faulting module path: d:\build\mozilla-central\obj-i686-pc-mingw32\dist\bin\jemalloc.dll
Report Id: 810dca07-af9d-11e0-b7f0-001b2112456b
Comment 5 Dave Townsend [:mossop] 2011-07-16 10:55:28 PDT
(In reply to comment #4)
> Since http://hg.mozilla.org/mozilla-central/rev/a65a4165c236 it has been
> impossible to compile under VS2010.  I can't quite figure out why, but, a
> bisection shows this changeset as the culprit.  The crash will usually occur
> once shlibsign.exe is hit. 

That'd be pretty surprising, none of the code changed is compiled by VS. Could you file a new bug so we can track it though.
Comment 6 Kyle Huey [:khuey] (khuey@mozilla.com) 2011-07-16 17:35:58 PDT
That is fallout from Bug 671441.
Comment 7 Paul O'Shannessy [:zpao] (not reading much bugmail, email directly) 2011-07-25 16:32:32 PDT
Pushed http://hg.mozilla.org/integration/fx-team/rev/0ffeb8ce63f1 to update a comment so it says jsval instead of string
Comment 8 :Gavin Sharp [email: gavin@gavinsharp.com] 2011-07-28 09:55:49 PDT
http://hg.mozilla.org/mozilla-central/rev/0ffeb8ce63f1
Comment 9 Eric Shepherd [:sheppy] 2011-08-24 08:34:14 PDT
Mossop updated the docs here:

https://developer.mozilla.org/en/XPCOM_Interface_Reference/nsISessionStartup

I added a note that the previous type was string.

Also mentioned on Firefox 8 for developers.

Note You need to log in before you can comment on or make changes to this bug.