Closed Bug 670508 Opened 9 years ago Closed 9 years ago

Crash [@ nsFrame::HandlePress] when ctrl-clicking on td contenteditable

Categories

(Core :: DOM: Selection, defect, critical)

x86
Windows 7
defect
Not set
critical

Tracking

()

RESOLVED WORKSFORME
mozilla9

People

(Reporter: martijn.martijn, Assigned: masayuki)

References

(Depends on 1 open bug, Blocks 1 open bug)

Details

(Keywords: crash, regression, testcase)

Crash Data

Attachments

(2 files)

Attached file testcase
See testcase, which crashes current trunk build when ctrl-clicking on the text in the table cell.

https://crash-stats.mozilla.com/report/index/f0589070-d092-4825-a10b-f0d6421107100 	xul.dll 	nsFrame::HandlePress 	layout/generic/nsFrame.cpp:2313
1 	xul.dll 	nsFrame::HandleEvent 	
2 	xul.dll 	nsPresShellEventCB::HandleEvent 	layout/base/nsPresShell.cpp:1503
3 	xul.dll 	nsEventTargetChainItem::HandleEventTargetChain 	content/events/src/nsEventDispatcher.cpp:389
4 	xul.dll 	nsEventDispatcher::Dispatch 	content/events/src/nsEventDispatcher.cpp:672
5 	xul.dll 	PresShell::HandleEventInternal 	layout/base/nsPresShell.cpp:7093
6 	xul.dll 	PresShell::HandlePositionedEvent 	layout/base/nsPresShell.cpp:6923
7 	xul.dll 	PresShell::HandleEvent 	layout/base/nsPresShell.cpp:6755
8 	xul.dll 	nsViewManager::HandleEvent 	view/src/nsViewManager.cpp:1053
9 	xul.dll 	nsViewManager::DispatchEvent 	view/src/nsViewManager.cpp:1031
10 	xul.dll 	AttachedHandleEvent 	view/src/nsView.cpp:192
11 	xul.dll 	nsWindow::DispatchEvent 	widget/src/windows/nsWindow.cpp:3550
12 	xul.dll 	nsWindow::DispatchWindowEvent 	widget/src/windows/nsWindow.cpp:3573
13 	xul.dll 	nsWindow::DispatchMouseEvent 	widget/src/windows/nsWindow.cpp:3997
14 	xul.dll 	nsWindow::ProcessMessage 	
15 	xul.dll 	nsWindow::WindowProcInternal 	widget/src/windows/nsWindow.cpp:4404
16 	xul.dll 	CallWindowProcCrashProtected 	xpcom/base/nsCrashOnException.cpp:65
17 	xul.dll 	nsWindow::WindowProc 	widget/src/windows/nsWindow.cpp:4346
18 	user32.dll 	InternalCallWinProc 	
19 	user32.dll 	UserCallWinProcCheckWow 
etc..
Probably, this cause is similar to bug 670081. Taking.
Assignee: nobody → masayuki
Status: NEW → ASSIGNED
Version: unspecified → Trunk
Attached patch Patch v1.0Splinter Review
Needs null check. If there is no scrollable frame, we don't need to call SetCapturingContent() at that time since it was already called for normal selection. So, selection root content has been capturing mouse events already.
Attachment #545783 - Flags: review?(roc)
Comment on attachment 545783 [details] [diff] [review]
Patch v1.0

Review of attachment 545783 [details] [diff] [review]:
-----------------------------------------------------------------
Attachment #545783 - Flags: review?(roc) → review+
http://hg.mozilla.org/mozilla-central/rev/0141c3f5b18c
Status: ASSIGNED → RESOLVED
Closed: 9 years ago
Flags: in-testsuite+
Resolution: --- → FIXED
Whiteboard: [inbound]
Target Milestone: --- → mozilla8
Temporarily, backed out for risk management of mozilla8, see bug 675865.
Resolution: FIXED → WORKSFORME
Target Milestone: mozilla8 → mozilla9
You need to log in before you can comment on or make changes to this bug.