Last Comment Bug 670645 - Cannot find texture from pixmap symbols
: Cannot find texture from pixmap symbols
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Graphics (show other bugs)
: Trunk
: All Other
: -- normal (vote)
: mozilla8
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
: 658921 673608 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-07-11 05:55 PDT by Rob Bradford
Modified: 2011-10-11 13:58 PDT (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch to try and address this issue (1.21 KB, patch)
2011-07-11 06:10 PDT, Rob Bradford
matt.woodrow: review+
Details | Diff | Review

Description Rob Bradford 2011-07-11 05:55:12 PDT
User Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/534.30 (KHTML, like Gecko) Chrome/12.0.742.112 Safari/534.30

Steps to reproduce:

On startup the following warnings appear:

Can't find symbol 'glXBindTexImageEXT'
Can't find symbol 'glXReleaseTexImageEXT

Hardware graphics platform: Mesa 7.10 and mesa git on Intel Ironlake



Actual results:

The TFP symbols are not looked up through glXGetProcAddress and are thus not found - texture from pixmap is then not enabled.


Expected results:

The texture from pixmap functions should be found and texture from pixmap enabled.
Comment 1 Rob Bradford 2011-07-11 06:10:56 PDT
Created attachment 545157 [details] [diff] [review]
Patch to try and address this issue

This patch gets rid of the symbol lookup warnings and allows the texture from pixmap to be enabled on this platform.

Feedback welcome!
Comment 2 Rob Bradford 2011-07-11 06:58:35 PDT
Comment on attachment 545157 [details] [diff] [review]
Patch to try and address this issue

Review of attachment 545157 [details] [diff] [review]:
-----------------------------------------------------------------
Comment 3 Matt Woodrow (:mattwoodrow) 2011-07-12 14:18:46 PDT
Comment on attachment 545157 [details] [diff] [review]
Patch to try and address this issue

Review of attachment 545157 [details] [diff] [review]:
-----------------------------------------------------------------

Interesting that this has never shown up for other extensions.

Looks good to me though!

::: gfx/thebes/GLContextProviderGLX.cpp
@@ +239,4 @@
>      {
>          mHasTextureFromPixmap = PR_TRUE;
> +    } else {
> +        NS_WARNING("Texture from pixmap disabled");

I think we should just return PR_FALSE here, performance without this enabled is significantly reduced over just using X to composite.
Comment 4 Rob Bradford 2011-07-13 06:54:14 PDT
Thanks Matt. I've opened a bug about failing the initialisation in that case: https://bugzilla.mozilla.org/show_bug.cgi?id=671259
Comment 5 Matt Woodrow (:mattwoodrow) 2011-07-14 14:04:54 PDT
http://hg.mozilla.org/integration/mozilla-inbound/rev/7ce783faf48f
Comment 6 :Ehsan Akhgari (busy, don't ask for review please) 2011-07-15 07:04:48 PDT
http://hg.mozilla.org/mozilla-central/rev/7ce783faf48f
Comment 7 Karl Tomlinson (ni?:karlt) 2011-07-31 17:10:01 PDT
*** Bug 658921 has been marked as a duplicate of this bug. ***
Comment 8 Joe Drew (not getting mail) 2011-10-11 13:58:08 PDT
*** Bug 673608 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.