Last Comment Bug 671240 - Text from Name Group text-field shifts to the left while writting
: Text from Name Group text-field shifts to the left while writting
Status: RESOLVED FIXED
:
Product: Firefox Graveyard
Classification: Graveyard
Component: Panorama (show other bugs)
: Trunk
: All All
: -- normal
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
Depends on: 671243
Blocks:
  Show dependency treegraph
 
Reported: 2011-07-13 05:28 PDT by George Carstoiu
Modified: 2016-04-12 14:00 PDT (History)
3 users (show)
See Also:
QA Whiteboard:
Iteration: ---
Points: ---


Attachments

Description George Carstoiu 2011-07-13 05:28:49 PDT
Mozilla/5.0 (X11; Linux i686; rv:7.0a2) Gecko/20110712 Firefox/7.0a2

When the name of the group is longer than the designated text-field, the string starts shifting to the left although text-field is expanding to right where is has enough space. This is more easily observable on Linux builds.

Steps to reproduce:
1. Enter Panorama and create a group
2. Start entering a string that is longer than the designated text-field area.
3. Observe behavior

Actual results:
 - string shifts slowly to the left

Expected results:
 - string shifts to the left only when the text-field reaches the right part of the group and there's no more space for it to expand
Comment 1 Teddy Ni 2011-07-15 02:22:42 PDT
Possible half-duplicate of bug 589132. They aren't exactly the same but the patch in progress appears to be trying to do some detection of the actual width of the group name. Maybe is better marked as a duplicate of bug 586545, which I'd guess causes this behavior.
Comment 2 Tim Taubert [:ttaubert] (on PTO, back Aug 29th) 2011-07-17 09:21:41 PDT
This happens especially when typing wide characters (as 'w') because there's a false assumption of each character being 6px wide. This will be fixed with bug 671243.
Comment 3 Tim Taubert [:ttaubert] (on PTO, back Aug 29th) 2011-10-11 02:43:20 PDT
Fixed by bug 671243.

Note You need to log in before you can comment on or make changes to this bug.