Closed Bug 671454 Opened 9 years ago Closed 9 years ago

Implement telemetry ui on mobile

Categories

(Firefox for Android Graveyard :: General, defect)

defect
Not set

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: taras.mozilla, Assigned: stechz)

References

Details

Attachments

(1 file, 1 obsolete file)

No description provided.
Madhava, can you provide some guidance on an approach? Desktop has landed a similar feature.
The following error occurs for 3 times in Error Console:

Error: Unable to report telemetry.
Source File: jar:file///data/app/org.mozilla.fennec-1.apk!/components/nsPlacesAutoComplete.js   Line: 739

I'm able to reproduce it when I browse to http://jeremydouglass.com/gamertextually/images/gt_snowflake_tags-2-ach-large.png
Is this error related to this bug?

--
Build id : Mozilla/5.0 (Android;Linux armv7l;rv:8.0a1)Gecko/20110803
Firefox/8.0a1 Fennec/8.0a1
Device: HTC Desire Z
OS: Android 2.3.3
The error mentioned in comment 2 was filed as bug 676246.
Madhava, ping? I'm not sure this needs a lot of UX energy, but maybe a general direction would be helpful to move this bug forward. We can always incrementally improve later.

Should we add a call to action on the home page?

Do a dialog?

Put an option in preferences?
Assignee: mark.finkle → ben
Attached patch Implement telemtry ui on mobile (obsolete) — Splinter Review
Called pref "Send performance data." I would have preferred to add a "to
Mozilla," but that overflows text on the pre-Honeycomb theme.
Attachment #551180 - Flags: review?(mark.finkle)
Comment on attachment 551180 [details] [diff] [review]
Implement telemtry ui on mobile

Looks good, but I'd like to see the new pref in a new section. "Privacy & Security" is not exactly the best place for it.

Let's add a new <settings> group under "Content" called "Other" (with an id of "prefs-other"). Add the telemetry pref there.

New patch and I'll r+ it
Attachment #551180 - Flags: review?(mark.finkle)
An other section? Bleck. What's wrong with Privacy & Security? This fits best as a privacy option.
(In reply to Benjamin Stover (:stechz) from comment #7)
> An other section? Bleck. What's wrong with Privacy & Security? This fits
> best as a privacy option.

It's weakly related in that it's an opt-in feature and we are sending data back to Mozilla. Not the typical type of "privacy" in that section. Also, it's listed first? I don't think so.

Desktop has this option buried in "Advanced > General > System Defaults"
I don't think this belongs in our standard short set of prefs. How about in the tester tools pane, given that this is for people who are volunteering to help us out?

For a string - "Submit performance data" is what they use on Desktop; I'd have preferred it to be clearer to _whom_ they're sending, but "Send performance data to Mozilla" is long.
There's a bug for enabling tester tools on nightly (bug 651867), but we shouldn't block for that.
We can have a follow-up bug for transferring it to feedback tools once the above bug lands, but we really could use some real data right now.
OS: Linux → All
Hardware: x86 → All
Attachment #551551 - Flags: review?(mark.finkle)
Attachment #551180 - Attachment is obsolete: true
Attachment #551551 - Flags: review?(mark.finkle) → review+
(as it turns out, fixing the nightly feedback problem was trivial)
Depends on: 651867
No longer depends on: 651867
Pushed http://hg.mozilla.org/mozilla-central/rev/c70a97a478fe
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.