Closed Bug 671515 Opened 9 years ago Closed 9 years ago

Could not read chrome manifest file [install_path]\extensions\{972ce4c6-7e08-4474-a285-3208198ce6fd}\chrome.manifest

Categories

(Firefox :: General, defect)

8 Branch
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 586610

People

(Reporter: mozilla, Unassigned)

References

Details

Attachments

(2 files)

Started Firefox Nightly as I always do and all tabs from previous session haven't been restored.

Taking a quick look into Error Console, I have found the error message
Could not read chrome manifest file 'C:\Program Files\Mozilla Firefox\extensions\{972ce4c6-7e08-4474-a285-3208198ce6fd}\chrome.manifest'

Tried to do the following:
1) disable all plugins and add-ons and restarted,
2) created a new and clean user profile,
3) uninstalled Nightly, removed all remaining files/folders in programs folder and also in Local and Roaming user profile folders, then reinstalled

None of the above solved this issue, which prevents session restore also from third-parties add-ons such as Tab Mix Plus.
(In reply to LanX from comment #0)
> Started Firefox Nightly as I always do and all tabs from previous session
> haven't been restored.

Have you still had this issue?

> Taking a quick look into Error Console, I have found the error message
> Could not read chrome manifest file 'C:\Program Files\Mozilla
> Firefox\extensions\{972ce4c6-7e08-4474-a285-3208198ce6fd}\chrome.manifest'

That's not likely related.

> Tried to do the following:
> 1) disable all plugins and add-ons and restarted,
> 2) created a new and clean user profile,
> 3) uninstalled Nightly, removed all remaining files/folders in programs
> folder and also in Local and Roaming user profile folders, then reinstalled
> 
> None of the above solved this issue, which prevents session restore also
> from third-parties add-ons such as Tab Mix Plus.

If you don't have Firefox set to show windows & tabs from last time in options > general, then your session won't be automatically restored. It should be available under history > restore previous session. The default setting is to show your home page.

(In reply to Bob from comment #1)
> Created attachment 554376 [details]
> Could not read chrome manifest file

That's mostly just a bunch of errors from extensions that aren't really compatible.
Status: UNCONFIRMED → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 586610
The error message is still show in Error console.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
Attached patch fixSplinter Review
The same fix as http://hg.mozilla.org/comm-central/rev/11953f14423a for m-c.
Attachment #569273 - Flags: review?(mbanner)
OS: Windows 7 → All
Hardware: x86_64 → All
Component: Session Restore → General
QA Contact: session.restore → general
Attachment #569273 - Flags: feedback?(dtownsend)
Depends on: 586610
Comment on attachment 569273 [details] [diff] [review]
fix

This isn't my area - you probably just want to ask Mossop striaght off.
Attachment #569273 - Flags: review?(mbanner)
Attachment #569273 - Flags: review?(dtownsend)
Attachment #569273 - Flags: feedback?(dtownsend)
No longer depends on: 586610
Comment on attachment 569273 [details] [diff] [review]
fix

Review of attachment 569273 [details] [diff] [review]:
-----------------------------------------------------------------

The problem with this is that it adds additional file IO during startup that we don't want. Instead I have a patch for bug 697312 which will just not include the default theme in extensions.ini
Attachment #569273 - Flags: review?(dtownsend) → review-
Status: UNCONFIRMED → RESOLVED
Closed: 9 years ago9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 586610
You need to log in before you can comment on or make changes to this bug.