Closed Bug 671535 Opened 10 years ago Closed 10 years ago

Videos fail to play on Windows 2000

Categories

(Core :: Audio/Video, defect)

x86
Windows 2000
defect
Not set
normal

Tracking

()

RESOLVED WONTFIX

People

(Reporter: simona.marcu, Unassigned)

References

Details

Mozilla/5.0 (Windows NT 5.0; rv:6.0) Gecko/20100101 Firefox/6.0

An ogv video on Windows 2000 can be played only once. The first time the video starts to play automatically, but the same video in a different tab will fail to play (the video will load but will not play, even if the play button is pressed).

Reproducible: always

Steps to reproduce:
1. Go to http://videos.mozilla.org/firefox4beta/Firefox_4_beta.theora.ogv
2. Open a new tab and go to the video from step 1 again.

Actual results:
The video from the second tab fails to play

Expected results
The videos from both tabs will start to play automatically.
Simona, could you find a regression range for this problem?
Component: General → Video/Audio
Product: Firefox → Core
QA Contact: general → video.audio
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9.2.18) Gecko/20110614 Firefox/3.6.18

Ogv videos fails to play since Firefox 3.6.18. A better way to reproduce this issue is by following these steps:

1. Start Firefox.
2. Go to http://videos.mozilla.org/firefox4beta/Firefox_4_beta.theora.ogv\
3. Wait for the video to start and pause it.
4. Resume the video.

After step 4 the ogv video will refuse to play again.
Simona, to help narrow down where the problem might like, could you please test http://flim.org/~kinetik/3d198wqepg78m_nosound.ogg and let me know if you can reproduce the problem?
s/like/lie/
(In reply to comment #3)
> Simona, to help narrow down where the problem might like, could you please
> test http://flim.org/~kinetik/3d198wqepg78m_nosound.ogg and let me know if
> you can reproduce the problem?

Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9.2.18) Gecko/20110614 Firefox/3.6.18
On Firefox 3.6.18 - video plays, pause/play works ok.

Mozilla/5.0 (Windows NT 5.0; rv:6.0) Gecko/20100101 Firefox/6.0
On Firefox 6.0b2 - video plays, pause/play works fine (sometimes video fails to load in a new empty tab)
(In reply to comment #3)
> Simona, to help narrow down where the problem might like, could you please
> test http://flim.org/~kinetik/3d198wqepg78m_nosound.ogg and let me know if
> you can reproduce the problem?

Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9.2.18) Gecko/20110614 Firefox/3.6.18
On Firefox 3.6.18 - video plays, pause/play works ok.

Mozilla/5.0 (Windows NT 5.0; rv:6.0) Gecko/20100101 Firefox/6.0
On Firefox 6.0b2 - video plays, pause/play works fine (sometimes video fails to load in a new empty tab)
Thanks.  How about http://www.vorbis.com/music/The_Abyss-4T.ogg (Vorbis audio track only)?

Do older versions of Firefox 3.5 or 3.6 work with the original file?  You said it broke with 3.6.18... do you mean between than and 3.6.17, or between than and Firefox 4.0?  Particularly interested in 3.6.6 vs 3.6.7 if you're able to test.
Firefox 3.5:
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9.1) Gecko/20090624 Firefox/3.5

The ogv video: http://videos.mozilla.org/firefox4beta/Firefox_4_beta.theora.ogv - behaves like in Comment 2 (fails to play after pause) 

http://flim.org/~kinetik/3d198wqepg78m_nosound.ogg - video plays and pause/play works fine.

http://www.vorbis.com/music/The_Abyss-4T.ogg - video plays but after the first pause video refuses to play again (same behavior as in Comment 2).

Firefox 3.6
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9.2) Gecko/20100115 Firefox/3.6

The ogv video: http://videos.mozilla.org/firefox4beta/Firefox_4_beta.theora.ogv - behaves like in Comment 2 (fails to play after pause) 

http://flim.org/~kinetik/3d198wqepg78m_nosound.ogg - video plays and pause/play is allowed.

http://www.vorbis.com/music/The_Abyss-4T.ogg - video plays but after the first pause will refuse to play again. (behaves as in Comment 2)
Interesting, thank you!  That set of behaviours strongly implicates the audio backend code (libsydneyaudio, or how we're calling it).  I think I'll need to debug on a Win2k system to make any further progress diagnosing the bug.

This may be fixed when bug 623444 lands, since it's going to replace the code in question completely.  I'll make this bug depend on that one for now, and once the new code lands I'll get you to test a new nightly for this bug.

In the meantime, can you please update the bug with some details on the sound hardware and sound driver your system is using?
Depends on: cubeb
(In reply to comment #9)
> In the meantime, can you please update the bug with some details on the
> sound hardware and sound driver your system is using?

SoundMax Integrated Digital Audio
Driver Version: 5.12.1.5240
Summary: Ogv videos fail to play on Windows 2000 → Videos fail to play on Windows 2000
I can't reproduce this when running Win2k SP4 in Virtualbox (tested with Firefox 6.0.2).
Duplicate of this bug: 685810
Simona, can you confirm if this is reproducible in a VM or if you are testing in a native host installation of Windows 2000.
(In reply to Anthony Hughes, Mozilla QA (irc: ashughes) from comment #13)
> Simona, can you confirm if this is reproducible in a VM or if you are
> testing in a native host installation of Windows 2000.

Mozilla/5.0 (Windows NT 5.0; rv:7.0) Gecko/20100101 Firefox/7.0

Bug is reproducible in a Win2k native host environment.
Does this still happen with Firefox 9.0b2? If so, please work to find a regression range.
(In reply to Anthony Hughes, Mozilla QA (irc: ashughes) from comment #15)
> Does this still happen with Firefox 9.0b2? If so, please work to find a
> regression range.

I could reproduce the issue with the ogv videos on Firefox 9.0b2, Firefox 3.6 and Firefox 3.5. Should I search for a regression window on older versions of Firefox (Firefox 3.0, Firefox 2.0)?
No point in going any further back. At least we know this is not a regression.

Windows 2000 is likely going to be unsupported in the near future. I would say this is WONTFIX given the scope of this bug.
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → WONTFIX
No longer depends on: cubeb
I know we WONTFIXed this based on dropping support for Windows 2000, but I'm curious if a current nightly works for you since bug 623444 landed.
Simona, care to retest this in latest Firefox 15?
(In reply to Anthony Hughes, Mozilla QA (irc: ashughes) from comment #19)
> Simona, care to retest this in latest Firefox 15?

The latest Nightly install is refused on Win 2000.  

Mozilla/5.0 (Windows NT 5.0; rv:12.0a1) Gecko/20120131 Firefox/12.0a1
I could also not reproduce this issue on one of the latest supported builds.
Ah, good point Simona. Matthew, would you be able to spin a try-server build with the Win2k block disabled? Otherwise, I don't think we'll be able to test your request in comment 18.
I didn't realize we'd unsupported Win2k quite so directly.  In that case, it doesn't matter.  Thanks for letting me know.
You need to log in before you can comment on or make changes to this bug.