Preferences/Beta force add-ons compatibility option is not updated to the latest Beta build

VERIFIED FIXED in Firefox 7

Status

Fennec Graveyard
Extension Compatibility
VERIFIED FIXED
6 years ago
6 years ago

People

(Reporter: xti, Assigned: mbrubeck)

Tracking

Firefox 5
Firefox 7
ARM
Android

Details

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
Build id : Mozilla/5.0 (Android;Linux armv7l;rv:6.0)Gecko/20110713
Firefox/6.0 Fennec/6.0
Device: Motorola Droid 2
OS: Android 2.2

Steps to reproduce:
1. Open Fennec App
2. Go to Preferences > Beta tab
3. Enable force add-ons compatibility
4. Restart app
5. Go to about:config
6. Check if extensions.checkCompatibility preferences is updated for the running build

Expected result:
For Firefox 6 Beta 2, after step 6, about:config adds the following preference: extensions.checkCompatibility.6.0

Actual result:
After step 6, extensions.checkCompatibility.4.0b is added to about:config.
status-firefox6: --- → affected
status-firefox7: --- → affected
status-firefox8: --- → affected
Feedback add-on is hard coded to use "extensions.checkCompatibility.4.0b" in it's preference UI. We need to dynamically generate the preference like it's done here:
http://mxr.mozilla.org/mozilla-central/source/toolkit/mozapps/extensions/test/browser/browser_globalwarnings.js#19

A simpler, safer fix could be used in fx6 (beta) branch, if we want to even take it now. I don't think we do.
tracking-fennec: --- → 7+
Assignee: nobody → mark.finkle
(Assignee)

Comment 2

6 years ago
Created attachment 551824 [details] [diff] [review]
patch
Assignee: mark.finkle → mbrubeck
Status: NEW → ASSIGNED
Attachment #551824 - Flags: review?(mark.finkle)
Comment on attachment 551824 [details] [diff] [review]
patch

Nice
Attachment #551824 - Flags: review?(mark.finkle) → review+
(Assignee)

Comment 4

6 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/ee51239376b5
Whiteboard: [inbound]
(Assignee)

Comment 5

6 years ago
Comment on attachment 551824 [details] [diff] [review]
patch

Requesting mozilla-approval-aurora.  This patch is mobile-only, and the code it touches ships only in Nightly/Aurora/Beta builds (not release).  This is not a new regression (it first regressed in 5.0 beta), but it would be good to get this into our next beta migration.  Currently we are shipping an add-on to Beta users with a checkbox that fails to do anything.
Attachment #551824 - Flags: approval-mozilla-aurora?
Comment on attachment 551824 [details] [diff] [review]
patch

Git er done before monday migration, please!
Attachment #551824 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
(Assignee)

Comment 7

6 years ago
Landed on Aurora for Firefox 7:
https://hg.mozilla.org/releases/mozilla-aurora/rev/7894b27a5a9a
status-firefox6: affected → wontfix
status-firefox7: affected → fixed
status-firefox8: affected → ---
Target Milestone: --- → Firefox 7
Version: Firefox 6 → Firefox 5
(Assignee)

Comment 8

6 years ago
The previous push to inbound was missing part of the patch because of a manual rebase error.  Pushed it as a followup:
https://hg.mozilla.org/integration/mozilla-inbound/rev/ad7544a6078b
http://hg.mozilla.org/mozilla-central/rev/ee51239376b5
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Whiteboard: [inbound]
Target Milestone: Firefox 7 → Firefox 8
http://hg.mozilla.org/mozilla-central/rev/ad7544a6078b
(Assignee)

Updated

6 years ago
Target Milestone: Firefox 8 → Firefox 7
(Assignee)

Updated

6 years ago
Depends on: 678261

Comment 11

6 years ago
Verified fixed on: Mozilla /5.0 (Android;Linux armv7l;rv:7.0) Gecko/20110816 Firefox/7.0 Fennec/7.0
Device: LG Optimus 2X
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.