Closed Bug 672141 Opened 11 years ago Closed 11 years ago

'Enter' doesn't behave correctly when renaming tab group

Categories

(Firefox Graveyard :: Panorama, defect)

5 Branch
x86_64
Windows 7
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 649307

People

(Reporter: demonofsarila, Unassigned)

Details

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:5.0) Gecko/20100101 Firefox/5.0
Build ID: 20110615151330

Steps to reproduce:

In the tab group view: I clicked on the name of a tab group to change it's name, typed in the box, and naturally hit 'enter' on my key board since I was finished naming the tab group.


Actual results:

It closed the tab groups view and opened one of my web pages with the tabs in the same group as it. It's very jarring when Firefox does this, since it's completely unexpected when it happens. In order to continue naming my groups, I have to re-enter the tab group view.


Expected results:

Firefox should have simply unfocused the text box and accept that as the name of the group, and stayed in the tab group view.
Reproduced:
Mozilla/5.0 (X11; Linux x86_64; rv:5.0) Gecko/20100101 Firefox/5.0

Works for me:
Mozilla/5.0 (X11; Linux x86_64; rv:6.0) Gecko/20100101 Firefox/6.0
Mozilla/5.0 (X11; Linux x86_64; rv:7.0a2) Gecko/20110717 Firefox/7.0a2
Mozilla/5.0 (X11; Linux x86_64; rv:8.0a1) Gecko/20110717 Firefox/8.0a1

Thus, this seems to be fixed in latest versions of Firefox - at least when running Linux.
OS: Other → Windows 7
Hardware: All → x86_64
Duplicate of bug 649307?
Component: Keyboard Navigation → Panorama
QA Contact: keyboard.navigation → panorama
Summary: 'Enter' doesn't behave correctly → 'Enter' doesn't behave correctly when renaming tab group
Definitely a dupe of bug 649307 - issue was fixed in the meantime in Fx6.
Status: UNCONFIRMED → RESOLVED
Closed: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 649307
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.