New icons for each Win7 Jump list task

RESOLVED DUPLICATE of bug 515785

Status

()

RESOLVED DUPLICATE of bug 515785
7 years ago
6 years ago

People

(Reporter: bbondy, Assigned: shorlander)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(4 attachments, 4 obsolete attachments)

(Reporter)

Description

7 years ago
Created attachment 546496 [details]
Showing the new icons

When you click and hold the firefox icon in Windows 7 you will see a jump list popup.

We would like to have 3 new icons for the jump list entries in the Tasks section (See screenshot):
- open new window
- open new tab
- enter private browsing

These icons are usually used at 16x16, but depending on the DPI can be any of:
16x16
20x20
24x24
32x32

ICO format containing PNGs would be optimal but if the images are supplied separately I can construct that ICO in the context of the blocked task.  I'm sure we also want to keep the source file (.psd, .ai, ... whatever it is)

Comment 1

7 years ago
Alex/Steve - not sure who handles creating our application icons. This bug tracks creating new ico/png files that would get embedded in the exe.
(Reporter)

Comment 2

7 years ago
By the way we can trivially scale the icons to the needed size, but I'm not sure if an ICO containing all 4 sizes would be a better picture if all 4 sizes are supplied separately.  

I guess it is a trade off on file size vs. optimal look on all DPI.

Comment 3

7 years ago
Limi, curious if you know who we would assign this bug to. Details on the image format are in comment 1. 

We would really like to get this menu finished up. The last thing we need are a few custom icons.

Comment 4

7 years ago
Created attachment 583587 [details]
jumplist screen shot
Attachment #546496 - Attachment is obsolete: true
Sean: Would you be able to help out Jim and Brian here?

Comment 6

7 years ago
Are new icons really needed ? Because for example the venitian mask could perfectly fit for private browsing navigation.
(Reporter)

Comment 7

7 years ago
The mask sounds good for private browsing, what is preferred for new window and new tab?

Comment 8

7 years ago
As far as I remember Faaborg had some icons for new tab (a plus), but I don't know if he had something for new window.

Comment 9

7 years ago
I'd check with Horlander on this as I'm not familiar with what is current/planned within the product.
(Assignee)

Comment 10

7 years ago
Yeah we have icons we can use for most of these already. Just need to convert the PNGs to ICO.
(Assignee)

Updated

7 years ago
Assignee: nobody → shorlander
(Assignee)

Comment 11

6 years ago
Created attachment 618783 [details]
New Window Icon
(Assignee)

Comment 12

6 years ago
Created attachment 618784 [details]
New Tab Icon
(Assignee)

Comment 13

6 years ago
Created attachment 618785 [details]
Private Browsing Mode Icon
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
(Reporter)

Comment 14

6 years ago
Awesome, thank you!
(Assignee)

Updated

6 years ago
Attachment #618783 - Attachment is obsolete: true
(Assignee)

Updated

6 years ago
Attachment #618784 - Attachment is obsolete: true
(Assignee)

Updated

6 years ago
Attachment #618785 - Attachment is obsolete: true
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Comment 15

6 years ago
Shouldn't there also be an icon for "quit private browsing" ?
Status: REOPENED → RESOLVED
Last Resolved: 6 years ago6 years ago
Resolution: --- → FIXED
Nothing landed here and I'm not sure why these images weren't just attached in bug 515785...
Resolution: FIXED → DUPLICATE
Duplicate of bug: 515785
You need to log in before you can comment on or make changes to this bug.