The default bug view has changed. See this FAQ.

Use new icons for each task in Win7 Jump list tasks

RESOLVED FIXED in Firefox 15

Status

()

Firefox
General
P2
normal
RESOLVED FIXED
8 years ago
5 years ago

People

(Reporter: jimm, Assigned: jaws)

Tracking

(Depends on: 2 bugs)

Trunk
Firefox 15
x86
Windows 7
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite -

Firefox Tracking Flags

(status2.0 ?)

Details

Attachments

(2 attachments, 1 obsolete attachment)

(Reporter)

Description

8 years ago
The new win7 taskbar jump list supports custom tasks. Currently four tasks are supported in the working patch, three of which we hope to enable by default for the release:

open new window
open new tab
private browsing mode
profile manager

private browsing mode and profile manager may be hidden by default due to some limitations in launching them when there are running instances, but custom icons for each would still be nice. private browsing we deffinitely be enabled by default at some point.

These icons would most likely be embedded in firefox.exe. They should support the same color depths and resolutions as as the default firefox and firefox document icons.
(Reporter)

Comment 1

8 years ago
Created attachment 399828 [details]
tasks list screenshots

Updated

8 years ago
Component: Theme → General
QA Contact: theme → general
(Reporter)

Updated

8 years ago
No longer blocks: 473045
(Reporter)

Updated

8 years ago
Blocks: 518666
(Reporter)

Updated

8 years ago
No longer blocks: 518666
(Reporter)

Updated

8 years ago
Blocks: 519985

Comment 2

7 years ago
Any updates on this?
Also Chrome, Opera and IE8+ also use favicons for recently/frequent visited sites, Firefox uses default html-icon.

Comment 3

7 years ago
nvm, just discovered Bug 549472
(Reporter)

Updated

7 years ago
status2.0: --- → ?
(Reporter)

Comment 4

7 years ago
We don't have 'profiles' anymore. The current tasks are

open new window
open new tab
enter private browsing
(Reporter)

Comment 5

7 years ago
(In reply to comment #3)
> nvm, just discovered Bug 549472

I had hoped to get that done for the release, but I'm not sure I will. (We have a lot of cleanup work to do.)
(Reporter)

Updated

6 years ago
Depends on: 549472
(Reporter)

Updated

6 years ago
No longer blocks: 519985
Depends on: 519985
Should there be another task defined for this for a graphic designer to make the custom images?  I can do the rest for this task once I know which images to use.
Assignee: nobody → netzen
(Reporter)

Comment 7

6 years ago
(In reply to comment #6)
> Should there be another task defined for this for a graphic designer to make
> the custom images?  I can do the rest for this task once I know which images
> to use.

Yes, I'd file a new bug (theme maybe?) and cc shorlander and faaborg.
Depends on: 661502
Depends on: 672177
Posted here: Bug 672177 - New icons for each Win7 Jump list task
Summary: Win7 Jump list task list requires an icon for each task → Use new icons for each task in Win7 Jump list tasks
Assignee: netzen → nobody
Assignee: nobody → jwein
Status: NEW → ASSIGNED
Target Milestone: Firefox 3.6 → ---
Created attachment 619069 [details] [diff] [review]
WIP of patch

This patch includes everything that we should need with the exception of the correct icons.
Created attachment 619135 [details] [diff] [review]
Patch for bug

This patch includes the new icons. Thanks Stephen :)

Here is a screenshot of it: http://screencast.com/t/8EAPf2E7o7E
Attachment #619069 - Attachment is obsolete: true
Attachment #619135 - Flags: review?(netzen)
Comment on attachment 619135 [details] [diff] [review]
Patch for bug

Review of attachment 619135 [details] [diff] [review]:
-----------------------------------------------------------------

Nice work, looks good.
As long as it passes try tests we're good to go.
Attachment #619135 - Flags: review?(netzen) → review+
Pushed to try: https://tbpl.mozilla.org/?tree=Try&rev=5cf59016afe7
https://hg.mozilla.org/integration/mozilla-inbound/rev/d913b3d444e4
Flags: in-testsuite-
Target Milestone: --- → Firefox 15

Updated

5 years ago
Duplicate of this bug: 672177
http://hg.mozilla.org/mozilla-central/rev/d913b3d444e4
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Aww, you guys don't do anything clever with extracting icons out of theme PNGs at build time. That's what Tb does (bug 659788).
You need to log in before you can comment on or make changes to this bug.