Dom Inspector does not work for Fennec anymore

REOPENED
Unassigned

Status

Other Applications
DOM Inspector
REOPENED
7 years ago
9 months ago

People

(Reporter: Martijn Wargers (dead), Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
When pressing ctrl-shift-i, I see this error in the error console:
content is null
chrome://browser/content/browser.xul
1

I guess the problem is in tasksOverlay-mobile.xul :
    <command id="Tasks:InspectPage" oncommand="inspectDOMDocument(content.document);"/>
Where content is apparently null.

I really would like to be able to use the DOM Inspector again for Fennec on Windows. It would allow me to relatively easy find out what is going on regarding to bug 672004.
Is this recent?  When bumping versions numbers on AMO recently, I also bumped up mobile for good measure.  It was at something like 1.0a1 or 1.0b or something.  I have no idea how people were using DOM Inspector on Fennec before, unless there was manual install.rdf tweaking happening.

The fact that |content| is null is interesting, and I'm guessing has something to do with electrolysis?  Any hints about what should be there instead?
Yes, it's electrolysis. "content" is NULL for remote pages. I think we should just use ctrl+shift+i to open the inspector window, but not load a document.

That would allow the shortcut to still work, and the chrome or locale webpage could be opened from the inspector window.
(Reporter)

Comment 3

7 years ago
Sorry for the confusion, but apparently today it seems to work for me.
I installed the dom inspector and ctrl-shift-i works for me, currently. Not sure what changed since 2 days ago.

I guess this bug can be closed. Sorry for the disturbance.
(In reply to comment #3)
> apparently today it seems to work for me.

I was just about to say the same thing. :)
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → INVALID
(Reporter)

Comment 5

7 years ago
Ok, it turns out I can open about: pages just fine, when pressing ctrl-shift-i, but when I try to open the dom inspector on a website, then I get this error.

So this is indeed e10s related, I think.

So I don't think this is invalid, right?
Status: RESOLVED → REOPENED
Resolution: INVALID → ---
(Reporter)

Comment 6

7 years ago
It's not a big issue, I think, though, because my main problem was not being able to open the dom inspector at all under Fennec.
The dom inspector is currently not really suited for Fennec, anyway.
As I mentioned in comment 2, let's just stop trying to open the active browser tab in the DOMi window on ctrl+shift+i

Let's just open the DOMi window without any content document, OR we should check for a NULL "content" before trying to use "content.document"
(Reporter)

Updated

9 months ago
Status: REOPENED → RESOLVED
Last Resolved: 7 years ago9 months ago
Resolution: --- → WORKSFORME
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
You need to log in before you can comment on or make changes to this bug.