IMAP: messages deleted in another client are not deleted in Thunderbird/SeaMonkey after synchronization

RESOLVED DUPLICATE of bug 693204

Status

MailNews Core
Networking: IMAP
RESOLVED DUPLICATE of bug 693204
6 years ago
3 years ago

People

(Reporter: Tom Metro, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.2.17) Gecko/20110422 Ubuntu/9.10 (karmic) Firefox/3.6.17
Build ID: 20110422070846

Steps to reproduce:

1. Login to SquirrelMail (v.1.4.21) to access an IMAP account hosted at Dreamhost and  observe a new, unread message in the INBOX.
2. In Thunderbird (3.1.9pre on Linux, or 3.1.x on Windows) select the 
INBOX of the same account and observe the same message is listed.
3. In SquirrelMail mark the message as deleted.
4. In TB observe that nothing has changed.
5. In TB, select "Get new messages for > " for the chosen account, observe nothing has changed, except the unread count on the Trash folder has increased by one (as expected).
6. In TB select a different folder and return to the INBOX. Observe nothing has changed.
7. In SquirrelMail, logout (trigger an expunge, presumably), then repeat #5 and #6. Observe nothing has changed.
8. In TB compact the INBOX. Observe nothing has changed.
9. In TB select "Repair Folder" from the folder properties dialog. Observe that the message deleted in SquirrelMail has now finally disappeared.


Actual results:

Message deleted in another IMAP client was not shown as removed in Thunderbird, if TB has already cached the message.


Expected results:

Deleted message should have been removed from the message listing.

That the message finally does get removed when the folder index is rebuilt suggests that the problem is on the TB side, rather than with SquirrelMail, and that it is a bug.

Both TB installations (first observed on one of my client's machines (Windows Vista; stable TB release) and reproduced with the Shredder build I have installed on Ubuntu) should be using the default settings for the delete model and offline synchronization.

Prior art:
Bug 465800 covers several issues, but one of them is spot-on identical.
Bug 248397 describes identical symptoms, but was abandoned.
Bug 40701 describes an identical setup, but with different resulting symptoms, and likely isn't relevant.
I've seen similar issues all the way back to 3 versions.  My scenario is I have 2 Thunderbird clients running 5.0 on two different Mac's configured 100% the same and getting their mail via IMAP from a Zimbra server.  I'm also retrieving my mail via my iPhone 4.  

All three clients show a different message count as I've deleted messages from all three at different times throughout the day.  If I check the Zimbra web interface it matches my iPhone client.  The two Thunderbird clients do not match each other or Zimbra.  If I press the Get Mail button in order to synchronize my client, nothing changes.  If I restart Thunderbird everything updates and we're current among all devices for the time being.  Some message from Zimbra to Thunderbird is dropping somewhere even though I'm still getting my new messages...my deleted messages are just not disappearing until I restart the Thunderbird client.

The strange thing is this isn't always the behavior.  Meaning it isn't 100% reproducible...as an example...while writing this I was able to reproduce it once by deleting an email on the iPhone that didn't delete on either Thunderbird client.  I then pressed the Get Mail button on each client and it has been working ever since.  So maybe it is something that happens after the client has been idle for some time.
Is autosynch enabled on your copies of Thunderbird ?

Can you get us imaps and ImapAutoSync logs as described at <https://wiki.mozilla.org/MailNews:Logging>
Component: General → Networking: IMAP
Product: Thunderbird → MailNews Core
QA Contact: general → networking.imap
Version: 3.1 → Trunk
(Reporter)

Comment 3

6 years ago
(In reply to Ludovic Hirlimann [:Usul] from comment #2)
> Is autosynch enabled on your copies of Thunderbird ?

If it isn't on by default, then most likely no. Where is the setting for it?


> Can you get us imaps and ImapAutoSync logs as described at
> <https://wiki.mozilla.org/MailNews:Logging>

Yes. I will follow up with logs in a few weeks.
(In reply to Tom Metro from comment #3)
> (In reply to Ludovic Hirlimann [:Usul] from comment #2)
> > Is autosynch enabled on your copies of Thunderbird ?
> 
> If it isn't on by default, then most likely no. Where is the setting for it?
> 
I second that...where is the setting for this?

Comment 5

6 years ago
Is this a dup of bug 665855 ?

As another data point, I have also been having this problem since Thunderbird 3. TB is not my primary client, I use emacs-wanderlust on linux, and k-9 mail on android, and often TB fails to indicate deleted messages. Quitting and restarting TB does not help.
(In reply to Tom Metro from comment #3)
> (In reply to Ludovic Hirlimann [:Usul] from comment #2)
> > Is autosynch enabled on your copies of Thunderbird ?
> 
> If it isn't on by default, then most likely no. Where is the setting for it?

It's on by default. The value of mail.server.default.autosync_offline_stores is true when enabled.


(In reply to Len Trigg from comment #5)
> Is this a dup of bug 665855 ?

We'll need to have imap logs to be sure.
So it appears, at least in my case, that I've fixed the problem.  After some extensive testing I've found that the problem was on the side of Mozilla's mail server...the server my Thunderbird client is connecting to.  It was actually more a limitation of the mail server setup than a problem.

I had selected all of my folders for synchronization and I have quite a few.  The problem appeared to be related to the number of concurrent connections attempting to be initiated by Thunderbird exceeded what the mail server could handle.  This setting is found under Tools --> Account Settings and then within your Account Settings under Server Settings, within the Server Settings space there is an Advanced button...press that.  You'll then get a drop down with Advanced Server Settings options...the important one here is the 'Maximum number of server connections to cache'.  Mine was set at default to 5...once I changed it to 1 everything keeps sync PERFECTLY.  

I've been running it like this for two days straight and this is the first time I haven't had to close Thunderbird and restart it in order for it to notice when I've deleted or changed an item from another client.  ALL clients, (iPhone, WebMail, Other Thunderbird), are all matching for the first time ever...when before both of my Thunderbird clients would show stale information until I restarted them.

I don't know if this will work for everyone but it definitely did the trick for me.  Please let me know if you need me to explain this in more detail.

Comment 8

4 years ago
This bug hasn't recorded any activity in almost 2 years.  I have hit this issue many times and I'm wondering how many countless others who don't even bother to search on it have this issue as well.  With smart phones being more common, I would think this should be a more pressing issue now.  Having to restart TB to refresh the inbox is invasive to our productivity.  Is there an easier way to work-around this issue?  Does any plug-in help?
Do you eable IDLE?
If yes, does your IMAP server notify "\Deleted falg status change" to Tb via IDLE?

If IDLE is supported by your IMAP server and "Use IDLE command" is enabled in Tb, this bug is perhaps same issue as bug 693204 :
  IMAP server doesn't notify "addition/removal of IMAP flag",.
  although Tb expects notification of "addition/removal of IMAP flag".
So, same workaround is applicable:
- Go Work Offline, go back to Work Online, re-open Inbox
- Max cached connections=1, click other folder and click Inbox8re-open)

Because this bug is for "\Deleted flag" following is perhaps another workaround.
- Expunge mails flagged as \Deleted by an IMAP client.
  (If Tb, Compact of context menu of the folder)
  Because expunged message number is usually notified via IDLE,
  Tb removes the mail which was flagged as \Deleted and expunged.

Comment 10

4 years ago
In my account settings, If IDLE is supported by your IMAP server and "Use IDLE command" is enabled. I am using imap.gmail.com as my imap server which I believe supports the IDLE command.  When the issue happens (it's not consistent), going offline and back online does not do it.  I believe I tried compact before, which also didn't work IIRC.  Exiting TB and getting back in is the only way so far that I have found.

Comment 11

4 years ago
User agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:23.0) Gecko/20100101 Firefox/23.0 SeaMonkey/2.20
Build identifier: 20130729213456

After having SeaMonkey mirroring my $DAYJOB G-mail hosted account without problems for well over a year, this problem started a few weeks ago.  $DAYJOB is running Outlook on top of Google Apps Sync 3.3.335.950 on an old XP box.  I haven't had time to explore, but wanted to chime in that it is happening  SeaMonkey.  The fact that it just started may offer a clue.  I need to check out the things above and roll back to a previous 2.2 beta to see if there was some change in SM which triggered this.  Mail deleted in SM is being reflected in Outlook, usually within tens of seconds.  It just doesn't work the other way anymore.

I have to wonder why OP Tom experienced this this two years ago and it just started for me.  Tom, are you still having the problem?
Summary: IMAP: messages deleted in another client are not deleted in Thunderbird after synchronization → IMAP: messages deleted in another client are not deleted in Thunderbird/SeaMonkey after synchronization
(Reporter)

Comment 12

4 years ago
(In reply to Rich Gray (:rbgray) from comment #11)
> Tom, are you still having the problem?

My client is the one who experienced the problem, and it takes a bit of time to set up an environment for me to reproduce it. (Which is probably why I didn't follow-up with the requested logs.)

I did receive a report from that client that they still saw messages in TB that had been deleted on their iPhone, but I didn't investigate and verify. This most recent occurrence would have been with a Thunderbird version released within the past 12 months running on Windows 7.
(In reply to Don Beusee from comment #10)
> I am using imap.gmail.com as my imap server (snip)
> When the issue happens (it's not consistent), going offline and back online does not do it.

Did you do "re-open Inbox" step after "Work Offline/Work Online"?
(re-open == click other than Inbox including account, and click Inbox)
If yes, it may be due to CONDSTORE. Read bug 885220 and check with mail.server.server#.use_condstore=false.

Comment 14

4 years ago
I had this issue again today.  Today, compact did the trick.  I think I did reopen the inbox, but I'll make sure next time...

Comment 15

4 years ago
User agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:24.0) Gecko/20100101 Firefox/24.0 SeaMonkey/2.21
Build identifier: 20130819194341

WFM now.  The problem has gone away after upgrading to SM 2.21b1 this morning.

Comment 16

4 years ago
Still seeing this problem. Offline->back Online brings it back.

24.1.1 on linux (x64) and windows 7 (x64), IMAP to Office365.

Comment 17

3 years ago
I can confirm that this issue exists. 

I have Thunderbird on my Windows 7 machine and I access my mail from Gmail on imap from TB and my phone. Whenever I delete or mark a message read on my phone, nothing happens in Thunderbird even if I click get mail or click back and forth between accounts. The only way to get Thunderbird to update is to restart it. However, it works the other way. If I change a message in Thunderbird, it updates properly on my Phone.

This started when I installed Thunderbird on my new motherboard. I didn't have this problem with syncing email in the past.
Because bug 693204 was processed after analysis of many bugs, that bug is crispy than other bugs.
So, duping this bug to bug 693204.
If duping is wrong, re-open this bug, please.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 693204
You need to log in before you can comment on or make changes to this bug.