Last Comment Bug 672732 - Don't report per-compartment measurements that have zero bytes
: Don't report per-compartment measurements that have zero bytes
Status: RESOLVED FIXED
[MemShrink]
:
Product: Core
Classification: Components
Component: XPConnect (show other bugs)
: unspecified
: x86_64 Linux
: -- normal (vote)
: mozilla8
Assigned To: Nicholas Nethercote [:njn]
:
Mentors:
Depends on:
Blocks: MemShrinkTools
  Show dependency treegraph
 
Reported: 2011-07-19 23:37 PDT by Nicholas Nethercote [:njn]
Modified: 2011-07-22 14:11 PDT (History)
5 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch (7.98 KB, patch)
2011-07-20 22:37 PDT, Nicholas Nethercote [:njn]
gal: review+
Details | Diff | Splinter Review

Description Nicholas Nethercote [:njn] 2011-07-19 23:37:29 PDT
Here's an example compartment report:

   ├────3,940,269 B (01.07%) -- compartment(https://blog.mozilla.com/nnethercote/wp-login.php)
│  │    ├──2,736,128 B (00.74%) -- gc-heap
│  │    │  ├──1,330,152 B (00.36%) -- arena-unused
│  │    │  ├────781,760 B (00.21%) -- shapes
│  │    │  ├────557,888 B (00.15%) -- objects
│  │    │  ├─────34,616 B (00.01%) -- arena-padding
│  │    │  ├─────16,032 B (00.00%) -- arena-headers
│  │    │  ├─────15,680 B (00.00%) -- strings
│  │    │  └──────────0 B (00.00%) -- xml
│  │    ├────655,360 B (00.18%) -- mjit-code
│  │    ├────487,941 B (00.13%) -- scripts
│  │    ├─────47,344 B (00.01%) -- object-slots
│  │    ├─────13,496 B (00.00%) -- string-chars
│  │    ├──────────0 B (00.00%) -- mjit-data
│  │    ├──────────0 B (00.00%) -- tjit-code
│  │    └──────────0 B (00.00%) -- tjit-data
│  │               ├──0 B (00.00%) -- allocators-main
│  │               └──0 B (00.00%) -- allocators-reserve

Six entries are zero.  Printing them all is a bit pointless, especially since we can have lots of compartments.  I propose not reporting the zero entries to save space.

A side-benefit: it'll help us forget that E4X support exists :P
Comment 1 Nicholas Nethercote [:njn] 2011-07-20 22:37:02 PDT
Created attachment 547323 [details] [diff] [review]
patch

Simple patch.
Comment 2 Nicholas Nethercote [:njn] 2011-07-21 17:40:07 PDT
http://hg.mozilla.org/integration/mozilla-inbound/rev/e9b6850cc324

Note You need to log in before you can comment on or make changes to this bug.