Closed Bug 672782 Opened 9 years ago Closed 8 years ago

Progress bar animation from RTL build has inconsistent behavior

Categories

(Core :: Widget: Win32, defect)

All
Windows 7
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 661364

People

(Reporter: george.carstoiu, Unassigned)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

Mozilla/5.0 (Windows NT 6.1; WOW64; rv:6.0) Gecko/20100101 Firefox/6.0 -'ar'

Although the animation goes now from right to left, its behavior is not consistent - sometimes it disappears and reapers a few centimeters away, it doesn't always start from the beginning of the progress bar.

Steps to reproduce:
 1. Start a RTL build
 2. Download anything
 3. Observe progress bar animation

Actual results:
 - sometimes it disappears and reapers a few centimeters away, it doesn't always start from the beginning of the progress bar.

Expected results:
 - the animation has consistent behavior
Blocks: 641942
Does it appear on trunk? Can you take a video of this?
Hardware: x86 → All
Attached video Screencast
Mozilla/5.0 (Windows NT 6.1; rv:8.0a1) Gecko/20110724 Firefox/8.0a1

The screencast is from Firefox 6.0 beta 3. The same behavior can be also observed on the Nightly build.

Do you need anything else on this issue?
George, the entire animation seems to be really hashed. Is the computer slow? was it in a heavy CPU usage?
Version: 6 Branch → Trunk
It is a P4 3 Ghz computer with 2 GB of RAM and a Nvidia 210M dedicated graphics card. No, there wasn't any CPU intensive application running in the background - this is what I get every time.
Depends on: 726144
Likely dupe -> bug 661364 which I have a fix for.
It actually seems to be the only explanation of this bug. Marking as dup.

George, if that doesn't sound correct, please, let us know.
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 661364
Seems right Mounir. Thanks for finding the dupe.
No longer depends on: 726144
Blocks: 726144
You need to log in before you can comment on or make changes to this bug.