FTP directory listing generated by SQUID proxy stalls mozilla

VERIFIED WORKSFORME

Status

()

Core
Networking: FTP
--
critical
VERIFIED WORKSFORME
18 years ago
17 years ago

People

(Reporter: Tom Mraz, Assigned: dougt)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
My mozilla (Linux nightly 2001012921 on RH Linux 7.0) stalls when downloading
FTP directory listing generated by Squid proxy. All browser windows became
stalled and mozilla get 100 %CPU. It must be a recent regression as I was able
to browse FTP through the proxy for long time.

Comment 1

18 years ago
See also bug 66139

Comment 2

18 years ago
Two different bugs, actually.
The squid-bug is bug 59310: "ftp proxy is not forced to update with mozilla"
Marking dup.
The 100% CPU is another phenomena - bug 65220 "FTP clobbers CPU"




*** This bug has been marked as a duplicate of 59310 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 3

18 years ago
this matches, except for one thing : the regression.
So i'm not verifying this quite yet.
(Reporter)

Comment 4

18 years ago
I'm sorry but both these bugs mentioned that should be this bug a duplicate of
are really different bugs. Here the mozilla is completely stalled - the windows
doesn't repaint at all and they cannot be closed. I have to kill it from console.
And the bug 59310 is completely different except it is with squid proxy too.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---

Comment 5

18 years ago
Some triage from the Networking folks would be appreciated here

Comment 6

18 years ago
Adding qawanted keyword.
Keywords: qawanted
(Reporter)

Comment 7

18 years ago
This is now WORKSFORME as the dougt's bidi transfer branch landed.
I'll reopen if I see it again.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → WORKSFORME

Comment 8

17 years ago
verified wfm
Status: RESOLVED → VERIFIED

Updated

17 years ago
Keywords: qawanted
You need to log in before you can comment on or make changes to this bug.