Closed Bug 59310 Opened 19 years ago Closed 19 years ago

Proxy: ftp is not forced to update with mozilla

Categories

(Core :: Networking: FTP, defect, P3, major)

defect

Tracking

()

VERIFIED FIXED
mozilla0.9.1

People

(Reporter: ezh, Assigned: dougt)

References

Details

(Whiteboard: fixed on branch)

Attachments

(1 file)

I use my provider proxy (Squid/2.3.STABLE4-hno.20000819).

When I go to the ftp://ftp.mozilla.org/pub/mozilla/nightly/
Mozilla do not requires the proxy to update it database. Even when I press 
reload, shift-relod.

When I load 4.76 and come to the link proxy updates, so I can see a new, updated 
ftp link in Mozilla.

I think it is critical and may affect http:// pages as well. Marking it critical 
for quicker investigating.
Not critical. =>Networking
Is mozilla set to use the proxy for ftp?
Reporter: you should know better than to file bugs w/o including build id's
http should be considered as a separate bug for now.
Assignee: asa → gagan
Severity: critical → normal
Component: Browser-General → Networking
QA Contact: doronr → tever
Summary: proxy is not forced to update with mozilla → ftp proxy is not forced to update with mozilla
Build is 2000110508-Mtrunk.
It is dogfood. I cannot update the proxy from Mozilla.

At this moment I get a filelist from 07 Nov 2000 00:56:09, but now we have have
18.00 local time. There is no way to refresh it from mozilla.
Keywords: dogfood
Whiteboard: [dogfood-]
It also happens on Linux. Attached is an excerpt from a squid log. I pointed
Mozilla at an ftp URL via squid. Squid thought the URL was stale plus Mozilla
had an old copy in its cache so it issued an If-Modified-Since header. Squid
dutifully contacted the ftp server. I then tries Reload and shift-Reload but
Mozilla issued no headers to tell squid that it wanted an update so squid
returned its cached copy. I then tried Lynx. It didn't say anything special so
squid still used the cached copy. When I did a Ctrl-R in Lynx, it issued
suitable headers and squid re-veified.

It's clearly a Mozilla problem and it probably occurs on all platforms.
Attached file squid log
OS: Windows 2000 → All
ftp bugs to component:ftp
Assignee: gagan → dougt
Component: Networking → Networking: FTP
Target Milestone: --- → M19
Blocks: 61691
->major - only known workaround is to use other browser for ftp (in that situation).
Severity: normal → major
Keywords: mozilla0.9
Hardware: PC → All
Blocks: 62353
*** Bug 67289 has been marked as a duplicate of this bug. ***
Keywords: nsbeta1
Target Milestone: --- → mozilla0.9.1
OK. I tried out this with 2001032704 (talkback) on win98 and it did worked. I'll
try this on yesterday's build, so we can deside if this was fixed by 73447 or
earlier.

Please verify yourself if this works now.
Forgot to mention that the proxy updates (at least) when Shift-Reload.
Cannot verify with yesterday's build due to bug 73099 - it does displays a ftp I
visited and nothing helps. :(((
Keywords: nsdogfood-
Keywords: nsdogfood
Depends on: 76866
Whiteboard: [dogfood-] → fixed on branch
Fixes checked in.  QA please verify.
Status: NEW → RESOLVED
Closed: 19 years ago
Resolution: --- → FIXED
verified:
WinNT 2001061304
Mac os9 2001061308
Linux rh6 2001061308
Status: RESOLVED → VERIFIED
+makingtest
Need to add to proxy tests
Keywords: makingtest
Summary: ftp proxy is not forced to update with mozilla → Proxy: ftp is not forced to update with mozilla
You need to log in before you can comment on or make changes to this bug.