Last Comment Bug 673164 - Sync button in tab bar changes to Back button while syncing
: Sync button in tab bar changes to Back button while syncing
Status: RESOLVED FIXED
:
Product: Firefox
Classification: Client Software
Component: Theme (show other bugs)
: 8 Branch
: All Windows 7
: -- normal (vote)
: ---
Assigned To: Joshua M [:soapy]
:
Mentors:
Depends on:
Blocks: 671553
  Show dependency treegraph
 
Reported: 2011-07-21 10:58 PDT by Siddhartha Dugar [:sdrocking]
Modified: 2011-08-04 04:52 PDT (History)
5 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch for 673164 v1 (2.82 KB, patch)
2011-08-02 16:02 PDT, Joshua M [:soapy]
no flags Details | Diff | Review
Patch for 673164 v2 (3.79 KB, patch)
2011-08-03 11:00 PDT, Joshua M [:soapy]
dao+bmo: review+
Details | Diff | Review

Description Siddhartha Dugar [:sdrocking] 2011-07-21 10:58:04 PDT
User Agent: Mozilla/5.0 (Windows NT 6.1; rv:8.0a1) Gecko/20110721 Firefox/8.0a1
Build ID: 20110721065410

Steps to reproduce:

With the default theme active and tabs on top, put the sync button in the tab bar. Now do a sync.


Actual results:

Sync button changes to back-button while syncing.
Comment 1 :Margaret Leibovic 2011-07-21 13:05:45 PDT
Which platform are you on? I can't reproduce this on OSX.
Comment 2 Leman Bennett [Omega] 2011-07-22 07:40:17 PDT
Confirmed on Windows 7.
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:8.0a1) Gecko/20110722 Firefox/8.0a1 ID:20110722030827
Comment 3 Siddhartha Dugar [:sdrocking] 2011-07-27 05:26:30 PDT
Should this block Firefox 8?
Comment 4 Joshua M [:soapy] 2011-08-02 16:02:29 PDT
Created attachment 550238 [details] [diff] [review]
Patch for 673164 	v1

Temporary patch until an inverted sync throbber is made.
Comment 5 Dão Gottwald [:dao] 2011-08-02 23:02:19 PDT
Comment on attachment 550238 [details] [diff] [review]
Patch for 673164 	v1

Doesn't http://mxr.mozilla.org/mozilla-central/source/browser/themes/winstripe/browser/browser.css#673 need to be updated as well?
Comment 6 Siddhartha Dugar [:sdrocking] 2011-08-03 00:12:59 PDT
Please note that this issue doesn't happen with dark personas
Comment 7 Joshua M [:soapy] 2011-08-03 07:02:09 PDT
(In reply to comment #5)
> Comment on attachment 550238 [details] [diff] [review] [diff] [details] [review]
> Patch for 673164 	v1
> 
> Doesn't
> http://mxr.mozilla.org/mozilla-central/source/browser/themes/winstripe/
> browser/browser.css#673 need to be updated as well?

I don't think it is necessary because it is already specified on line 1117 http://mxr.mozilla.org/mozilla-central/source/browser/themes/winstripe/browser/browser.css#1117, but I can go ahead and make that change and upload another patch if you would like.
Comment 8 Joshua M [:soapy] 2011-08-03 11:00:28 PDT
Created attachment 550429 [details] [diff] [review]
Patch for 673164 	v2

Addressed comments by Dão.
Comment 9 Dão Gottwald [:dao] 2011-08-04 04:50:48 PDT
Comment on attachment 550429 [details] [diff] [review]
Patch for 673164 	v2

Looks good, thanks!
Comment 10 Dão Gottwald [:dao] 2011-08-04 04:52:50 PDT
http://hg.mozilla.org/mozilla-central/rev/b59ee1dfe623

Note You need to log in before you can comment on or make changes to this bug.