Last Comment Bug 673168 - 7/21 nightly crashes on startup after update
: 7/21 nightly crashes on startup after update
Status: VERIFIED FIXED
: regression
Product: Fennec Graveyard
Classification: Graveyard
Component: General (show other bugs)
: Firefox 8
: ARM Android
: -- blocker (vote)
: Firefox 8
Assigned To: Matt Brubeck (:mbrubeck)
:
:
Mentors:
Depends on:
Blocks: 669424
  Show dependency treegraph
 
Reported: 2011-07-21 11:11 PDT by Mike Hommey [:glandium]
Modified: 2013-12-10 10:00 PST (History)
5 users (show)
See Also:
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
Logcat from Update to Clear data (194.71 KB, text/plain)
2011-07-21 12:11 PDT, Naoki Hirata :nhirata (please use needinfo instead of cc)
no flags Details
patch (2.49 KB, patch)
2011-07-21 13:33 PDT, Matt Brubeck (:mbrubeck)
mark.finkle: review+
mbrubeck: checkin+
Details | Diff | Splinter Review

Description Mike Hommey [:glandium] 2011-07-21 11:11:02 PDT
This is not bug 672809:

I/ActivityManager(  138): Starting: Intent { act=android.intent.action.MAIN cat=[android.intent.category.LAUNCHER] flg=0x10200000 cmp=org.mozilla.fennec/.App bnds=[400,547][496,643] } from pid 6641
I/ActivityManager(  138): Start proc org.mozilla.fennec for activity org.mozilla.fennec/.App: pid=10467 uid=10100 gids={3003, 1015}
D/WindowManager(  138): adjustConfigurationLw, config:{ scale=1.0 imsi=0/0 loc=null touch=3 keys=1/1/2 nav=1/1 orien=L layout=0x10000014 uiMode=0x0} mLidOpen:-1 mHasDockFeature:true mHasHallSensorFeature:true config.hardKeyboardHidden:2
D/TabletStatusBar(  289): lights on
D/dalvikvm(10467): GC_CONCURRENT freed 150K, 4% free 6601K/6855K, paused 4ms+2ms
W/SharedPreferencesImpl(10467): Attempt to read preferences file /data/data/org.mozilla.fennec/shared_prefs/App.xml without permission
I/GeckoApp(10467): create
I/GeckoAppJava(10467): Checking for an update
I/GeckoApp(10467): start
I/GeckoApp(10467): resume
W/dalvikvm(10467): threadid=10: thread exiting with uncaught exception (group=0x40258760)
E/AndroidRuntime(10467): FATAL EXCEPTION: Thread-11
E/AndroidRuntime(10467): java.lang.UnsatisfiedLinkError: Couldn't load mozutils: findLibrary returned null
E/AndroidRuntime(10467): 	at java.lang.Runtime.loadLibrary(Runtime.java:425)
E/AndroidRuntime(10467): 	at java.lang.System.loadLibrary(System.java:554)
E/AndroidRuntime(10467): 	at org.mozilla.gecko.GeckoAppShell.loadGeckoLibs(GeckoAppShell.java:274)
E/AndroidRuntime(10467): 	at org.mozilla.gecko.GeckoApp$4.run(GeckoApp.java:249)
E/AndroidRuntime(10467): 	at java.lang.Thread.run(Thread.java:1020)
W/ActivityManager(  138):   Force finishing activity org.mozilla.fennec/.App
I/GeckoAppShell(10467): Network state changed: (up, wifi) 
I/GeckoApp(10467): pause
D/WindowManager(  138): adjustConfigurationLw, config:{ scale=1.0 imsi=0/0 loc=null touch=3 keys=1/1/2 nav=1/1 orien=L layout=0x10000014 uiMode=0x0} mLidOpen:-1 mHasDockFeature:true mHasHallSensorFeature:true config.hardKeyboardHidden:2
I/GeckoAppJava(10467): surface created
E/SurfaceHolder(10467): Exception locking surface
E/SurfaceHolder(10467): java.lang.IllegalArgumentException
E/SurfaceHolder(10467): 	at android.view.Surface.lockCanvasNative(Native Method)
E/SurfaceHolder(10467): 	at android.view.Surface.lockCanvas(Surface.java:346)
E/SurfaceHolder(10467): 	at android.view.SurfaceView$4.internalLockCanvas(SurfaceView.java:774)
E/SurfaceHolder(10467): 	at android.view.SurfaceView$4.lockCanvas(SurfaceView.java:750)
E/SurfaceHolder(10467): 	at org.mozilla.gecko.GeckoSurfaceView.drawSplashScreen(GeckoSurfaceView.java:108)
E/SurfaceHolder(10467): 	at org.mozilla.gecko.GeckoSurfaceView.drawSplashScreen(GeckoSurfaceView.java:104)
E/SurfaceHolder(10467): 	at org.mozilla.gecko.GeckoSurfaceView.surfaceCreated(GeckoSurfaceView.java:245)
E/SurfaceHolder(10467): 	at android.view.SurfaceView.updateWindow(SurfaceView.java:565)
E/SurfaceHolder(10467): 	at android.view.SurfaceView.access$000(SurfaceView.java:84)
E/SurfaceHolder(10467): 	at android.view.SurfaceView$3.onPreDraw(SurfaceView.java:173)
E/SurfaceHolder(10467): 	at android.view.ViewTreeObserver.dispatchOnPreDraw(ViewTreeObserver.java:590)
E/SurfaceHolder(10467): 	at android.view.ViewRoot.performTraversals(ViewRoot.java:1383)
E/SurfaceHolder(10467): 	at android.view.ViewRoot.handleMessage(ViewRoot.java:2009)
E/SurfaceHolder(10467): 	at android.os.Handler.dispatchMessage(Handler.java:99)
E/SurfaceHolder(10467): 	at android.os.Looper.loop(Looper.java:132)
E/SurfaceHolder(10467): 	at org.mozilla.gecko.GeckoApp$3.run(GeckoApp.java:194)
E/SurfaceHolder(10467): 	at android.os.Handler.handleCallback(Handler.java:587)
E/SurfaceHolder(10467): 	at android.os.Handler.dispatchMessage(Handler.java:92)
E/SurfaceHolder(10467): 	at android.os.Looper.loop(Looper.java:132)
E/SurfaceHolder(10467): 	at android.app.ActivityThread.main(ActivityThread.java:4025)
E/SurfaceHolder(10467): 	at java.lang.reflect.Method.invokeNative(Native Method)
E/SurfaceHolder(10467): 	at java.lang.reflect.Method.invoke(Method.java:491)
E/SurfaceHolder(10467): 	at com.android.internal.os.ZygoteInit$MethodAndArgsCaller.run(ZygoteInit.java:841)
E/SurfaceHolder(10467): 	at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:599)
E/SurfaceHolder(10467): 	at dalvik.system.NativeStart.main(Native Method)
I/GeckoSurfaceView(10467): canvas is null
E/SurfaceHolder(10467): Exception locking surface
E/SurfaceHolder(10467): java.lang.IllegalArgumentException
E/SurfaceHolder(10467): 	at android.view.Surface.lockCanvasNative(Native Method)
E/SurfaceHolder(10467): 	at android.view.Surface.lockCanvas(Surface.java:346)
E/SurfaceHolder(10467): 	at android.view.SurfaceView$4.internalLockCanvas(SurfaceView.java:774)
E/SurfaceHolder(10467): 	at android.view.SurfaceView$4.lockCanvas(SurfaceView.java:750)
E/SurfaceHolder(10467): 	at org.mozilla.gecko.GeckoSurfaceView.drawSplashScreen(GeckoSurfaceView.java:108)
E/SurfaceHolder(10467): 	at org.mozilla.gecko.GeckoSurfaceView.surfaceChanged(GeckoSurfaceView.java:171)
E/SurfaceHolder(10467): 	at android.view.SurfaceView.updateWindow(SurfaceView.java:571)
E/SurfaceHolder(10467): 	at android.view.SurfaceView.access$000(SurfaceView.java:84)
E/SurfaceHolder(10467): 	at android.view.SurfaceView$3.onPreDraw(SurfaceView.java:173)
E/SurfaceHolder(10467): 	at android.view.ViewTreeObserver.dispatchOnPreDraw(ViewTreeObserver.java:590)
E/SurfaceHolder(10467): 	at android.view.ViewRoot.performTraversals(ViewRoot.java:1383)
E/SurfaceHolder(10467): 	at android.view.ViewRoot.handleMessage(ViewRoot.java:2009)
E/SurfaceHolder(10467): 	at android.os.Handler.dispatchMessage(Handler.java:99)
E/SurfaceHolder(10467): 	at android.os.Looper.loop(Looper.java:132)
E/SurfaceHolder(10467): 	at org.mozilla.gecko.GeckoApp$3.run(GeckoApp.java:194)
E/SurfaceHolder(10467): 	at android.os.Handler.handleCallback(Handler.java:587)
E/SurfaceHolder(10467): 	at android.os.Handler.dispatchMessage(Handler.java:92)
E/SurfaceHolder(10467): 	at android.os.Looper.loop(Looper.java:132)
E/SurfaceHolder(10467): 	at android.app.ActivityThread.main(ActivityThread.java:4025)
E/SurfaceHolder(10467): 	at java.lang.reflect.Method.invokeNative(Native Method)
E/SurfaceHolder(10467): 	at java.lang.reflect.Method.invoke(Method.java:491)
E/SurfaceHolder(10467): 	at com.android.internal.os.ZygoteInit$MethodAndArgsCaller.run(ZygoteInit.java:841)
E/SurfaceHolder(10467): 	at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:599)
E/SurfaceHolder(10467): 	at dalvik.system.NativeStart.main(Native Method)
I/GeckoSurfaceView(10467): canvas is null
I/GeckoAppJava(10467): surfaceChanged: fmt: 4 dim: 1280 752
I/GeckoAppJava(10467): surface destroyed
I/GeckoApp(10467): stop
I/GeckoApp(10467): destroy
Comment 1 Aaron Train [:aaronmt] 2011-07-21 11:12:42 PDT
Dupe of bug 663454?
Comment 2 Naoki Hirata :nhirata (please use needinfo instead of cc) 2011-07-21 12:11:12 PDT
Created attachment 547461 [details]
Logcat from Update to Clear data

Logcat of Updating to Clear Caching:
1. Update from 7/18/2011 nightly build
2. try to launch (you get an error message that states that it can't open)
3. clear data
4. try to launch and you get a crash of the application (Sorry message)
Comment 3 Matt Brubeck (:mbrubeck) 2011-07-21 12:55:59 PDT
(In reply to comment #2)
> 4. try to launch and you get a crash of the application (Sorry message)

The "sorry" message and permission errors after clearing the cache look like a regression caused by bug 669424.  It looks like we will need to back out bug 669424 to ensure that updating from old versions works correctly.
Comment 4 Matt Brubeck (:mbrubeck) 2011-07-21 13:33:36 PDT
Created attachment 547494 [details] [diff] [review]
patch
Comment 5 Matt Brubeck (:mbrubeck) 2011-07-21 14:15:13 PDT
Comment on attachment 547494 [details] [diff] [review]
patch

Backed out the sharedUserId change (bug 669424):
http://hg.mozilla.org/mozilla-central/rev/99d2fda67471

Leaving this bug open for now because it's not clear if this will fix all the errors here, or only some of them.
Comment 6 Matt Brubeck (:mbrubeck) 2011-07-21 16:13:41 PDT
Upgrading from the 7/19 nightly to the latest tinderbox build (from 99d2fda67471) works for me.
Comment 7 Mike Hommey [:glandium] 2011-07-21 23:13:28 PDT
Yeah, works for me. Thanks.
Comment 8 Aaron Train [:aaronmt] 2011-07-24 16:58:12 PDT
Verified Fixed
Mozilla/5.0 (Android; Linux armv7l; rv:8.0a1) Gecko/20110724 Firefox/8.0a1 Fennec/8.0a1
Device: HTC Nexus One, Samsung Nexus S
OS: Android 2.3.4

Note You need to log in before you can comment on or make changes to this bug.