Closed Bug 673440 Opened 8 years ago Closed 7 years ago

add support for NPNVSupportsCompositingCoreAnimationPluginsBool

Categories

(Core :: Plug-ins, defect)

All
macOS
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla22

People

(Reporter: jaas, Assigned: BenWa)

References

Details

Attachments

(1 file, 2 obsolete files)

Attached patch patch v1 (obsolete) — Splinter Review
Attachment #547737 - Flags: review?(joshmoz)
Comment on attachment 547737 [details] [diff] [review]
patch v1

This looks good though the npapi.h changes should land as a sync with npapi-sdk. Lets open a bug on pulling that and land this after we've closed the new bug out.

The diff for nsNPAPIPlugin.cpp is funny - what are you changing about the impl for NPNVsupportsCoreAnimationBool and NPNVsupportsInvalidatingCoreAnimationBool?
Attachment #547737 - Flags: review?(joshmoz) → review+
(In reply to comment #2)
> Comment on attachment 547737 [details] [diff] [review] [review]
> patch v1
> The diff for nsNPAPIPlugin.cpp is funny - what are you changing about the
> impl for NPNVsupportsCoreAnimationBool and
> NPNVsupportsInvalidatingCoreAnimationBool?

I had an extra whitespace, the code wasn't lining up. Housekeeping my intern code ^-^.
Whiteboard: waiting-on-npapi.h
Depends on: 674240
Whiteboard: waiting-on-npapi.h
No longer depends on: 674240
Depends on: 674240
This should be good to go, I updated the npapi headers.
Keywords: checkin-needed
patching file dom/plugins/base/npapi.h
Hunk #1 FAILED at 423
Keywords: checkin-needed
The modifications to npapi.h in this patch can be thrown out. They are part of the npapi header update that already landed.
Attached patch patch v2 (obsolete) — Splinter Review
Removed changed in dom/plugins/base/npapi.h landed in bug 674240, carrying forward r+.
Keywords: checkin-needed
Attachment #547737 - Attachment is obsolete: true
I had to backout Bug 668953 and Bug 673440 from inbound because one of the two caused a Tp5 and Tp5 RSS regression on OSX 10.6.2. I don't know which of the two, if you have an idea you may reland the other one separately.
Whiteboard: [inbound]
Re-landing this change: 
http://hg.mozilla.org/integration/mozilla-inbound/rev/f53ac674db57

Unless a plugin is reading this value and misbehaving I don't see how it could cause a perf regression.
Backout:
http://hg.mozilla.org/integration/mozilla-inbound/rev/9ab31534ef50

This was in fact the cause of the tp5 regression. There must be some plugins using this value already.
Let's try this again once plugins are updated on talos.
Depends on: 664728
I will push this if it doesn't regress try.
Attachment #549669 - Attachment is obsolete: true
Attachment #719983 - Flags: review+
Flags: needinfo?(bgirard)
https://hg.mozilla.org/mozilla-central/rev/6f0d5bc7f55a
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla22
You need to log in before you can comment on or make changes to this bug.