Last Comment Bug 673616 - --enable-shared-js + --enable-shark breaks xpcom test build
: --enable-shared-js + --enable-shark breaks xpcom test build
Status: RESOLVED FIXED
[inbound]
:
Product: Core
Classification: Components
Component: XPCOM (show other bugs)
: unspecified
: x86_64 Linux
: -- normal (vote)
: mozilla8
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
Depends on:
Blocks: 673631
  Show dependency treegraph
 
Reported: 2011-07-22 16:55 PDT by Steve Fink [:sfink] [:s:]
Modified: 2011-11-30 02:04 PST (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Add JS libs into link of tests (863 bytes, patch)
2011-07-22 16:55 PDT, Steve Fink [:sfink] [:s:]
khuey: review+
Details | Diff | Review

Description Steve Fink [:sfink] [:s:] 2011-07-22 16:55:19 PDT
Created attachment 547844 [details] [diff] [review]
Add JS libs into link of tests

xpcom/tests/TestHarness.h conditionally #includes "jsdbgapi.h" if MOZ_SHARK is defined, so that it can call JS_StartProfiling. libmozjs.so (eg) is not included on the link of the tests that use TestHarness.h.

khuey says the attached is the right fix. I don't really understand why it was working without --enable-shared-js, and if it was because the JS lib was included in libxul.so, then I don't understand why this wouldn't cause duplicate symbols or something. I'm hoping I'll never have to understand.

I am changing the profiling stuff around substantially. This fix will be necessary to avoid --enable-shared-js *always* breaking the test builds, which would suck.
Comment 1 Kyle Huey [:khuey] (khuey@mozilla.com) 2011-07-25 10:30:24 PDT
Comment on attachment 547844 [details] [diff] [review]
Add JS libs into link of tests

NB: You need to make the same change to js/src/config/rules.mk, or you will anger the copy-paste test in make check.
Comment 2 Steve Fink [:sfink] [:s:] 2011-08-01 16:07:59 PDT
Mirrored the changes to js/src, thanks.

http://hg.mozilla.org/integration/mozilla-inbound/rev/8f591ae20300
Comment 3 Marco Bonardo [::mak] 2011-08-02 03:22:27 PDT
http://hg.mozilla.org/mozilla-central/rev/8f591ae20300
Comment 4 Mike Hommey [:glandium] 2011-11-30 02:04:20 PST
For what it's worth, the fix for this bug is wrong and broke win64 on the landing of bug 702179. The issue will be resolved there.

Note You need to log in before you can comment on or make changes to this bug.