Closed Bug 673896 Opened 11 years ago Closed 10 years ago

"Compose" Windows hangs (and/or is very slow) for a while with dual GPU Mac

Categories

(Thunderbird :: Message Compose Window, defect)

All
Other
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 646043

People

(Reporter: fooraide, Unassigned)

Details

(Keywords: perf)

Attachments

(1 file)

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_6_8) AppleWebKit/535.1 (KHTML, like Gecko) Chrome/13.0.782.99 Safari/535.1

Steps to reproduce:

Open a new message (compose) window on Thunderbird/Miramar 6.

This also happened to me on Miramar builds before the release of thunderbird 5.


Actual results:

The new message window hangs and is very slow for 30 seconds or so.
If you give it enough time, it'll become responsive again.

Clicking on the various fields (body, To, subject) will take several seconds to take effect. The UI graphics will also tear sometimes.
This happens to me quite often but I am unable to reproduce this at the time of filing this bug.

I will attach a screenshot of the UI tearing when it happens again.

Note that I believe I have two factors which may cause this to happen:
- I have a HTML signature which has a link to an image (hosted logo)
- I have a LDAP address book with more than 100 employees in it.


Expected results:

The compose window UI should not lag, wether or not thunderbird is currently loading things such as the signature or the LDAP directory (if those are the issue).
I can confirm this here. When I click on "New Message" (or whatever it’s called in English), the window opens, but the content/html area stays in window background color instead of textarea color. And all of Thunderbird hangs. About 30 seconds later, everything becomes normal and the message can be written.

It only happens the *first* time one tries it after starting Thunderbird.

I have a strong feeling this is related to that other bug since TB “5.0”*, where every time you display a message for the first time, it shows the source code instead. And only after switching to another message and back, does it show the proper HTML or only one part of a multipart message.

This is amd64, xorg 1.10.3, Gentoo Linux, KDE 4.6.5 and Thunderbind 5.0.

___
* <rant>most idiotic versioning scheme since “98, ME, 2000, XP, Vista, 7“ with no relation to actual progress… which is kinda the point of versioning</rant>
Keywords: perf
It seems like I can reproduce the issue "at will" right now.

When I click on "Write", a new window opens but:
- The "To" field is grayed out
- The "Subject" field is grayed out
- My signature (from an html file) isn't there

I cannot click anywhere in the window.

If I click on the Window's title bar and just slightly drag the window, it will become responsive again.

If you need more information, let me know.
I have found an even better workaround:

I have simply installed the “Thunderbird Compose” add-on, which uses a completely different, much more powerful compose editor. (Still a bit rough around the edges with the visual design, but nothing worse that I know of.) Which apparently also completely circumvents the problem.

As a big plus it also offers what I bet everyone here requested since the beginning of Thunderbird: The compose window is now a *tab*.

By the way: I think this bug is related to something else I have noticed:
Every time I switch to a different folder, and then click on a message there, it first just shows everything in what I think is plain text. Only after switching to something else that is not a message in that folder (like a grouping) and back to the message, will it be displayed properly. I think this only happens with HTML mails, but I’m not sure.
So I have a strong feeling this has something to do with the HTML display widget. Especially with its “first” loading.
is it better in safe mode?
 http://support.mozillamessaging.com/en-US/kb/safe-mode

how many graphics adapters installed?
Whiteboard: [closeme 2011-10-01]
Sorry for the delay. I just found something new though.
Today the “Script takes too long” dialog appeared when this problem happened again.
Unfortunately I had trouble remembering the exact text after closing it, even though I tried to memorize it. (I couldn’t keep it open at the time.)

It was something with a name like “*/*/??ComposeAddressWidget*.js”.
Maybe it helps anyway. Otherwise I will report back when it happens again.

I have one graphics adapter, but technically the GeForce GTX 295 is a dual-GPU card. I don’t know how the nVidia driver describes it to the system though.

I can’t really try safe mode, unless I have a time where I don’t need calendaring etc. And that seems to be just about never. We’ll see. I’ll try my best.
dual GPU on Macs have a problem
Status: UNCONFIRMED → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
Summary: "Compose" Windows hangs (and/or is very slow) for a while → "Compose" Windows hangs (and/or is very slow) for a while with dual GPU Mac
Whiteboard: [closeme 2011-10-01]
Duplicate of bug: 646043
You need to log in before you can comment on or make changes to this bug.