StartInstall() needs to initialize a internal "package folder"

VERIFIED DUPLICATE of bug 6719

Status

Core Graveyard
Installer: XPInstall Engine
P3
normal
VERIFIED DUPLICATE of bug 6719
19 years ago
2 years ago

People

(Reporter: Cathleen, Assigned: Sean Su)

Tracking

Trunk
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
from Dan's Email:

> Regardless of SetPackageFolder() being implemented, StartInstall() needs
> to initialize some internal "package folder" which the overloaded forms
> can use. Of course they'd mostly return an error because it'll be null,
> but if someone updates a package that was installed using 4.5 it should
> pick up the old package.
>
> I assume that part wasn't implemented, either -- another bug.


Assigning the bug to me right now to keep track of this bug.
Will figure out the owner later.
(Reporter)

Updated

19 years ago
Target Milestone: M9
(Reporter)

Comment 1

19 years ago
set tfv to M9 for now

Updated

19 years ago
Assignee: cathleen → ssu

Comment 2

19 years ago
assigning to ssu.  sean, did you already fix this?
(Assignee)

Updated

19 years ago
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → DUPLICATE
(Assignee)

Comment 3

19 years ago
yes I have.  It's a dup of #6719.

*** This bug has been marked as a duplicate of 6719 ***

Updated

19 years ago
Status: RESOLVED → VERIFIED

Comment 4

19 years ago
Bulk move of XPInstall (component to be deleted) bugs to Installer: XPInstall
Engine
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.