Remove routeEvent, enableExternalCapture and disableExternalCapture

RESOLVED FIXED in Firefox 24

Status

()

Core
DOM: Events
RESOLVED FIXED
6 years ago
4 years ago

People

(Reporter: David Bruant, Assigned: emk)

Tracking

({addon-compat, dev-doc-complete, site-compat})

Trunk
mozilla25
addon-compat, dev-doc-complete, site-compat
Points:
---
Bug Flags:
in-testsuite -

Firefox Tracking Flags

(firefox24+ fixed, firefox25+ fixed)

Details

(Whiteboard: [qa-])

Attachments

(3 attachments, 3 obsolete attachments)

(Reporter)

Description

6 years ago
These functions have been obseleted in Gecko 1.9 (Firefox 3) https://developer.mozilla.org/en/Gecko_1.9_Changes_affecting_websites#A_few_other_old_event_APIs_are_no_longer_supported


I have discovered them today randomly by traversing the global object on a webpage.
After research, these functions are not seems standard from what I've seen. I've never heard of anyone using them in code.
Bug 132132 asks for removal and is solved as duplicate of Bug 330494. Yet, I still see these properties on the global object in the webconsole and Firebug
> and is solved as duplicate of Bug 330494

Which it's not.  The guy who did that confused deprecation and removal.

Olli, can we remove these now?  I seem to recall some sites using them, but maybe that was a while ago?

Updated

5 years ago
Duplicate of this bug: 132132

Comment 3

4 years ago
I intend to remove these from Blink.
(Assignee)

Comment 4

4 years ago
Created attachment 747163 [details] [diff] [review]
[WIP] Remove captureEvents, releaseEvents, and routeEvent

Chrome is going to remove them very soon.
https://code.google.com/p/chromium/issues/detail?id=238243
Let's try to follow that.
try: https://tbpl.mozilla.org/?tree=Try&rev=382bbec5b5a1
(Assignee)

Comment 5

4 years ago
Created attachment 747175 [details] [diff] [review]
[WIP] Remove captureEvents, releaseEvents, and routeEvent

https://tbpl.mozilla.org/?tree=Try&rev=16c37d946206
Attachment #747163 - Attachment is obsolete: true
Keywords: dev-doc-needed

Updated

4 years ago
Keywords: addon-compat, site-compat
OS: Linux → All
Hardware: x86 → All
Version: 5 Branch → Trunk
(Assignee)

Comment 6

4 years ago
Created attachment 747619 [details] [diff] [review]
Remove captureEvents, releaseEvents, and routeEvent

Green on try: https://tbpl.mozilla.org/?tree=Try&rev=671d217429b2
Assignee: nobody → VYV03354
Attachment #747175 - Attachment is obsolete: true
Status: NEW → ASSIGNED
Attachment #747619 - Flags: review?(bugs)

Comment 7

4 years ago
Comment on attachment 747619 [details] [diff] [review]
Remove captureEvents, releaseEvents, and routeEvent

The crashtest is odd, but ok.

This should land early in a cycle, so could you land this after the next merge, which
happens next week.
Attachment #747619 - Flags: review?(bugs) → review+
(Assignee)

Comment 8

4 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/2aa62db58f24
Flags: in-testsuite-
https://hg.mozilla.org/mozilla-central/rev/2aa62db58f24
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla24
Updated:
https://developer.mozilla.org/en-US/docs/Gecko_1.9_Changes_affecting_websites
https://developer.mozilla.org/en-US/docs/Web/API/document
https://developer.mozilla.org/en-US/docs/Web/API/window
https://developer.mozilla.org/en-US/docs/Web/API/window.captureEvents
https://developer.mozilla.org/en-US/docs/Web/API/window.releaseEvents
https://developer.mozilla.org/en-US/docs/Web/API/window.routeEvent

Added:
https://developer.mozilla.org/en-US/docs/Site_Compatibility_for_Firefox_24

Bug 330494 deprecated preventBubble and preventCapture too but these are still implemented. Is this intended?
Keywords: dev-doc-needed → dev-doc-complete
Summary: Remove releaseEvents, captureEvents, routeEvents → Remove releaseEvents, captureEvents, routeEvent
(Reporter)

Comment 11

4 years ago
(In reply to Kohei Yoshino from comment #10)
> Updated:
> https://developer.mozilla.org/en-US/docs/Gecko_1.9_Changes_affecting_websites
> https://developer.mozilla.org/en-US/docs/Web/API/document
> https://developer.mozilla.org/en-US/docs/Web/API/window
> https://developer.mozilla.org/en-US/docs/Web/API/window.captureEvents
> https://developer.mozilla.org/en-US/docs/Web/API/window.releaseEvents
> https://developer.mozilla.org/en-US/docs/Web/API/window.routeEvent
> 
> Added:
> https://developer.mozilla.org/en-US/docs/Site_Compatibility_for_Firefox_24
Thanks for the doc! It all looks good to me.

> Bug 330494 deprecated preventBubble and preventCapture too but these are
> still implemented. Is this intended?
I wish I had noticed these when reporting this bug to add them to the list of things to remove :-/
Filed bug 874003 for this.

Comment 12

4 years ago
Unfortunately we had to add them back to Chrome. There is a lot of code out there that starts with:

if (!IE) {
  document.captureEvents();
}

Another data point is that IE11 (which does not identify as IE) had to add it as well.

Sigh.
Argh.

Sounds like we need to back out the change and HTML spec needs to be updated.

emk, could you back out the change?
Flags: needinfo?(VYV03354)
https://www.w3.org/Bugs/Public/show_bug.cgi?id=22847

Updated

4 years ago
tracking-firefox24: --- → ?
tracking-firefox25: --- → ?
Switching the doc back to dev-doc-needed to not forget to update the doc (or not) once the decision is taken :-(
Keywords: dev-doc-complete → dev-doc-needed
(Assignee)

Comment 16

4 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/bd49d8389a9b
I couldn't simply backout the changeset because nsIDOMJSWindow and nsIDOMHTMLDocument were changed after this bug.
Also this bug contains a string change. Can I land this patch on Aurora?
Flags: needinfo?(VYV03354)
(Assignee)

Updated

4 years ago
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Upload the patch for Aurora and ask for approval.
(Assignee)

Comment 18

4 years ago
Created attachment 784042 [details] [diff] [review]
Backout patch for aurora

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 673919
User impact if declined: A lot of Websites will be broken, according to a report from Google
Testing completed (on m-c, etc.): waiting for merge on m-i
Risk to taking this patch (and alternatives if risky): low, backout.
String or IDL/UUID changes made by this patch: uuid will be reverted but removed strings will be re-added.
Attachment #784042 - Flags: approval-mozilla-aurora?
(Assignee)

Comment 19

4 years ago
uuid change is a simple backout on aurora.
(Assignee)

Comment 20

4 years ago
Created attachment 784070 [details] [diff] [review]
Remove routeEvent, enableExternalCapture, disableExternalCapture

Try removing routeEvent() again. And I bet enableExternalCapture() and disableExternalCapture() are not needed.
Attachment #784070 - Flags: review?(bugs)

Updated

4 years ago
Attachment #784070 - Flags: review?(bugs) → review+
(Assignee)

Comment 21

4 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/8103ed66ceef
Target Milestone: mozilla24 → mozilla25
(Assignee)

Comment 22

4 years ago
Created attachment 784406 [details] [diff] [review]
Backout patch without reverting string change

[Approval Request Comment]
See comment #18, modulo:
String or IDL/UUID changes made by this patch: uuid will be reverted. No string change.

Only one of this patch or attachment 784042 [details] [diff] [review] needs an approval.
Attachment #784406 - Flags: approval-mozilla-aurora?
https://hg.mozilla.org/mozilla-central/rev/8103ed66ceef
Status: REOPENED → RESOLVED
Last Resolved: 4 years ago4 years ago
Resolution: --- → FIXED
(Assignee)

Updated

4 years ago
Summary: Remove releaseEvents, captureEvents, routeEvent → Remove releaseEvents, enableExternalCapture, disableExternalCapture
Comment on attachment 784406 [details] [diff] [review]
Backout patch without reverting string change

PLease make sure the UUID change is backed out as well.
Attachment #784406 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+

Updated

4 years ago
status-firefox24: --- → affected
status-firefox25: --- → affected
tracking-firefox24: ? → +
tracking-firefox25: ? → +
Comment on attachment 784042 [details] [diff] [review]
Backout patch for aurora

Approved the alternate patch without the  removal of string's
Attachment #784042 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora-
(Assignee)

Updated

4 years ago
Attachment #784042 - Attachment is obsolete: true
(Assignee)

Comment 26

4 years ago
Sorry, I have no time to watch the tree right now.
Keywords: checkin-needed
(Assignee)

Updated

4 years ago
Attachment #784406 - Flags: checkin?
(Assignee)

Comment 27

4 years ago
Already reverted (and relanded without captureEvents and releaseEvents removal) on Nightly.
status-firefox25: affected → fixed
Whiteboard: [land the approved patch to aurora]
Updated docs:
https://developer.mozilla.org/en-US/docs/Web/API/document
https://developer.mozilla.org/en-US/docs/Web/API/window
https://developer.mozilla.org/en-US/docs/Web/API/window.captureEvents
https://developer.mozilla.org/en-US/docs/Web/API/window.releaseEvents
https://developer.mozilla.org/en-US/docs/Web/API/window.routeEvent
https://developer.mozilla.org/en-US/docs/Site_Compatibility_for_Firefox_24
Keywords: dev-doc-needed → dev-doc-complete
(Assignee)

Comment 29

4 years ago
https://hg.mozilla.org/releases/mozilla-aurora/rev/4ea223de889c
status-firefox24: affected → fixed
Keywords: checkin-needed
Whiteboard: [land the approved patch to aurora]
(Assignee)

Updated

4 years ago
Attachment #784406 - Flags: checkin? → checkin+
Marking WONTFIX and clearing the keywords to avoid confusion, as the patches have been backed out.
Keywords: addon-compat, dev-doc-complete, site-compat
Resolution: FIXED → WONTFIX
(Assignee)

Comment 31

4 years ago
Actually this bug has been morphed to a bug removing releaseEvents, enableExternalCapture, disableExternalCapture (see the Summary change).
Maybe I should have filed a new bug. Sorry for the confusion.
Keywords: addon-compat, dev-doc-complete, site-compat
Resolution: WONTFIX → FIXED
(Assignee)

Comment 32

4 years ago
So the documentation should be updated again.
Keywords: dev-doc-complete → dev-doc-needed
Oh, oh...

(In reply to Masatoshi Kimura [:emk] from comment #29)
> https://hg.mozilla.org/releases/mozilla-aurora/rev/4ea223de889c

As per this changeset,
* Still available: captureEvents, releaseEvents
* Removed: routeEvent, enableExternalCapture, disableExternalCapture
so the summary should be corrected here.
Summary: Remove releaseEvents, enableExternalCapture, disableExternalCapture → Remove routeEvent, enableExternalCapture and disableExternalCapture
I mean this changeset on central:
https://hg.mozilla.org/mozilla-central/rev/8103ed66ceef

Updated the docs:
https://developer.mozilla.org/en-US/docs/Web/API/Window.routeEvent
https://developer.mozilla.org/en-US/docs/Site_Compatibility_for_Firefox_24
Keywords: dev-doc-needed → dev-doc-complete
(Assignee)

Comment 35

4 years ago
> Recently Google Chrome (the Blink rendering engine) also removed the support for those methods.

This sentence should be removed because Google Chrome reverted the removal of captureEvents and releaseEvents, and it have never supported the rest from the start.
(In reply to Masatoshi Kimura [:emk] from comment #35)
> > Recently Google Chrome (the Blink rendering engine) also removed the support for those methods.
> 
> This sentence should be removed because Google Chrome reverted the removal
> of captureEvents and releaseEvents, and it have never supported the rest
> from the start.

Removed the incorrect sentence. Thanks!
Assuming no QA needed here.
Whiteboard: [qa-]
You need to log in before you can comment on or make changes to this bug.