Closed Bug 674106 Opened 8 years ago Closed 7 years ago

Unified Folders Inbox doesn't show any messages since version 5. virtualFolders.dat is messed up

Categories

(Thunderbird :: Folder and Message Lists, defect)

All
Other
defect
Not set

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: jonas, Unassigned)

Details

User Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/534.30 (KHTML, like Gecko) Chrome/12.0.742.124 Safari/534.30

Steps to reproduce:

Select the Unified Folders Inbox view in the folder pane.


Actual results:

No e-mails are shown in the message list although there are e-mails in the Inboxes.


Expected results:

A list of all e-mails in all Inboxes should be displayed, i.e. if there are 5 messages in Inbox A and 3 in Inbox B, the Unified Inbox view should display 8 messages.

This worked in Thunderbird 3 but seems to be broken in version 5.
Does it work if you start Thunderbird in -safe-mode ?

Anything in Tools -> Error console ?
It doesn't work but the Error console shows

Error: uncaught exception: [Exception... "Component returned failure code: 0x80550005 [nsIMsgFolder.msgDatabase]"  nsresult: "0x80550005 (<unknown>)"  location: "JS frame :: chrome://messenger/content/mailWidgets.xml :: parseFolder :: line 2168"  data: no]

and if I click on aforementioned U.F. Inbox this exception appears:

Error: this._sort[aIndex] is undefined
Source File: resource:///modules/dbViewWrapper.js
Line: 1547
Component: General → Folder and Message Lists
QA Contact: general → folders-message-lists
can you check the content of the virtualfolder.dat where I think the unified folder views are defined and see if something is wrong in there ?
$ cat .thunderbird/jonas.default/virtualFolders.dat 
version=1
Bug still present in Thunderbird 6. btw this bug seems to be a duplicate of #578148
(In reply to Jonas H. from comment #5)
> Bug still present in Thunderbird 6. btw this bug seems to be a duplicate of
> #578148

So your inbox unified folder shows something ?
(In reply to Jonas H. from comment #4)
> $ cat .thunderbird/jonas.default/virtualFolders.dat 
> version=1

It should contain a bit more and that's probably why you don't see anything (right David ?)
(In reply to Ludovic Hirlimann [:Usul] from comment #6)
> (In reply to Jonas H. from comment #5)
> > Bug still present in Thunderbird 6. btw this bug seems to be a duplicate of
> > #578148
> 
> So your inbox unified folder shows something ?

Er, no, it does not show anything.

I tried the fix in #578148 (deleting profile/Mail/smart mailboxes) and now it works again. Also my virtualFolders.dat contains a lot more stuff now.

Not marking this resolved as the bug is still present, after all.
(In reply to Ludovic Hirlimann [:Usul] from comment #7)
> (In reply to Jonas H. from comment #4)
> > $ cat .thunderbird/jonas.default/virtualFolders.dat 
> > version=1
> 
> It should contain a bit more and that's probably why you don't see anything
> (right David ?)

Right, if it's empty, then there are no virtual folders corresponding to the smart mailboxes.
This issue just appeared again. I did some debugging and noticed that the virtualFolders.dat gets screwed up every time I launch Thunderbird.

Here's the contents before starting Thunderbird:

--- begin virtualFolders.dat ---
version=1
uri=mailbox://nobody@smart%20mailboxes/Trash
searchFolderFlag=100
scope=mailbox://nobody@Local%20Folders/Trash|mailbox://me%40domain3.org@pop.domain2.org/Trash|mailbox://me@pop3.domain1.org/Trash|mailbox://me@pop3.domain1.org/Trash
terms=ALL
searchOnline=true
uri=mailbox://nobody@smart%20mailboxes/Sent
searchFolderFlag=200
scope=mailbox://me@pop3.domain1.org/Sent|mailbox://me%40domain3.org@pop.domain2.org/Sent
terms=ALL
searchOnline=true
uri=mailbox://nobody@smart%20mailboxes/Inbox
searchFolderFlag=1000
scope=mailbox://me@pop3.domain1.org/Inbox|mailbox://me%40domain3.org@pop.domain2.org/Inbox|mailbox://me@pop3.domain1.org/Inbox
terms=ALL
searchOnline=true
uri=mailbox://nobody@smart%20mailboxes/Drafts
searchFolderFlag=400
scope=mailbox://me@pop3.domain1.org/Drafts|mailbox://me%40domain3.org@pop.domain2.org/Drafts
terms=ALL
searchOnline=true
--- end virtualFolders.dat ---

After launching and closing Thunderbird, at that's left is

--- begin virtualFolders.dat ---
version-1
--- end virtualFolders.dat ---

Seems like there's something wrong with the virtualFolders.dat... I'm confused because I never changed anything in that file and it used to work the other day.
Ok are you running some AV software ?

Are there many extension installed in your profile ?

Could a cron job like a backup job alter that file ?
No I'm on Linux, so no AV. No cron jobs (or similar) either. Extension list:

* Clean Subject
* CompactHeader
* External Editor
* Identity Chooser
* LookOut
* Maximaize Message Pane
* ThreadKey
* Unified search

All of these are only UI related and shouldn't touch any files at all.
Jonas, do you still see this when running a newer version?
Flags: needinfo?(jonas)
Summary: Unified Folders Inbox doesn't show any messages since version 5 → Unified Folders Inbox doesn't show any messages since version 5. virtualFolders.dat is messed up
Wayne, no I don't. I'm currently running Thunderbird 17.0. Although sometimes the unified Trash view does not display the whole set of e-mails in the subfolders but only parts.  Can't reproduce now. It's okay with me to close the bug for now and if the issue appears again I'm going to reopen/open a new one.
Flags: needinfo?(jonas)
Status: UNCONFIRMED → RESOLVED
Closed: 7 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.