Automatic Find as you type broken

RESOLVED FIXED in seamonkey2.5

Status

SeaMonkey
Find In Page
RESOLVED FIXED
7 years ago
6 years ago

People

(Reporter: Hans, Assigned: InvisibleSmiley)

Tracking

Trunk
seamonkey2.5

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:8.0a1) Gecko/20110726 Firefox/8.0a1 SeaMonkey/2.5a1
Build ID: 20110726003039

Steps to reproduce:

Type text for a Link as usual for Find as you type.


Actual results:

Nothing.


Expected results:

Link should be selected.

(starting Find as you type with ' character still works), through.

This was broken the last 2-3 days, I think.

Build identifier: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:8.0a1) Gecko/20110726 Firefox/8.0a1 SeaMonkey/2.5a1

Comment 1

7 years ago
Error: invalid 'instanceof' operand Components.interfaces.nsIDOMHTMLIsIndexElement
Source file: jar:file:///C:/T1/hg/objdir-sm/mozilla/dist/seamonkey/omni.jar!/components/nsTypeAheadFind.js
Line: 193

Ms2ger said he killed nsIDOMHTMLIsIndexElement

<Ms2ger> I'd just remove that line, it's been dead since Gk2
Whiteboard: [good first bug]

Comment 2

7 years ago
<Ms2ger> I'm surprised you don't check input

Comment 3

7 years ago
(In reply to comment #2)
> <Ms2ger> I'm surprised you don't check input
Why am I not surprised that Ms2ger doesn't check comm-central?

Anyway, we do check input, it's 6 lines further down.
(Assignee)

Comment 4

7 years ago
Created attachment 548822 [details] [diff] [review]
patch [Checkin: comment 5]

nsIDOMHTMLIsIndexElement was removed in m-c changeset 0f00661af740 / bug 666665. Has not propagated to Aurora yet, so landing on c-c should do.

This is a brain-dead removal action, so IMO not a good GFB candidate. Let's just fix it right now.
Assignee: nobody → jh
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Attachment #548822 - Flags: review?(neil)
(Assignee)

Updated

7 years ago
Depends on: 666665
Whiteboard: [good first bug]

Updated

7 years ago
Attachment #548822 - Flags: review?(neil) → review+
(Assignee)

Comment 5

7 years ago
Comment on attachment 548822 [details] [diff] [review]
patch [Checkin: comment 5]

http://hg.mozilla.org/comm-central/rev/d76b160f0737
Attachment #548822 - Attachment description: patch → patch [Checkin: comment 5]
(Assignee)

Updated

7 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 7 years ago
OS: Other → All
Resolution: --- → FIXED
Target Milestone: --- → seamonkey2.5

Comment 6

6 years ago
Anyone want to fix findbar.xml which contains our last reference?

Comment 7

6 years ago
> Anyone want to fix findbar.xml which contains our last reference?
Patch in bug 687317. Who wants to steal the review?
You need to log in before you can comment on or make changes to this bug.