Closed Bug 674547 Opened 9 years ago Closed 8 years ago

Decode images using a single worker event, rather than one worker per image

Categories

(Core :: ImageLib, defect)

defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 715308

People

(Reporter: justin.lebar+bug, Unassigned)

References

(Blocks 1 open bug)

Details

In bug 666352 (and elsewhere), we've noted that we currently decode each image in its own worker event.  This means that if there are 100 images to decode on the page, and each event decodes for 5ms, we'll block the event loop for 500ms on every decode step.

A better solution would be to use a single worker event to decode images.
If images are decoded by a single worker, could they be queued up in order of their distance from the center of the current view? That way the most relevant images would be decoded first, which sounds like a start to fixing bug 660577. The in-view images would still have to be displayed as soon as they are decoded for it to have a visible effect.
I'm working on this. Could someone assign it to me? (I don't have editbug permissions)
Assignee: nobody → rclickenbrock
I don't know when I'll be able to finish this. The motherboard in my box died and it's going to be a while before I can replace it. :(

I have WIP patches in my queue that work, although IIRC there was a thing or two that I wasn't entirely happy with. Sometime soon I'll try to scavenge them off my hard drive and get 'em posted here.
Blocks: 715308
jlebar is doing this in bug 715308.
Assignee: rclickenbrock → nobody
No longer blocks: 715308
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 715308
You need to log in before you can comment on or make changes to this bug.