Make the default value for auth in baseapp "off"

VERIFIED FIXED

Status

defect
VERIFIED FIXED
8 years ago
8 years ago

People

(Reporter: telliott, Assigned: tarek)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [qa-])

Attachments

(5 attachments)

(Reporter)

Description

8 years ago
In general, the default for auth should not be that it exists and has to be turned off. It might even be enough to look for a specific [auth] section in config, combined with any routes that specify that they need auth.
(Assignee)

Comment 1

8 years ago
This is a three-fold patch:

- make reg force the auth option
- make storage force the auth option
- change the default in core
(Assignee)

Comment 2

8 years ago
Assignee: nobody → tarek
Status: NEW → ASSIGNED
Attachment #548973 - Flags: review?(jrconlin)
(Assignee)

Comment 4

8 years ago
Attachment #548977 - Flags: review?(rtilder)
Comment on attachment 548974 [details] [diff] [review]
Make the app explictely define the auth class [reg]

Review of attachment 548974 [details] [diff] [review]:
-----------------------------------------------------------------
Attachment #548974 - Flags: review?(rmiller) → review+
(Assignee)

Updated

8 years ago
Attachment #548977 - Flags: review?(rmiller)
Attachment #548977 - Flags: review?(jrconlin)
Comment on attachment 548977 [details] [diff] [review]
Make baseapp auth class turned off by default

Review of attachment 548977 [details] [diff] [review]:
-----------------------------------------------------------------
Attachment #548977 - Flags: review?(rmiller) → review+
Attachment #548977 - Flags: review?(jrconlin) → review+
Comment on attachment 548977 [details] [diff] [review]
Make baseapp auth class turned off by default

Review of attachment 548977 [details] [diff] [review]:
-----------------------------------------------------------------
Attachment #548977 - Flags: review?(rtilder) → review+
Attachment #548973 - Flags: review?(jrconlin) → review+
Attachment 548977 [details] [diff] breaks syncstorage.wsgiapp's import of the Authentication from services.baseapp.

This is a quick one liner to correct the import.
Attachment #549582 - Flags: review?(tarek)
See comment #9
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Duplicate of this bug: 675441
Attachment #549582 - Flags: review?(tarek) → review?(telliott)
(Reporter)

Updated

8 years ago
Attachment #549582 - Flags: review?(telliott) → review+
We missed server-full in the set_app() changes.
Attachment #549588 - Flags: review?(telliott)
(Reporter)

Updated

8 years ago
Attachment #549588 - Flags: review?(telliott) → review+
(Reporter)

Updated

8 years ago
Blocks: 676423
(Assignee)

Comment 13

8 years ago
everything was applied, closing
Status: REOPENED → RESOLVED
Last Resolved: 8 years ago8 years ago
Resolution: --- → FIXED
Status: RESOLVED → VERIFIED
Whiteboard: [qa-]
You need to log in before you can comment on or make changes to this bug.