Last Comment Bug 674819 - Tab dragging animation does not work properly
: Tab dragging animation does not work properly
Status: VERIFIED FIXED
[testday-20110930]
: verified-beta
Product: Firefox
Classification: Client Software
Component: Tabbed Browser (show other bugs)
: Trunk
: All All
: -- normal (vote)
: Firefox 8
Assigned To: Frank Yan (:fryn)
:
: Dão Gottwald [:dao]
Mentors:
: 674940 (view as bug list)
Depends on:
Blocks: 455694
  Show dependency treegraph
 
Reported: 2011-07-27 22:44 PDT by Alice0775 White
Modified: 2011-09-30 08:09 PDT (History)
8 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Alice0775 White 2011-07-27 22:44:17 PDT
Build Identifier:
http://hg.mozilla.org/mozilla-central/rev/e4c8a1e7b373
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:8.0a1) Gecko/20110727 Firefox/8.0a1 ID:20110727081800

Tab dragging animation does not work properly.
Screen capture http://www.youtube.com/watch?v=8ssI67uHciI

Reproducible: Always

Steps to Reproduce:

1. Start Firefox with clean profile.
2. Open Several tabs
3. Drag a tab in the tab strip

Actual Results: 
  Overlapped tab would not move.

Expected Results: 
  Tab dragging animation should work as expected.
Comment 1 Cork 2011-07-27 22:52:50 PDT
I can reproduce this, but far from always, and can't find a pattern for what triggers it.

Mozilla/5.0 (X11; Linux x86_64; rv:8.0a1) Gecko/20110727 Firefox/8.0a1
Comment 2 Alice0775 White 2011-07-27 22:53:58 PDT
Screen capture2 http://www.youtube.com/watch?v=bZsuBDJbYlU
Comment 3 Frank Yan (:fryn) 2011-07-28 03:09:42 PDT
Caused by a typo.
Fixed earlier today: https://hg.mozilla.org/mozilla-central/rev/d066929dd830
Comment 4 Siddhartha Dugar [:sdrocking] 2011-07-28 07:58:27 PDT
I can still reproduce this on the 7/28 nightly (Built from http://hg.mozilla.org/mozilla-central/rev/a627b24e684e)
Comment 5 Jeff Muizelaar [:jrmuizel] 2011-07-28 10:57:40 PDT
*** Bug 674940 has been marked as a duplicate of this bug. ***
Comment 6 Teodosia Pop 2011-09-30 08:09:39 PDT
Verified using Mozilla/5.0 (Windows NT 6.1; rv:8.0) Gecko/20100101 Firefox/8.0

Note You need to log in before you can comment on or make changes to this bug.