Closed Bug 674837 Opened 8 years ago Closed 8 years ago

Fennec android builds are not thumb anymore

Categories

(Firefox for Android Graveyard :: General, defect)

ARM
Android
defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED
Firefox 8

People

(Reporter: glandium, Assigned: glandium)

References

Details

(Whiteboard: [inbound])

Attachments

(1 file, 3 obsolete files)

Since the switch to NDK 5, fennec android builds are not built with -mthumb -march=armv7-a -mfpu=vfp -mfloat-abi=soft-float.

This is because the new target name doesn't match what is checked in configure.in to put these flags.

I think it's time to stop using $target to do these kind of selections, and use our normalized values such as CPU_ARCH and OS_TARGET instead.
Attachment #549042 - Flags: review?(ted.mielczarek)
Attachment #549043 - Flags: review?(ted.mielczarek)
(In reply to comment #0)
> Since the switch to NDK 5, fennec android builds are not built with -mthumb
> -march=armv7-a -mfpu=vfp -mfloat-abi=soft-float.

This makes the binary significantly bigger, as well as the apk. I'd also expect some talos regression...
with configure
Attachment #549054 - Flags: review?(ted.mielczarek)
Attachment #549043 - Attachment is obsolete: true
Attachment #549043 - Flags: review?(ted.mielczarek)
Comment on attachment 549042 [details] [diff] [review]
Properly set android build options on NDK5+

Review of attachment 549042 [details] [diff] [review]:
-----------------------------------------------------------------
Attachment #549042 - Flags: review?(ted.mielczarek) → review+
Comment on attachment 549054 [details] [diff] [review]
Properly set android build options on NDK5+ - nspr part

Review of attachment 549054 [details] [diff] [review]:
-----------------------------------------------------------------
Attachment #549054 - Flags: review?(ted.mielczarek) → review+
Assignee: nobody → mh+mozilla
Blocks: 674880
Attachment #549042 - Attachment is obsolete: true
Attachment #549054 - Attachment is obsolete: true
Attachment #549084 - Flags: review?(ted.mielczarek) → review+
Duplicate of this bug: 674855
http://hg.mozilla.org/mozilla-central/rev/f7c8248747d6
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 8
You need to log in before you can comment on or make changes to this bug.