QuickSearch for message body doesn't work for IMAP when offline storage not enabled

RESOLVED DUPLICATE of bug 67421

Status

defect
RESOLVED DUPLICATE of bug 67421
8 years ago
7 years ago

People

(Reporter: hi3536897, Unassigned)

Tracking

x86
Solaris

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User Agent: Mozilla/5.0 (X11; U; Linux i686; zh-CN; rv:1.9.2.16) Gecko/20110322 Fedora/3.6.16-1.fc14 Firefox/3.6.16
Build ID: 20110322223938

Steps to reproduce:

1. Switch into Inbox Floder 
2. In the quicksearch box type in a search term such as "mozilla" (make sure "mozilla" is clearly contained in one or more messages in Inbox Floder ). 
3. Set quicksearch dropdown to search by body. 


Actual results:

It shows "No Result " rather than returns the messages containing "mozilla" in the message body.


Expected results:

A set of email messages which contain "mozilla" in its body are returned.
(Reporter)

Updated

8 years ago
Hardware: All → x86
(Reporter)

Updated

8 years ago
OS: Other → Linux
does rebuilding indexes for the folder where you filter helps ?
YangLinling

(In reply to Ludovic Hirlimann [:Usul] from comment #1)
> does rebuilding indexes for the folder where you filter helps ?
Whiteboard: [closeme 2011-10-01]
(Reporter)

Comment 3

8 years ago
Hi , I'm sorry that I was busy with other work and failed to reply in time.
Can you introduce something about how to rebuild indexes for the folder ? I'm not very clear about it.
Thx very much !

(In reply to Wayne Mery (:wsmwk) from comment #2)
> YangLinling

(In reply to Ludovic Hirlimann [:Usul] from comment #1)
> does
> rebuilding indexes for the folder where you filter helps ?
right+click folder, properties, repair
Whiteboard: [closeme 2011-10-01]
(Reporter)

Comment 5

8 years ago
(In reply to Wayne Mery (:wsmwk) from comment #4)
> right+click folder, properties, repair

I have tried ,it works ok on Linux, but still doesn't work on Solaris .
OS: Linux → Solaris

Comment 6

8 years ago
This seems fixed in build 7.0.1.
For both Solaris 11 and Fedora 15.
YangLingling, do you agree?

(In reply to fengyuan from comment #6)
> This seems fixed in build 7.0.1.
> For both Solaris 11 and Fedora 15.
WFM per comment 6
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 9

8 years ago
(In reply to Wayne Mery (:wsmwk) from comment #7)
> YangLingling, do you agree?
> 
> (In reply to fengyuan from comment #6)
> > This seems fixed in build 7.0.1.
> > For both Solaris 11 and Fedora 15.

It works ok now on Solaris.

Comment 10

7 years ago
Reopen this bug, reproduce on Solaris11u + Thunderbird 10.0.1 ESR. 

Even after rebuild indexes for the folder(right+click folder, properties, repair), still can not search body message. 

The only way to search body message is to download all the messages on local computer by turn on "Keep messages for this account on this computer" in Account Settings->Synchronization&  Storage. If the mails are downloaded on your computer, it will search for the body.
Status: RESOLVED → REOPENED
Ever confirmed: true
Resolution: WORKSFORME → ---
Summary: QuickSearch for message body doesn't work → QuickSearch for message body doesn't work for IMAP when offline storage not enabled

Comment 11

7 years ago
Looks like a dup of Bug 67421

Updated

7 years ago
Status: REOPENED → RESOLVED
Last Resolved: 8 years ago7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 67421
You need to log in before you can comment on or make changes to this bug.