Last Comment Bug 669829 - remove atlbase.h check from configure
: remove atlbase.h check from configure
Status: RESOLVED FIXED
: dev-doc-complete
Product: Core
Classification: Components
Component: Build Config (show other bugs)
: Trunk
: x86 Windows Vista
: -- normal (vote)
: mozilla9
Assigned To: Matheus Kerschbaum
:
Mentors:
: 614504 674870 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-07-06 23:48 PDT by Makoto Kato [:m_kato]
Modified: 2012-03-12 08:30 PDT (History)
9 users (show)
matjk7: in‑testsuite-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch (2.81 KB, patch)
2011-09-17 16:27 PDT, Matheus Kerschbaum
ted: review+
Details | Diff | Splinter Review

Description Makoto Kato [:m_kato] 2011-07-06 23:48:04 PDT
Since ActiveX support is dropped and accessibility support doesn't need ATL now, I think we can remove atlbase.h checking from configure.
Comment 1 Joey Armstrong [:joey] 2011-07-07 05:37:28 PDT
Docs could be updated/flagged as legacy after configure is changed:
  http://developer.mozilla.org/en/atlbase.h

Moot item if the header check is removed -- windows7 may not be paying attention to the --disable- flag.

>> ac_add_options --disable-accessibility
Comment 2 Makoto Kato [:m_kato] 2011-07-08 14:11:45 PDT
Humm, we still only use ATL header into breakpad although we don't use atlbase.h

http://mxr.mozilla.org/mozilla-central/search?string=atlcomcli.h

IPC code that include atlcomcli.h isn't build target. (Makefile doesn't have win_safe_util.cc entry).

(In reply to comment #1)
> Docs could be updated/flagged as legacy after configure is changed:
>   http://developer.mozilla.org/en/atlbase.h
> 
> Moot item if the header check is removed -- windows7 may not be paying
> attention to the --disable- flag.
> 
> >> ac_add_options --disable-accessibility

This document is invalid now.
Comment 3 Ted Mielczarek [:ted.mielczarek] 2011-07-18 06:40:36 PDT
(In reply to comment #2)
> Humm, we still only use ATL header into breakpad although we don't use
> atlbase.h

That Breakpad code is part of dump_syms, which we don't build as part of the build (we have prebuilt binaries in the tree).
Comment 4 Matheus Kerschbaum 2011-09-17 16:27:32 PDT
Created attachment 560741 [details] [diff] [review]
patch
Comment 5 Ted Mielczarek [:ted.mielczarek] 2011-09-23 08:34:31 PDT
(In reply to Joey Armstrong [:joey] from comment #1)
> Docs could be updated/flagged as legacy after configure is changed:
>   http://developer.mozilla.org/en/atlbase.h

Seems fine to note that this doc is outdated, but we should leave it there because we linked to it from the configure error in older versions.
Comment 7 Matt Brubeck (:mbrubeck) 2011-09-24 08:28:57 PDT
https://hg.mozilla.org/mozilla-central/rev/ec384fc33769
Comment 8 Eric Shepherd [:sheppy] 2011-11-11 12:04:21 PST
Documentation updated:

https://developer.mozilla.org/en/atlbase.h
Comment 9 Daniel Holbert [:dholbert] 2012-01-26 09:56:05 PST
*** Bug 614504 has been marked as a duplicate of this bug. ***
Comment 10 Ted Mielczarek [:ted.mielczarek] 2012-03-12 08:30:03 PDT
*** Bug 674870 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.