Last Comment Bug 675236 - portrait view shifted on tablet awesomescreen
: portrait view shifted on tablet awesomescreen
Status: VERIFIED FIXED
: regression, verified-aurora, verified-beta
Product: Fennec Graveyard
Classification: Graveyard
Component: General (show other bugs)
: Trunk
: All Android
: -- normal (vote)
: Firefox 6
Assigned To: Mark Finkle (:mfinkle) (use needinfo?)
:
Mentors:
: 669797 (view as bug list)
Depends on:
Blocks: 655740
  Show dependency treegraph
 
Reported: 2011-07-29 09:37 PDT by Tony Chung [:tchung]
Modified: 2011-08-09 22:41 PDT (History)
5 users (show)
See Also:
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
tablet all pages screenshot (118.79 KB, image/png)
2011-07-29 09:37 PDT, Tony Chung [:tchung]
no flags Details
tablet view - sync setup screenshot (52.32 KB, image/png)
2011-07-29 09:37 PDT, Tony Chung [:tchung]
no flags Details
patch (1.38 KB, patch)
2011-08-01 12:16 PDT, Mark Finkle (:mfinkle) (use needinfo?)
wjohnston2000: review+
blassey.bugs: approval‑mozilla‑aurora+
blassey.bugs: approval‑mozilla‑beta+
Details | Diff | Splinter Review

Description Tony Chung [:tchung] 2011-07-29 09:37:04 PDT
Created attachment 549403 [details]
tablet all pages screenshot

The viewing space on portrait view of tablet doesnt seem to fit on firefox 6 beta.   it does look find on Firefox 5, released builds.  It also works on phones.

See screenshots.

Repro:
1) Install Firefox 6 beta, and nightlies, on a Honeycomb Tablet.  (Xoom, Android 3.1)
- Mozilla/5.0 (Android; Linux armv71; rv:6.0) Gecko/20110721 Firefox/6.0 Fennec/6.0
2) set device in portrait mode, and visit awesomescreen
3) verify portrait view visibility is shifted
Comment 1 Tony Chung [:tchung] 2011-07-29 09:37:41 PDT
Created attachment 549404 [details]
tablet view - sync setup screenshot
Comment 2 Tony Chung [:tchung] 2011-07-29 09:51:05 PDT
we should get this fixed for next Fx 6 beta. nom'ing
Comment 3 Tony Chung [:tchung] 2011-07-29 11:45:49 PDT
just checked 20110729 nightly against a HTC Flyer, 7" tablet.   Viewing area looks fine there.  it's running Gingerbread, and does not have the new tablet theming.

So far its only appearing on a 10" wide view tablet.
Comment 4 Mark Finkle (:mfinkle) (use needinfo?) 2011-08-01 12:13:47 PDT
This is a regression from bug 655740. We are applying a style to all "panel-row-button" buttons, but should only apply them to the buttons in the preference container.
Comment 5 Mark Finkle (:mfinkle) (use needinfo?) 2011-08-01 12:16:55 PDT
Created attachment 549885 [details] [diff] [review]
patch

This patch makes the CSS more explicit and only applies it to the preference panel buttons.

The Awesomescreen buttons already have CSS to "switch" in portrait mode:
http://mxr.mozilla.org/mozilla-central/source/mobile/themes/core/platform.css#688
Comment 6 Mark Finkle (:mfinkle) (use needinfo?) 2011-08-01 14:41:13 PDT
pushed http://hg.mozilla.org/mozilla-central/rev/4338bea0bb71
Comment 7 Matt Brubeck (:mbrubeck) 2011-08-01 15:39:04 PDT
Comment on attachment 549885 [details] [diff] [review]
patch

Requesting approval for Aurora (Firefox 7) and Beta (Firefox 6).  This is a two-line mobile-only change (zero desktop risk).  It's very low risk (just changes one CSS selector in the mobile chrome to be more specific) and fixes a visible regression in Firefox 6.  It landed on mozilla-central today, so can be tested on the Nightly channel tomorrow.
Comment 8 Matt Brubeck (:mbrubeck) 2011-08-02 15:39:11 PDT
hg.mozilla.org/releases/mozilla-beta/rev/5290a61c6998
http://hg.mozilla.org/releases/mozilla-aurora/rev/b03971e28880
Comment 9 Tony Chung [:tchung] 2011-08-03 11:03:49 PDT
Verified view fix on Xoom Tablet, Android 3.1

Nightly: Mozilla/5.0 (Android; Linux armv71; rv:8.0a1) Gecko/20110803 Firefox/8.0a1 Fennec/8.0a1

Aurora: Mozilla/5.0 (Android; Linux armv71; rv:7.0a2) Gecko/20110803 Firefox/7.0a2 Fennec/7.0a2

still need to verify on fx6 beta5
Comment 10 Tony Chung [:tchung] 2011-08-04 13:58:55 PDT
Verified fix on beta 5: Mozilla/5.0 (Android; Linux armv71; rv:6.0) Gecko/20110804 Firefox/76.0 Fennec/6.0
Comment 11 Matt Brubeck (:mbrubeck) 2011-08-09 22:41:49 PDT
*** Bug 669797 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.