Closed Bug 675488 Opened 8 years ago Closed 8 years ago

Use the monochrome icons for New Event/Task

Categories

(Calendar :: Dialogs, defect)

x86
Windows 7
defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: Paenglab, Assigned: Paenglab)

Details

Attachments

(3 files, 2 obsolete files)

Follow the Thunderbird theme under Vista/Win7 and use monochrome icons also in New Event/Task dialog.
Attached patch Use monochrome icons (obsolete) — Splinter Review
This patch is using !important instead of using every different attribute (:hover, :hover:active, disabled etc.)
Assignee: nobody → richard.marti
Status: NEW → ASSIGNED
Attachment #549635 - Flags: ui-review?(nisses.mail)
Attachment #549635 - Flags: review?(philipp)
Attached image Patch in action
Attached patch Use monochrome icons v2 (obsolete) — Splinter Review
Made a selector more selective to not interfere with TB buttons.
Attachment #549635 - Attachment is obsolete: true
Attachment #549635 - Flags: ui-review?(nisses.mail)
Attachment #549635 - Flags: review?(philipp)
Attachment #554704 - Flags: ui-review?(nisses.mail)
Attachment #554704 - Flags: review?(philipp)
Attachment #554704 - Flags: review?(philipp) → review?(bv1578)
Comment on attachment 554704 [details] [diff] [review]
Use monochrome icons v2

There seems to be some issues with the customize dialog for that toolbar in that labels don't get icons (except for the save icon).
Attachment #554704 - Flags: ui-review?(nisses.mail) → ui-review-
I also wonder if we should set the toolbar to "Icons beside text" instead of "Icons and text", but that can be a separate bug, so I filed bug #687435 about that.
(In reply to Andreas Nilsson (:andreasn) from comment #4)
 
> There seems to be some issues with the customize dialog for that toolbar in
> that labels don't get icons (except for the save icon).

It seems a different problem (not caused by the patch). I can see it also in Lightning 1.0b4.
Maybe should another bug be opened?
(In reply to Decathlon from comment #7)
> (In reply to Andreas Nilsson (:andreasn) from comment #4)
>  
> > There seems to be some issues with the customize dialog for that toolbar in
> > that labels don't get icons (except for the save icon).
> 
> It seems a different problem (not caused by the patch). I can see it also in
> Lightning 1.0b4.
> Maybe should another bug be opened?

Oh, you're right. Changing this to ui-r+ and opening bug #687453 about the missing customize dialog icons.
Comment on attachment 554704 [details] [diff] [review]
Use monochrome icons v2

Giving ui-r+ since the issue I spotted was not caused by this patch.
Attachment #554704 - Flags: ui-review- → ui-review+
Comment on attachment 554704 [details] [diff] [review]
Use monochrome icons v2

Apart from my personal hate for the monochrome icons ;-), if we have to necessarily use them, the patch looks good.

A nit here (a semicolon is missing):

>+
>+#event-toolbox > menubar,
>+#event-toolbox > toolbar {
>+  -moz-appearance: none;
>+  border-style: none;
>+  background-color: transparent
>+}

and, just curiosity, why didn't you use directly the id selectors (#event-menubar and #event-toolbar) instead of the child selectors?

r+
Attachment #554704 - Flags: review?(bv1578) → review+
(In reply to Decathlon from comment #10)
> Comment on attachment 554704 [details] [diff] [review]
> Use monochrome icons v2
> 
> Apart from my personal hate for the monochrome icons ;-), if we have to
> necessarily use them, the patch looks good.
> 
> A nit here (a semicolon is missing):
> 
> >+
> >+#event-toolbox > menubar,
> >+#event-toolbox > toolbar {
> >+  -moz-appearance: none;
> >+  border-style: none;
> >+  background-color: transparent
> >+}
> 
> and, just curiosity, why didn't you use directly the id selectors
> (#event-menubar and #event-toolbar) instead of the child selectors?

Because I must be blind. I changed it in the patch for check-in.
Attachment #554704 - Attachment is obsolete: true
Attachment #561221 - Flags: ui-review+
Attachment #561221 - Flags: review+
Pushed to comm-central

<http://hg.mozilla.org/comm-central/rev/519ee522e7d1>
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Back ported to comm-beta:

<http://hg.mozilla.org/releases/comm-beta/rev/f30c88ade4fa>
Target Milestone: --- → 1.0b7
You need to log in before you can comment on or make changes to this bug.