Build places unconditionally

RESOLVED WONTFIX

Status

RESOLVED WONTFIX
7 years ago
8 months ago

People

(Reporter: matjk7, Assigned: matjk7)

Tracking

Trunk

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Comment hidden (empty)
(Assignee)

Updated

7 years ago
Depends on: 675500
(Assignee)

Comment 1

7 years ago
Created attachment 549657 [details] [diff] [review]
patch
Attachment #549657 - Flags: review?(khuey)

Updated

7 years ago
Assignee: nobody → matjk7
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Comment on attachment 549657 [details] [diff] [review]
patch

I don't think we want to do this ... I think there are non-Firefox Gecko consumers that don't use places.  Mak?
Attachment #549657 - Flags: feedback?(mak77)
I'm not sure either, most consumers I know use it, but my knowledge on that is incomplete, since I don't know all the projects around.  I'd suggest opening a thread in platform to get feedback before doing something like this.

Updated

7 years ago
Attachment #549657 - Flags: feedback?(mak77)
Whiteboard: [needs wider discussion]
(Assignee)

Comment 4

7 years ago
Fennec, Xulrunner, Seamonkey, Thunderbird, Calendar and Camino use places. Is there any other major Gecko consumer out there?
Ok, I didn't think Thunderbird did.
Whiteboard: [needs wider discussion]
Songbird I don't think uses places, but is based on XULRunner iirc. Same with Komodo, CC-ing Mook since I bet he would know on both counts.
(Assignee)

Comment 7

7 years ago
Actually Thunderbird doesn't seem to use Places either (http://mxr.mozilla.org/comm-central/source/mail/app/profile/all-thunderbird.js#627). I still think the build-time flag is useless though, since consumers can disable places with a simple pref.
(In reply to comment #7)
> Actually Thunderbird doesn't seem to use Places either
> (http://mxr.mozilla.org/comm-central/source/mail/app/profile/all-thunderbird.
> js#627). I still think the build-time flag is useless though, since
> consumers can disable places with a simple pref.

There are places interfaces that TB uses/needed last I checked, and why they actually build with PLACES.
bluegriffon, tom tom home use xulrunner as well
(In reply to comment #7)
> Actually Thunderbird doesn't seem to use Places either
> (http://mxr.mozilla.org/comm-central/source/mail/app/profile/all-thunderbird.
> js#627). I still think the build-time flag is useless though, since
> consumers can disable places with a simple pref.

I think the problem is not really with disabling it, but on libxul and xulrunner size, but I don't know if they care that much about those small improvements.
also even if you flip the pref the database is created regardless and with chunked growth (for fragmentation) its minimum size is 10MB, even if empty.
Thunderbird does indeed build places but have it disabled. iirc there's some stuff we use even with it disabled, but in any case, we've been moving our build closer to FF so we're fine with removing the compile option.

Comment 13

7 years ago
FWIW, as far as I can tell both Songbird and Komodo use the default here (i.e. build with Places).  http://timeline.songbirdnest.com/vendor/browser/trunk/xulrunner-1.9.2/mozconfigs/xulrunner.linux.release.i686.mozconfig for Songbird, and somewhere in http://grok.openkomodo.com/source/xref/openkomodo/trunk/mozilla/build.py#1483 for Komodo (sorry, that's such a mess...)

Instantbird also appears to use the default: http://lxr.instantbird.org/instantbird/source/tools/buildbot-configs/linux/mozconfig-release

It looks like BlueGriffon explicitly enables it for some reason: http://sources.disruptive-innovations.com/bluegriffon/trunk/config/mozconfig.linux
well, at this point I'd suggest to just announce the change in m.d.platform and if there are no complain for a couple weeks, proceed with it.
Comment on attachment 549657 [details] [diff] [review]
patch

r=me

I agree that we should announce this on .platform before landing.
Attachment #549657 - Flags: review?(khuey) → review+
fwiw, Mobile on Android wants to move to their own history implementation on top of the system history implementation, so they may want to actually undefine MOZ_PLACES.

I feel like this should go on the back burner till a decision is made.
(Assignee)

Comment 17

7 years ago
This is a really small cleanup so I don't really mind WONTFIXing it :)
Status: ASSIGNED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WONTFIX

Updated

8 months ago
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.