add "Open Link in New Background Window" to context menu

VERIFIED WONTFIX

Status

SeaMonkey
UI Design
--
enhancement
VERIFIED WONTFIX
17 years ago
9 years ago

People

(Reporter: ivo, Unassigned)

Tracking

({helpwanted})

Trunk
helpwanted
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
As I read a page with many references to other pages I usually do a lot of "Open
Link in New Window" and then minimize to carry on reading the page this link
originates. This extra minimizing should not be needed at all. So I make a
proposal to advance "Open Link in New Window" with this capability either adding
new command "Open Link in New Window as Minimized", with some keyboard
combination to achieve this behaviour or better both.

Comment 1

17 years ago
I like bug 56690 better (open link in a new window behind the current window).
This is not a "Viewer App" bug... (Viewer is a debug app we use.)
Assignee: rickg → ben
Component: Viewer App → XP Apps: GUI Features
QA Contact: rickg → sairuh
confirming [couldn't find a dup after a couple of searches]. i assume you want
to add this to the context menu?
Summary: Feature enhancement "Open Link in New Window as Minimized". → add "Open Link in New Window as Minimized" to context menu
really. this time.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 5

17 years ago
ivo@vendomar.ee, do you mind if I change this bug from
 add "Open Link in New Window as Minimized" to context menu 
to
 add "Open Linu in New Background Window" to context menu
to match bug 56690?  Or do would prefer for the new window to be minimized 
instead of behind the current window?
(Reporter)

Comment 6

17 years ago
Okey, maybe it is better to change this bug to "Open Link in New Background
Window" because "Open Link in New Window as Minimized"
 and "Open Link in New Background Window"
 behave almost the same.

Comment 7

17 years ago
Updating summary and making this depend on bug 56690, "Allow opening link in a 
new window behind current window".
Depends on: 56690
Summary: add "Open Link in New Window as Minimized" to context menu → add "Open Link in New Background Window" to context menu

Comment 8

17 years ago
*** Bug 73027 has been marked as a duplicate of this bug. ***

Updated

17 years ago
Depends on: 75338

Comment 9

16 years ago
<spam>

Multizilla (see multizilla.mozdev.org) has this and quite frankly I think it
would be a "killer feature" for mozilla itself to have.  Since installing
multizilla, I seldom use the normal "Open Link In New Window" at all.  Got my vote!

</spam>
helpwanted, nobody. 

Nice add-on for someone to do. 
Assignee: ben → nobody
Keywords: helpwanted

Comment 11

16 years ago
IMO, rather than cluttering up the context menus with Open Link in Background
Window and OPen Link in Background Tab, we should just make a pref for opening
links in new windows/tabs in the background, and make that pref apply regardless
of which tab vs. window.

Another idea is to have a modifier key, e.g., CTRL+SHIFT+CLICK or SHIFT+Middle
Click opens a link in the background.  This would naturally work with tabs as
well, since there's already a pref to make middle-click/ctrl+click use tabs.

Also, there is a bug filed already against me on opening tabs in the background.
 IMO these bugs are dups (or at the very least dependent).

Comment 12

16 years ago
I think this is an extremely low usage case scenario, certainly not worthy of
prefs, let alone more context menu items.  Modified clicks are much more
acceptable (though undiscoverable), but there are a limited number of them
available, and I'm not sure these are the cases we should use them on.

Comment 13

16 years ago
[Aufbau-P3]: Open-behind or Open-as-background would be nice for porn surfing,
especially on slow connections, since thubmnail galleries often take a while to
load.
Whiteboard: [Aufbau-P3]

Updated

16 years ago
Whiteboard: [Aufbau-P3]

Comment 14

16 years ago
*** Bug 107887 has been marked as a duplicate of this bug. ***

Comment 15

16 years ago
marking wontfix to adding this to the context menu.  Bug 56690 is for more 
hidden methods, e.g. keyboard modifiers.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WONTFIX
agreed, vrfy'ing
Status: RESOLVED → VERIFIED

Comment 17

14 years ago
*** Bug 234324 has been marked as a duplicate of this bug. ***
Product: Core → Mozilla Application Suite

Updated

9 years ago
Component: XP Apps: GUI Features → UI Design
You need to log in before you can comment on or make changes to this bug.