Crash [@ nsXULTreeAccessible::GetChildCount()

RESOLVED FIXED in mozilla8

Status

()

Core
Disability Access APIs
--
critical
RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: jon, Assigned: surkov)

Tracking

({crash})

5 Branch
mozilla8
x86
Windows XP
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Windows NT 5.1; rv:5.0) Gecko/20100101 Firefox/5.0
Build ID: 20110615151330

Steps to reproduce:

my firefox 5.0 crashes on random websites and i need to restart it over and over


Actual results:

browsesing to a website


Expected results:

it shouldn't crash all day long
(Reporter)

Comment 1

6 years ago
i have submitted bug after bug after bug and it doesn't seem like anything is happening

Comment 2

6 years ago
Please provide the crash report IDs from about:crashes from some of your recently submitted crashes.
(Reporter)

Comment 3

6 years ago
https://crash-stats.mozilla.com/report/index/81835928-14e5-4e38-ad99-3073c2110707

Updated

6 years ago
Crash Signature: [@ nsXULTreeAccessible::GetChildCount() ]

Comment 4

6 years ago
0 	xul.dll 	nsXULTreeAccessible::GetChildCount 	accessible/src/xul/nsXULTreeAccessible.cpp:452
1 	xul.dll 	nsAccessibleWrap::get_accChildCount 	accessible/src/msaa/nsAccessibleWrap.cpp:239
2 	rpcrt4.dll 	Invoke 	
3 	rpcrt4.dll 	NdrStubCall2 	
4 	rpcrt4.dll 	NdrClientMapCommFault 	
5 	oleaut32.dll 	oleaut32.dll@0x129ae 	
6 	ole32.dll 	SyncStubInvoke 	
7 	ole32.dll 	StubInvoke 	
8 	ole32.dll 	IFillLockBytes_FillAppend_Proxy 	
9 	ole32.dll 	COIDHashTable::Compare
Severity: normal → critical
Keywords: crash
Per http://bit.ly/p4W3hE this happens on Firefox 5/6/7/8 Branches.
Component: General → Disability Access APIs
Product: Firefox → Core
QA Contact: general → accessibility-apis
(Assignee)

Comment 6

6 years ago
Created attachment 550434 [details] [diff] [review]
patch
Assignee: nobody → surkov.alexander
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Attachment #550434 - Flags: review?(trev.saunders)
(Assignee)

Updated

6 years ago
Summary: i crash 8-10 times a day → Crash [@ nsXULTreeAccessible::GetChildCount()
Comment on attachment 550434 [details] [diff] [review]
patch


>+  if (!pcountChildren)
>+    return E_INVALIDARG;
>   *pcountChildren = 0;

blank line after return please.
Attachment #550434 - Flags: review?(trev.saunders) → review+
(Assignee)

Comment 8

6 years ago
(In reply to comment #7)

> >+  if (!pcountChildren)
> >+    return E_INVALIDARG;
> >   *pcountChildren = 0;
> 
> blank line after return please.

sure if you like
(Assignee)

Comment 9

6 years ago
inbound land http://hg.mozilla.org/integration/mozilla-inbound/rev/0e7f85aa8137
Whiteboard: [inbound]
(Assignee)

Comment 10

6 years ago
landed http://hg.mozilla.org/mozilla-central/rev/0e7f85aa8137
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Whiteboard: [inbound]
Target Milestone: --- → mozilla8
Duplicate of this bug: 682067
You need to log in before you can comment on or make changes to this bug.